Erstellen eines UML-Zustandsautomatendiagramms

Sie können ein UML-Zustandsautomatendiagramm erstellen, um das Verhalten eines Teils eines entworfenen Systems zu zeigen.

Wie ein Objekt auf ein Ereignis reagiert, hängt vom Zustand ab, in dem sich das Objekt befindet. In einem Zustandsautomatendiagramm wird die Reaktion eines Objekts auf externe Reize beschrieben. Das Objekt kann ein Computerprogramm, ein Gerät oder ein Prozess sein.

Beispiel für ein UML-Zustandsautomatendiagramm mit einem ATM-System.

Zuerst öffnen Sie das UML State Machine-Diagramm, das mit einer Zustandsautomatenschablone ausgestattet ist, die Shapes enthält, die dem UML 2.5- oder 2.0-Standard entsprechen, je nach Ihrer Version von Visio.

  1. Starten Sie Visio. Oder, wenn Sie bereits eine Datei geöffnet haben, klicken Sie auf Datei > Neu.

  2. Geben Sie im Feld Suchen den UML-Zustandsautomaten ein.

  3. Wählen Sie das DIAGRAMM UML State Machine aus.

  4. Wählen Sie im Dialogfeld entweder Metrische Einheiten oder US-Einheiten aus.

  5. Wählen Sie Erstellen aus.

  6. Das Diagramm wird geöffnet. Daraufhin sollte neben dem Diagramm das Fenster Shapes angezeigt werden. Wenn sie nicht angezeigt wird, wechseln Sie zu Ansicht > Aufgabenbereiche, und vergewissern Sie sich, dass Shapes ausgewählt ist. Wenn sie immer noch nicht angezeigt wird, klicken Sie auf der linken Seite auf die Schaltfläche Shapes-Fenster erweitern.

  7. Stellen Sie auf der Registerkarte Ansicht sicher, dass das Kontrollkästchen neben Verbindungspunkte aktiviert ist. Dadurch werden Verbindungspunkte angezeigt, wenn Sie mit dem Verbinden von Shapes beginnen.

  8. Ziehen Sie jetzt die Shapes, die Sie in Ihr Diagramm einbeziehen möchten, aus dem Fenster Shapes auf das Zeichenblatt. Wenn Sie die Textbezeichnungen umbenennen möchten, doppelklicken Sie auf die Bezeichnungen.

  1. Öffnen Sie Visio für das Web.

  2. Scrollen Sie im Katalog nach unten zur Zeile UML State Machine.

    Das erste Element in der Zeile stellt eine leere Vorlage sowie die Begleitschablone dar. Die anderen Elemente in der Zeile sind Beispieldiagramme, die einige Shapes bereits gezeichnet haben, damit Sie schnell beginnen können.

  3. Klicken Sie auf ein beliebiges Element, um die größere Vorschau anzuzeigen.

  4. Wenn Sie das Diagramm finden, das Sie verwenden möchten, klicken Sie auf die Schaltfläche Erstellen.

    Das neue Diagramm mit der zugehörigen Schablone wird in Ihrem Browser geöffnet. Sie können mit dem Hinzufügen von Shapes zu Einem Diagramm beginnen.

In Visio 2010 gibt es ein Zustandsdiagramm anstelle eines Zustandsautomatendiagramms. Weitere Informationen finden Sie unter Erstellen eines UML-Zustandsdiagramms.

Siehe auch

UML-Diagramme in Visio

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×