Zellen

Importieren oder Exportieren von Textdateien (TXT oder CSV)

Importieren oder Exportieren von Textdateien (TXT oder CSV)

Es gibt zwei Möglichkeiten, Daten aus einer Textdatei mit Excel zu importieren: Sie können sie in Excel öffnen, oder Sie können sie als Externer Datenbereich. Wenn Sie Daten aus Excel in eine Textdatei exportieren möchten, verwenden Sie den Befehl "Speichern unter", und ändern Sie den Dateityp aus dem Dropdownmenü.

Es gibt zwei häufig verwendete Textdateiformate:

  • Durch Trennzeichen getrennte Textdateien (TXT), in denen die einzelnen Textfelder üblicherweise durch TAB-Zeichen (ASCII-Zeichencode 009) getrennt sind.

  • Textdateien mit kommagetrennten Werten (CSV), in denen die einzelnen Textfelder üblicherweise durch Kommas (,) getrennt sind.

Sie können das Trennzeichen ändern, das in durch Trennzeichen getrennten Textdateien und in CSV-Textdateien verwendet wird. Dies kann erforderlich sein, um sicherzustellen, dass der Import- oder Exportvorgang in der gewünschten Weise abläuft.

Hinweis: Sie können bis zu 1.048.576 Zeilen und 16.384 Spalten importieren oder exportieren.

Importieren einer Textdatei durch Öffnen der Datei in Excel

Sie können eine Textdatei, die Sie in einem anderen Programm als Eine Excel-Arbeitsmappe erstellt haben, mithilfe des Befehls "Öffnen" öffnen. Durch das Öffnen einer Textdatei in Excel wird das Format der Datei nicht geändert . Dies wird in der Excel-Titelleiste angezeigt, in der der Name der Datei die Dateinamenerweiterung (z. B. TXT oder CSV) beibehalte.

  1. Wechseln Sie zu ">Öffnen", und navigieren Sie zu dem Speicherort, der die Textdatei enthält.

  2. Wählen Sie "Textdateien" in der Dropdownliste "Dateityp" im Dialogfeld "Öffnen" aus.

  3. Suchen Sie die Textdatei, die Sie öffnen möchten, und doppelklicken Sie darauf.

    • Handelt es sich bei der Datei um eine Textdatei (TXT), wird von Excel der Textimport-Assistent gestartet. Wenn Sie diese Schritte beendet haben, klicken Sie auf Fertig stellen, um den Importvorgang abzuschließen. Weitere Informationen zu Trennzeichen und erweiterten Optionen finden Sie im Textimport-Assistenten.

    • Handelt es sich bei der Datei um eine CSV-Datei, wird sie von Excel automatisch geöffnet, und die Daten werden in einer neuen Arbeitsmappe angezeigt.

      Hinweis: Wenn in Excel eine CSV-Datei geöffnet wird, werden die aktuellen Standardeinstellungen für das Datenformat verwendet, um zu interpretieren, wie die einzelnen Datenspalten importiert werden müssen. Wenn Sie beim Konvertieren von Spalten in unterschiedliche Datenformate ein größeres Maß an Flexibilität wünschen, können Sie den Textimport-Assistenten verwenden. Beispielsweise kann das Format einer Datenspalte in einer CSV-Datei MTJ sein, das Standarddatenformat in Excel jedoch TMJ, oder Sie möchten eine Spalte, die Zahlen mit führenden Nullen enthält, in Text konvertieren, sodass die führenden Nullen beibehalten werden. Wenn Sie erzwingen möchten, dass Excel den Importtext-Assistenten ausführen kann, können Sie die Dateinamenerweiterung von CSV in TXT ändern, bevor Sie sie öffnen, oder Sie können eine Textdatei importieren, indem Sie eine Verbindung mit ihr herstellen (weitere Informationen finden Sie im folgenden Abschnitt).

Importieren einer Textdatei durch Herstellen einer Verbindung mit der Datei (Power Query)

Sie können Daten aus einer Textdatei in ein vorhandenes Arbeitsblatt importieren.

  1. Klicken Sie auf der Registerkarte "Daten" in der & "Daten transformieren" auf "Aus Text/CSV".

  2. Suchen Sie im Dialogfeld "Daten importieren" die Textdatei, die Sie importieren möchten, doppelklicken Sie darauf, und klicken Sie dann auf "Importieren".

  3. Im Dialogfeld "Vorschau" gibt es mehrere Optionen:

    • Wählen Sie "Laden" aus, wenn Sie die Daten direkt in ein neues Arbeitsblatt laden möchten.

    • Wählen Sie alternativ "Laden in" aus, wenn Sie die Daten in eine Tabelle, eine PivotTable/ein PivotChart oder ein vorhandenes/neues Excel-Arbeitsblatt laden möchten, oder erstellen Sie einfach eine Verbindung. Sie können ihre Daten auch dem Datenmodell hinzufügen.

    • Wählen Sie "Daten transformieren" aus, wenn Sie die Daten in Power Query laden möchten, und bearbeiten Sie sie, bevor Sie sie in Excel anzeigen.

Wenn Excel eine bestimmte Datenspalte nicht in das von Ihnen zu verwendende Format konvertiert, können Sie die Daten nach dem Import konvertieren. Weitere Informationen finden Sie unter Konvertieren von Zahlen, die als Text gespeichert wurden und Konvertieren von Datumsangaben, die als Text gespeichert wurden, in Datumswerte.

Exportieren von Daten in eine Textdatei durch Speichern der Daten

Mit dem Befehl Speichern unter können Sie ein Excel-Arbeitsblatt in eine Textdatei konvertieren.

  1. Wechseln Sie zu Datei > Speichern unter.

  2. Klicken Sie auf Durchsuchen.

  3. Wählen Sie im Dialogfeld "Speichern unter" unter dem Feld "Dateityp" das Textdateiformat für das Arbeitsblatt aus. Klicken Sie z. B. auf "Text" (Tabstopp-getrennt) oder "CSV" (durch Trennzeichen getrennt).

    Hinweis: Die verschiedenen Formate unterstützen unterschiedliche Featuregruppen. Weitere Informationen zu den Featuregruppen, die von den verschiedenen Textdateiformaten unterstützt werden, finden Sie unter Dateiformate, die von Excel unterstützt werden.

  4. Navigieren Sie zu dem Speicherort, an dem die neue Textdatei gespeichert werden soll, und klicken Sie dann auf Speichern.

  5. Sie werden in einem Dialogfeld darauf hingewiesen, dass nur das aktuelle Arbeitsblatt in der neuen Datei gespeichert wird. Wenn Sie sicher sind, dass das aktuelle Arbeitsblatt als Textdatei gespeichert werden soll, klicken Sie auf OK. Sie können weitere Arbeitsblätter als separate Textdateien speichern, indem Sie dieses Verfahren für jedes einzelne Arbeitsblatt wiederholen.

    Möglicherweise wird unterhalb des Menübands auch eine Warnung angezeigt, dass einige Features möglicherweise verloren gehen, wenn Sie die Arbeitsmappe im CSV-Format speichern.

Weitere Informationen zum Speichern von Dateien in anderen Formaten finden Sie unter Speichern einer Arbeitsmappe in einem anderen Dateiformat.

Importieren einer Textdatei durch Herstellen einer Verbindung mit der Datei

Sie können Daten aus einer Textdatei in ein vorhandenes Arbeitsblatt importieren.

  1. Klicken Sie auf die Zelle, in die die Daten aus der Textdatei eingefügt werden sollen.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Externe Daten abrufen auf Aus Text.

  3. Suchen Sie im Dialogfeld "Daten importieren" die Textdatei, die Sie importieren möchten, doppelklicken Sie darauf, und klicken Sie dann auf "Importieren".

    Folgen Sie den Anweisungen des Textimport-Assistenten. Klicken Sie Schaltflächensymbol Seite des Textimport-Assistenten auf "Hilfe", um weitere Informationen zur Verwendung des Assistenten zu erhalten. Wenn Sie die Schritte im Assistenten beendet haben, klicken Sie auf Fertig stellen, um den Importvorgang abzuschließen.

  4. Führen Sie im Dialogfeld Daten importieren folgende Schritte aus:

    1. Führen Sie unter Wo sollen die Daten eingefügt werden? eine der folgenden Aktionen aus:

      • Wenn Sie die Daten an die ausgewählte Position zurückgeben möchten, klicken Sie auf Vorhandenes Arbeitsblatt.

      • Wenn Sie die Daten an die obere linke Ecke eines neuen Arbeitsblatts zurückgeben möchten, klicken Sie auf Neues Arbeitsblatt.

    2. Klicken Sie optional auf Eigenschaften, um die Aktualisierungs-, Formatierungs- und Layoutoptionen für die importierten Daten festzulegen.

    3. Klicken Sie auf OK.

      Der externe Datenbereich wird in Excel an der angegebenen Position eingefügt.

Wenn eine Datenspalte von Excel nicht in das gewünschte Format konvertiert wird, können Sie die Daten nach dem Import konvertieren. Weitere Informationen finden Sie unter Konvertieren von Zahlen, die als Text gespeichert wurden und Konvertieren von Datumsangaben, die als Text gespeichert wurden, in Datumswerte.

Exportieren von Daten in eine Textdatei durch Speichern der Daten

Mit dem Befehl Speichern unter können Sie ein Excel-Arbeitsblatt in eine Textdatei konvertieren.

  1. Wechseln Sie zu Datei > Speichern unter.

  2. Das Dialogfeld Speichern unter wird angezeigt.

  3. Wählen Sie im Feld Dateityp das Textdateiformat für das Arbeitsblatt aus.

    • Klicken Sie z. B. auf Text (Tabstopp-getrennt) oder CSV (Trennzeichen-getrennt).

    • Hinweis: Die verschiedenen Formate unterstützen unterschiedliche Featuregruppen. Weitere Informationen zu den Featuregruppen, die von den verschiedenen Textdateiformaten unterstützt werden, finden Sie unter Dateiformate, die von Excel unterstützt werden.

  4. Navigieren Sie zu dem Speicherort, an dem die neue Textdatei gespeichert werden soll, und klicken Sie dann auf Speichern.

  5. Sie werden in einem Dialogfeld darauf hingewiesen, dass nur das aktuelle Arbeitsblatt in der neuen Datei gespeichert wird. Wenn Sie sicher sind, dass das aktuelle Arbeitsblatt als Textdatei gespeichert werden soll, klicken Sie auf OK. Sie können weitere Arbeitsblätter als separate Textdateien speichern, indem Sie dieses Verfahren für jedes einzelne Arbeitsblatt wiederholen.

  6. In einem zweiten Dialogfeld werden Sie darauf hingewiesen, dass Ihr Arbeitsblatt Features enthalten kann, die von Textdateiformaten nicht unterstützt werden. Wenn Sie nur die Daten aus dem Arbeitsblatt in der neuen Textdatei speichern möchten, klicken Sie auf Ja. Wenn Sie nicht sicher sind und wissen möchten, welche Excel-Features von Textdateiformaten nicht unterstützt werden, klicken Sie auf Hilfe, um weitere Informationen zu erhalten.

Weitere Informationen zum Speichern von Dateien in anderen Formaten finden Sie unter Speichern einer Arbeitsmappe in einem anderen Dateiformat.

Die Art und Weise, wie Sie das Trennzeichen beim Importieren ändern, hängt davon ab, wie Sie den Text importieren.

  • Wenn Sie "Get & Transform Data > From Text/CSV"verwenden, wählen Sie, nachdem Sie die Textdatei ausgewählt und auf "Importieren"geklickt haben, ein Zeichen aus der Liste unter "Trennzeichen" aus. Die Auswirkungen der neuen Auswahl werden sofort in der Datenvorschau angezeigt, sodass Sie sicher sein können, dass Sie die von Ihnen getroffene Auswahl treffen, bevor Sie fortfahren.

  • Wenn Sie zum Importieren einer Textdatei den Textimport-Assistenten verwenden, können Sie das Trennzeichen ändern, das für den Importvorgang in Schritt 2 des Textimport-Assistenten verwendet wird. In diesem Schritt können Sie außerdem ändern, wie aufeinanderfolgende Trennzeichen (z. B. aufeinanderfolgende Anführungszeichen) behandelt werden.

    Weitere Informationen zu Trennzeichen und erweiterten Optionen finden Sie im Textimport-Assistenten.

Wenn Sie beim Speichern als CSV ein Semikolon als Standardlistentrennzeichen verwenden möchten, die Änderung jedoch auf Excel beschränken müssen, sollten Sie erwägen, das standardmäßige Dezimaltrennzeichen in ein Komma zu ändern. Dadurch wird Excel dazu zwingt, ein Semikolon für das Listentrennzeichen zu verwenden. Dies ändert natürlich auch die Art und Weise, in der Dezimalzahlen angezeigt werden, daher sollten Sie auch das Tausendertrennzeichen ändern, um Verwirrung zu vermeiden.

  1. Löschen Sie "Excel> optionen"> Optionen "Erweiterte>", und verwenden Sie Systemtrennzeichen.

  2. Legen Sie das Dezimaltrennzeichenauf "," (ein Komma)

  3. Legen Sie "Tausendertrennzeichen" auf "." (einen Zeitraum) ein.

Wenn Sie eine Arbeitsmappe als CSV-Datei speichern, ist das Standardmäßige Listentrennzeichen (Trennzeichen) ein Komma. Sie können dies mithilfe der Einstellungen für "Windows-Region" in ein anderes Trennzeichen ändern. 

Achtung: Das Ändern der Einstellung für Windows hat Auswirkungen auf alle Anwendungen auf dem Computer. Wenn Sie nur das Trennzeichen für Excel ändern möchten, lesen Sie "Ändern des Standardmäßigen Listentrennzeichens zum Speichern von Dateien als Text (CSV)" in Excel.

  1. Klicken Sie in Microsoft Windows 10 mit der rechten Maustaste auf die Schaltfläche "Start", und klicken Sie dann auf "Einstellungen".

  2. Klicken Sie & "Sprache"und dann im linken Bereich auf "Region".

  3. Klicken Sie im Hauptbereich unter "Regionale Einstellungen"auf "Zusätzliche Datums-, Uhrzeit- und Regionaleinstellungen".

  4. Klicken Sie unter "Region"auf "Datums-, Uhrzeit- oder Zahlenformat ändern".

  5. Klicken Sie im Dialogfeld "Region" auf der Registerkarte "Format" auf "Weitere Einstellungen".

  6. Geben Sie im Dialogfeld "Format anpassen" auf der Registerkarte "Zahlen" ein Zeichen ein, das als neues Trennzeichen im Listentrennfeld verwendet werden soll.

  7. Klicken Sie zweimal auf OK

  1. Klicken Sie in Microsoft Windows auf Start und dann auf Systemsteuerung.

  2. Klicken Sie unter Zeit, Sprache und Region auf Datums-, Uhrzeit- oder Zahlenformat ändern.

  3. Klicken Sie im Dialogfeld "Region" auf der Registerkarte "Format" auf "Weitere Einstellungen".

  4. Geben Sie im Dialogfeld "Format anpassen" auf der Registerkarte "Zahlen" ein Zeichen ein, das als neues Trennzeichen im Listentrennfeld verwendet werden soll.

  5. Klicken Sie zweimal auf OK

Hinweis:  Nachdem Sie das Listentrennzeichen für Ihren Computer geändert haben, wird das neue Zeichen von allen Programmen als Listentrennzeichen verwendet. Mithilfe desselben Verfahrens können Sie das Zeichen auch wieder in das Standardzeichen zurück ändern.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Siehe auch

Importieren von Daten aus externen Datenquellen (Power Query)

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×