Mit Power Query (in Excel als "& Transformieren abrufen" bezeichnet) können Sie externe Daten importieren oder eine Verbindung mit diesen Herstellen einer Verbindung herstellen und diese Daten dann so gestalten, dass sie beispielsweise eine Spalte entfernen, einen Datentyp ändern oder Tabellen auf eine Weise zusammenführen, die Ihren Anforderungen entspricht. Anschließend können Sie Ihre Abfrage in Excel laden, um Diagramme und Berichte zu erstellen. In regelmäßigen Abständen können Sie die Daten aktualisieren, um sie auf dem neuesten Stand zu halten. Power Query ist in drei Excel-Anwendungen verfügbar: Excel für Windows, Excel für Mac und Excel für das Web. Eine Zusammenfassung aller Power Query Hilfethemen finden Sie in Power Query der Excel-Hilfe.

Es gibt vier Phasen für die Verwendung von Power Query.

Power Query common steps

  1. Verbinden    Herstellen von Verbindungen mit Daten in der Cloud, in einem Dienst oder lokal

  2. Verwandeln    Shape-Daten für Ihre Anforderungen, während die ursprüngliche Quelle unverändert bleibt

  3. Kombinieren    Integrieren von Daten aus mehreren Quellen, um eine eindeutige Ansicht in die Daten zu erhalten

  4. Laden   Führen Sie die Abfrage aus, laden Sie sie in ein Arbeitsblatt oder Datenmodell, und aktualisieren Sie sie regelmäßig.

In den folgenden Abschnitten werden die einzelnen Phasen ausführlicher behandelt. 

Sie können Power Query verwenden, um in eine einzelne Datenquelle, z. B. eine Excel-Arbeitsmappe, oder in mehrere Datenbanken, Feeds oder Dienste zu importieren, die über die Cloud verteilt sind. Datenquellen umfassen Daten aus dem Web, Dateien, Datenbanken, Azure  oder sogar Excel-Tabellen in der aktuellen Arbeitsmappe. Mit Power Query können Sie dann alle diese Datenquellen zusammenbringen, indem Sie Ihre eigenen einzigartigen Transformationen und Kombinationen verwenden, um Erkenntnisse zu gewinnen, die Sie andernfalls nicht gesehen hätten. 

Nach dem Importieren können Sie die Daten aktualisieren, um Ergänzungen, Änderungen und Löschungen aus der externen Datenquelle zu erhalten. Weitere Informationen finden Sie unter Aktualisieren einer externen Datenverbindung in Excel.  

Importieren von Befehlen auf der Benutzeroberfläche

Das Transformieren von Daten bedeutet, dass sie in irgendeiner Weise geändert werden, um Ihre Datenanalyseanforderungen zu erfüllen. Sie können z. B. eine Spalte entfernen, einen Datentyp ändern oder Zeilen filtern. Jeder dieser Vorgänge ist eine Datentransformation. Dieser Prozess zum Anwenden von Transformationen (und Kombinieren) auf eine oder mehrere Datensätze wird auch als Modellieren von Daten bezeichnet.

Stellen Sie sich das so vor. Eine Vase beginnt als Tonklumpen, den man zu etwas Praktischem und Schönem formt. Die Daten sind identisch. Es muss zu einer Tabelle geformt werden, die für Ihre Anforderungen geeignet ist und attraktive Berichte und Dashboards ermöglicht.

Power Query verwendet ein dediziertes Fenster namens Power Query-Editor, um Datentransformationen zu vereinfachen und anzuzeigen. Sie können die Power Query-Editor öffnen, indem Sie im Befehl "Daten abrufen" in der Gruppe "& Daten transformieren" die Option "Abfrage-Editor starten" auswählen. Sie wird jedoch auch geöffnet, wenn Sie eine Verbindung mit einer Datenquelle herstellen, eine neue Abfrage erstellen oder eine Abfrage laden.

Benutzeroberfläche für Abfrageeinstellungen

Die Power Query-Editor verfolgt alles, was Sie mit den Daten tun, indem jede Transformation oder jeder Schritt aufgezeichnet und gekennzeichnet wird, die Sie auf die Daten anwenden. Unabhängig davon, ob es sich bei der Transformation um eine Datenverbindung, eine Spaltenentfernung, eine Zusammenführung oder eine Änderung des Datentyps handelt, können Sie jede Transformation im Abschnitt ANGEWENDETE SCHRITTE im Bereich "Abfrageeinstellungen" anzeigen und ändern.

Es gibt viele Transformationen, die Sie über die Benutzeroberfläche vornehmen können. Jede Transformation wird als Schritt im Hintergrund aufgezeichnet. Sie können sogar ihre eigenen Schritte mithilfe der Power Query M-Sprache in der Erweiterter Editor ändern und schreiben.

Alle Transformationen, die Sie auf Ihre Datenverbindungen anwenden, bilden zusammen eine Abfrage, die eine neue Darstellung der ursprünglichen (und unveränderten) Datenquelle ist. Wenn Sie eine Abfrage aktualisieren, wird jeder Schritt automatisch ausgeführt. Abfragen ersetzen die Notwendigkeit, Daten in Excel manuell zu verbinden und zu formen.

Sie können mehrere Abfragen in Ihrer Excel-Arbeitsmappe kombinieren, indem Sie sie anfügen oder zusammenführen. Die Vorgänge "Anfügen" und "Zusammenführen" werden für jede Abfrage mit tabellarischer Form ausgeführt und sind unabhängig von den Datenquellen, aus denen die Daten stammen.

Anfügen   Ein Anfügevorgang erstellt eine neue Abfrage, die alle Zeilen aus einer ersten Abfrage, gefolgt von allen Zeilen aus einer zweiten Abfrage, enthält. Sie können zwei Arten von Anfügevorgängen ausführen:

  • Zwischenanfüge    Erstellt eine neue Abfrage für jeden Anfügevorgang.

  • Inlineanfügen    Fügt Daten an die vorhandene Abfrage an, bis Sie ein Endgültiges Ergebnis erreicht haben.

Konzept der Anfügeabfragen

Zusammenführen    Ein Zusammenführungsvorgang erstellt eine neue Abfrage aus zwei vorhandenen Abfragen. Diese eine Abfrage enthält alle Spalten aus einer Primärtabelle, wobei eine Spalte als Navigationsverknüpfung zu einer verknüpften Tabelle dient. Die verknüpfte Tabelle enthält alle Zeilen, die jeder Zeile aus einem gemeinsamen Spaltenwert in der Primärtabelle entsprechen. Darüber hinaus können Sie Spalten aus einer verknüpften Tabelle in einer Primärtabelle erweitern oder hinzufügen.

Konzept "Abfragen zusammenführen"

Es gibt zwei Hauptmöglichkeiten zum Laden von Abfragen in Ihre Arbeitsmappe:

  • Im Power Query-Editor können Sie die Befehle "Schließen" und "Laden" in der Gruppe "Schließen" auf der Registerkarte "Start" verwenden.

  • Im Bereich "Excel-Arbeitsmappenabfragen" (Abfragen & Verbindungen auswählen) können Sie mit der rechten Maustaste auf eine Abfrage klicken und "Laden in" auswählen.

Sie können ihre Ladeoptionen auch optimieren, indem Sie im Dialogfeld "Abfrageoptionen " ( Datei > Optionen und Einstellungen > Abfrageoptionen auswählen) auswählen, wie Ihre Daten angezeigt werden sollen und wo sie geladen werden sollen, entweder in einem Arbeitsblatt oder in einem Datenmodell (bei dem es sich um eine relationale Datenquelle mehrerer Tabellen handelt, die sich in einer Arbeitsmappe befinden). 

Seit mehr als zehn Jahren wird Power Query in Excel für Windows unterstützt. Jetzt erweitert Excel Power Query Unterstützung für Excel für Mac und fügt Excel für das Web Unterstützung hinzu. Dies bedeutet, dass wir Power Query auf drei wichtigen Plattformen zur Verfügung stellen und die Beliebtheit und Funktionalität von Power Query bei Excel-Kunden demonstrieren. Achten Sie auf zukünftige Ankündigungen in der Microsoft 365-Roadmapund den Neuerungen in Excel für Microsoft 365.

Die Integration von Get & Transform Data (jetzt als Power Query bezeichnet) in Excel hat im Laufe der Jahre eine Reihe von Änderungen durchlaufen. 

Excel 2010 und 2013 für Windows

In Excel 2010 für Windows haben wir zuerst Power Query eingeführt und es war als kostenloses Add-In verfügbar, das von hier heruntergeladen werden konnte: Laden Sie das Power Query-Add-In herunter. Nach der Aktivierung war Power Query Funktionalität über die Registerkarte Power Query im Menüband verfügbar.

Excel 2013 Power Query Menüband

Microsoft 365

Wir haben Power Query aktualisiert, um die primäre Erfahrung in Excel für das Importieren und Bereinigen von Daten zu sein. Sie können auf die Power Query Datenimport-Assistenten und -Tools über die Gruppe "& Daten transformieren" auf der Registerkarte "Daten" des Excel-Menübands zugreifen.

Excel 2016 Power Query Menüband

Diese Erfahrung umfasste erweiterte Datenimportfunktionen, neu angeordnete Befehle auf der Registerkarte " Daten ", einen neuen Bereich " Abfragen & Verbindungsseite " und die fortlaufende Möglichkeit, Daten auf leistungsstarke Weise zu formen, indem Sie Sortieren, Ändern von Datentypen, Aufteilen von Spalten, Aggregieren der Daten usw. ermöglichen.

Diese neue Oberfläche ersetzte auch die älteren Assistenten für den Datenimport unter dem Befehl "Daten " in der Gruppe "Externe Daten abrufen ". Auf sie kann jedoch weiterhin über das Dialogfeld "Excel-Optionen " zugegriffen werden (Wählen Sie "Datei > Optionen > Daten > Assistenten zum Importieren älterer Daten anzeigen") aus.

Excel 2016 und 2019 für Windows

Wir haben die gleiche Get & Transform Data-Erfahrung basierend auf der Power Query-Technologie wie die von Microsoft 365 hinzugefügt.

Excel für Microsoft 365 für Mac

2019 haben wir uns auf die Reise zur Unterstützung Power Query in Excel für Mac begeben. Seitdem haben wir die Möglichkeit hinzugefügt, Power Query Abfragen aus TXT-, CSV-, XLSX-, JSON- und XML-Dateien zu aktualisieren. Wir haben auch die Möglichkeit hinzugefügt, Daten aus SQL Server und aus Tabellen & Bereichen in der aktuellen Arbeitsmappe zu aktualisieren.

Im Oktober 2019 haben wir die Möglichkeit hinzugefügt, vorhandene Power Query Abfragen zu aktualisieren und VBA zum Erstellen und Bearbeiten neuer Abfragen zu verwenden.

Im Januar 2021 haben wir Unterstützung für die Aktualisierung von Power Query Abfragen aus OData- und SharePoint-Quellen hinzugefügt.

Weitere Informationen finden Sie unter Verwenden von Power Query in Excel für Mac.

Hinweis   Es gibt keine Unterstützung für Power Query auf Excel 2016 und Excel 2019 für Mac.

Data Catalog Verfrühung

Mit dem Data Catalog können Sie Ihre freigegebenen Abfragen anzeigen und dann auswählen, um sie in der aktuellen Arbeitsmappe zu laden, zu bearbeiten oder anderweitig zu verwenden. Dieses Feature wurde schrittweise veraltet:

  • Am 1. August 2018 haben wir das Onboarding neuer Kunden in die Data Catalog eingestellt.

  • Am 3. Dezember 2018 konnten Benutzer keine neuen oder aktualisierten Abfragen im Data Catalog freigeben.

  • Am 4. März 2019 funktionierte die Data Catalog nicht mehr. Nach diesem Datum wird empfohlen, Ihre freigegebenen Abfragen herunterzuladen, damit Sie sie weiterhin außerhalb der Data Catalog verwenden können, indem Sie die Option "Öffnen" im Aufgabenbereich "Meine Data Catalog Abfragen" verwenden.

Power Query-Add-In-Veraltet

Anfang Sommer 2019 haben wir das Power Query-Add-In, das für Excel 2010 und 2013 für Windows erforderlich ist, offiziell veraltet. Mit freundlicher Genehmigung können Sie das Add-In weiterhin verwenden, dies kann sich jedoch zu einem späteren Zeitpunkt ändern.

Facebook-Datenconnector eingestellt

Der Import und die Aktualisierung von Daten aus Facebook in Excel funktionierten im April 2020 nicht mehr. Alle Facebook-Verbindungen, die vor diesem Datum erstellt wurden, funktionieren nicht mehr. Wir empfehlen, vorhandene Power Query Abfragen, die den Facebook-Connector verwenden, so schnell wie möglich zu überarbeiten oder zu entfernen, um unerwartete Ergebnisse zu vermeiden.

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Office Insidern beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×