Kombinieren von Dateien in einem Ordner mit Binärdateien kombinieren (Power Query)

Verwenden Sie die Excel-& Transformation (Power Query), um mehrere Dateien mit demselben Schema aus einem einzelnen Ordner in einer einzelnen Tabelle zu kombinieren. Ein Beispiel hierfür ist das Kombinieren von Budget-Arbeitsmappen für mehrere Abteilungen, in denen die Spalten zwar identisch, Zeilenanzahl und Werte in den einzelnen Arbeitsmappen jedoch unterschiedlich sind.

Um mit dem Kombinieren mehrerer Dateien zu beginnen, müssen Sie zunächst sicherstellen, dass sich alle zu kombinierenden Dateien in einem einzigen Dateiordner befinden.

Hinweis: Unterstützt werden Excel-, Text-, CSV-, JSON-, XML- und Access-Dateien.

  1. Klicken Sie auf die Registerkarte Daten , und rufen Sie dann Daten > aus Datei > aus dem Ordner ab. Wenn die Schaltfläche " Daten abrufen " nicht angezeigt wird, klicken Sie auf neue Abfrage > aus Datei > aus Ordner

    Kombinieren von Binärdateien aus Datei > aus Ordner Option

  2. Klicken Sie auf die Schaltfläche Durchsuchen, um nach Ihrem Ordner zu suchen.

    Es wird eine Liste der Dateien im Ordner angezeigt. In diesem Fall haben wir 4 Excel-Arbeitsmappen geladen. Nachdem Sie überprüft haben, dass alle gewünschten Dateien aufgelistet sind, wählen Sie die Option & laden kombinieren aus.

    Kombinieren von Binärdateien kombinieren und Option laden
  3. Jede Datei wird analysiert, und das richtige Dateiformat (z. B. Text, Excel oder JSON) wird bestimmt. In diesem Fall wird eine Liste der Arbeitsblätter aus der ersten Excel-Arbeitsmappe angezeigt. Wählen Sie das Arbeitsblatt aus, das Sie verwenden möchten, und klicken Sie auf OK. Der Transformationsprozess "Binärdateien kombinieren" erstellt dann automatisch eine Abfrage, um die Daten aus jeder Datei zu konsolidieren und die Ergebnisse in einem einzigen Arbeitsblatt anzuzeigen.

    Dialogfeld "Binärdateien kombinieren" mit verfügbaren Excel-Arbeitsblättern zur Auswahl des primären Konsolidierungsziels
  4. Wenn sich die ursprünglichen Datendateien ändern, können Sie die importierten Daten immer aktualisieren. Klicken Sie auf eine beliebige Stelle innerhalb des Datenbereichs, und wechseln Sie dann zu Abfrage Tools > Aktualisieren. Darüber hinaus können Sie auf einfache Weise zusätzliche Transformations-oder Extraktions Schritte anwenden, indem Sie die automatisch erstellte Beispielabfrage ändern, ohne sich Gedanken über das ändern oder Erstellen zusätzlicher Funktions Abfrageschritte machen zu müssen. Alle Änderungen an der Musterabfrage werden in der verknüpften Funktions Abfrage automatisch generiert.

Um mit dem Kombinieren mehrerer Dateien zu beginnen, müssen Sie zunächst sicherstellen, dass sich alle zu kombinierenden Dateien in einem einzigen Dateiordner befinden.

Hinweis: Unterstützt werden Excel-, Text-, CSV-, JSON-, XML- und Access-Dateien.

  1. Klicken Sie auf die Registerkarte Power Query und dann auf Datei > aus Ordner.

    Power Query > aus Datei > aus Ordneroptionen
  2. Klicken Sie auf die Schaltfläche Durchsuchen, um nach Ihrem Ordner zu suchen.

    Es wird eine Liste der Dateien im Ordner angezeigt. Wählen Sie die Option Bearbeiten aus, um den Abfrage-Editor zu öffnen. In diesem Fall haben wir 4 Excel-Arbeitsmappen geladen.

    Dialogfeld "Binärdateien kombinieren" mit den zu kombinierenden Dateien
  3. Nachdem Sie überprüft haben, dass alle gewünschten Dateien aufgeführt sind, klicken Sie in der Spalte Inhalt auf die Schaltfläche Binärdateien kombinieren.

    Drücken Sie in der Spalte "Inhalt" der Abfrage oder im Power Query-Menüband im Abschnitt "Kombinieren" auf die Schaltfläche "Binärdateien kombinieren".
  4. Jede Datei wird analysiert, und das richtige Dateiformat (z. B. Text, Excel oder JSON) wird bestimmt. In diesem Fall wird eine Liste der Arbeitsblätter aus der ersten Excel-Arbeitsmappe angezeigt. Wählen Sie das Arbeitsblatt aus, das Sie verwenden möchten, und klicken Sie auf OK.

    Dialogfeld "Binärdateien kombinieren" mit verfügbaren Excel-Arbeitsblättern zur Auswahl des primären Konsolidierungsziels
  5. Durch den Transformationsprozess beim Kombinieren der Binärdateien wird automatisch eine Abfrage erstellt, um die Daten der einzelnen Dateien zu konsolidieren und eine Vorschau anzuzeigen. Wenn Sie mit dem Ergebnis zufrieden sind, klicken Sie auf Schließen und Laden.

    Vorschau im Dialogfeld "Binärdateien kombinieren" Drücken Sie "Schließen & laden", um die Ergebnisse zu übernehmen und sie in Excel zu importieren.

    Durch den Kombinationsprozess der Binärdateien werden die aufgelisteten Arbeitsblätter in einem einzigen Arbeitsblatt konsolidiert.

  6. Wenn sich die ursprünglichen Datendateien ändern, können Sie die importierten Daten immer aktualisieren. Klicken Sie auf eine beliebige Stelle innerhalb des Datenbereichs, und wechseln Sie dann zu Abfrage Tools > Aktualisieren. Darüber hinaus können Sie auf einfache Weise zusätzliche Transformations-oder Extraktions Schritte anwenden, indem Sie die automatisch erstellte Beispielabfrage ändern, ohne sich Gedanken über das ändern oder Erstellen zusätzlicher Funktions Abfrageschritte machen zu müssen. Alle Änderungen an der Musterabfrage werden in der verknüpften Funktions Abfrage automatisch generiert.

Bekannte Probleme

Beim Laden der Prozedur "Binärdateien kombinieren" in Excel wird möglicherweise folgende Fehlermeldung angezeigt:

Fehlermeldung beim Kombinieren von Binärdateien. Dies ist ein bekanntes Problem, um das wir uns kümmern.

Wenn Sie die Fehlermeldung(en) schließen, indem Sie auf OK klicken, wird der Prozess Binärdateien kombinieren abgeschlossen, und Ihr Daten werden trotz des Fehlers ordnungsgemäß geladen. Wir arbeiten daran, den Fehler zu beheben.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Siehe auch

Abrufen und Transformieren in Excel 2016

Importieren von Daten aus externen Quellen

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×