Korrigieren einer #DIV/0! #BLOCKIERT!

Microsoft Excel zeigt den Fehler #DIV/0! an, wenn eine Zahl durch Null (0) geteilt werden soll. Dies geschieht, wenn Sie eine einfache Formel, wie =5/0, eingeben oder wenn eine Formel auf eine Zelle mit dem Wert 0 oder eine leere Zelle verweist, wie in dieser Abbildung dargestellt.

Beispiele für Formeln, die #DIV/0! Fehler beseitigt.

Führen Sie eine der folgenden Aktionen aus, um den Fehler zu beheben:

  • Stellen Sie sicher, dass in der Funktion bzw. in der Formel als Divisor weder Null noch eine leere Zelle verwendet wird.

  • Ändern Sie den Zellbezug in der Formel auf eine andere Zelle, in der sich keine Null (0) oder ein leerer Wert befindet.

  • Geben Sie #NV in die Zelle ein, auf die als Divisor verwiesen wird, wodurch sich das Ergebnis der Formel ebenfalls in #NV ändert, was anzeigt, dass der Wert für den Divisor nicht verfügbar ist.

In vielen Fällen kann der Fehler #DIV/0! nicht vermieden werden, da Ihre Formeln auf eine Eingabe von Ihnen oder einer anderen Person warten. In diesem Fall möchten Sie, dass keine Fehlermeldung angezeigt wird, daher gibt es einige Fehlerbehandlungsmethoden, mit denen Sie den Fehler unterdrücken können, während auf die Eingabe gewartet wird.

Auswerten des Nenners für 0 oder "kein Wert"

Die einfachste Methode zum Unterdrücken der #DIV/0! -Fehler besteht in der Verwendung der Wenn-Funktion, um das Vorhandensein des Nenners auszuwerten. Wenn es sich um einen Wert von 0 oder keinen Wert geht, zeigen Sie anstelle des Werts 0/0 als Formelergebnis an, #DIV/0! fehlerwert, andernfalls die Formel berechnen.

Wenn die Formel, die den Fehler zurückgibt, beispielsweise =A2/A3 lautet, geben Sie =WENN(A3;A2/A3;0) ein, damit 0, oder =WENN(A3;A2/A3;””), damit eine leere Zeichenfolge zurückgegeben wird. Es kann auch eine benutzerdefinierte Meldung wie die folgende angezeigt werden: =WENN(A3;A2/A3;"Eingabe erforderlich"). Mit der Funktion QUOTIENT aus dem ersten Beispiel würden Sie =WENN(A3;QUOTIENT(A2;A3);0) verwenden. Damit wird Excel Folgendes mitgeteilt: WENN(A3 vorhanden ist, gib das Ergebnis der Formel zurück, andernfalls ignorieren).

Beispiele für das Auflösen #DIV/0! Fehler beseitigt.

Verwenden von WENNFEHLER, um den Fehler #DIV/0! zu unterdrücken

Sie können diesen Fehler auch unterdrücken, indem Sie den Divisionsvorgang innerhalb der Funktion WENNFEHLER schachteln. Wenn Sie wieder A2/A3 verwenden, können Sie =WENNFEHLER(A2/A3;0) eingeben. Damit wird Excel mitgeteilt, dass 0 zurückgegeben werden soll, wenn die Formel einen Fehler aufweist, andernfalls das Ergebnis der Formel.

In Excel-Versionen vor Excel 2007 können Sie die Methode WENN(ISTFEHLER()) verwenden: =WENN(ISTFEHLER(A2/A3);0;A2/A3). Lesen Sie hierzu IST-Funktionen).

Hinweis: Sowohl die METHODEN WENNFEHLER als auch WENN(ISTFEHLER()) sind Pauschalfehlerhandler, da sie alle Fehler unterdrücken, nicht nur #DIV/0!. Sie müssen sicherstellen, dass die Formel ordnungsgemäß funktioniert, bevor Sie eine Fehlerbehandlung anwenden. Andernfalls stellen Sie möglicherweise nicht fest, dass die Formel nicht wie erwartet funktioniert.

Tipp: Wenn die Fehlerüberprüfung in Excel aktiviert ist, können Sie neben der Zelle, die den Fehlerwert anzeigt, auf Schaltflächensymbol klicken. Klicken Sie auf Berechnungsschritte anzeigen, falls dieser Befehl verfügbar ist, und wählen Sie die Lösung aus, die für Ihre Daten funktioniert.

Haben Sie eine Frage zu einer bestimmten Funktion?

Posten Sie eine Frage im Excel-Communityforum

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Siehe auch

WENN

WENNFEHLER

IST

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Ermitteln von Fehlern in Formeln

Excel-Funktionen (alphabetisch)

Excel-Funktionen (nach Kategorie)

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×