Korrigieren einer #REF! #BLOCKIERT!

Korrigieren einer #REF! #BLOCKIERT!

Der Fehler #BEZUG! wird angezeigt, wenn eine Formel auf eine Zelle verweist, die nicht gültig ist. Häufigste Ursache hierfür ist, dass Zellen, auf die aus einer Formel verwiesen wird, gelöscht oder durch andere Daten ersetzt wurden.

Beispiel – #REF! Fehler durch Löschen einer Spalte

Im folgenden Beispiel wird die Formel =SUMME(B2;C2;D2) in Spalte E verwendet.

Eine Formel mit expliziten Zellbezügen wie =SUMME(B2;C2;D2) kann zu einer #REF! fehler, wenn eine Spalte gelöscht wird.

Wenn Sie Spalte B, C oder D löschen würden, würde dies zu einer #REF! angezeigt. In diesem Fall löschen wir Spalte C (Umsatz 2007), und die Formel lautet jetzt =SUMME(B2;#REF!;C2). Wenn Sie explizite Zellbezüge wie diese verwenden (wobei Sie auf jede Zelle einzeln verweisen, durch ein Komma getrennt) und eine zeile oder spalte löschen, auf die verwiesen wird, kann Excel sie nicht auflösen, daher gibt es den Wert #REF! angezeigt. Dies ist der Hauptgrund, warum die Verwendung expliziter Zellbezüge in Funktionen nicht empfohlen wird.

Beispiel für #REF! Fehler durch Löschen einer Spalte.

Lösung

  • Wenn Sie Zeilen oder Spalten versehentlich gelöscht haben, können Sie sofort auf der Symbolleiste für den Schnellzugriff auf die Schaltfläche "Rückgängig" klicken (oder STRG+Z drücken), um die Zeilen oder Spalten wiederherzustellen.

  • Passen Sie die Formel so an, dass in ihr ein Bereichsbezug anstelle einzelner Zellen verwendet wird, etwa =SUMME(B2:D2). Jetzt können Sie eine beliebige Spalte im Bereich der Summe löschen, und Excel passt die Formel automatisch an. Sie können auch =SUMME(B2:B5) für eine Zeilensumme verwenden.

Beispiel: SVERWEIS mit falschen Bereichsbezügen

Im folgenden Beispiel gibt =SVERWEIS(A8;A2:D5;5;FALSCH) eine #REF! fehler, da nach einem Wert gesucht wird, der aus Spalte 5 zurückgegeben werden soll, der Bezugsbereich aber A:D ist, der nur 4 Spalten umfasst.

Beispiel für eine SVERWEIS-Formel mit einem falschen Bereich.  Die Formel ist =SVERWEIS(A8;A2:D5;5;FALSCH).  Es gibt keine fünfte Spalte im Bereich SVERWEIS, daher führt 5 zu einer #REF! angezeigt.

Lösung

Passen Sie den Bereich an, sodass er größer ist, oder verringern Sie den Spaltenverweiswert entsprechend dem Bezugsbereich. =SVERWEIS(A8;A2:E5;5;FALSCH) ist ein gültiger Bezugsbereich ebenso wie =SVERWEIS(A8;A2:D55;4;FALSCH).

Beispiel: INDEX mit falschem Zeilen- oder Spaltenbezug

In diesem Beispiel gibt die Formel =INDEX(B2:E5;5,5) eine #REF! fehler, da der INDEX-Bereich 4 Zeilen mal 4 Spalten umfasst, die Formel jedoch fragt, was sich in der 5. Zeile und der 5. Spalte befindet.

Beispiel einer INDEX-Formel mit einem ungültigen Bereichsbezug.  Formel ist =INDEX(B2:E5;5;5), aber der Bereich hat nur 4 Zeilen mal 4 Spalten.

Lösung

Passen Sie die Zeilen- oder Spaltenbezüge so an, dass sie im INDEX-Verweisbereich liegen. =INDEX(B2:E5;4;4) würde ein gültiges Ergebnis zurückgegeben.

Beispiel: Bezugnehmen auf eine geschlossene Arbeitsmappe mit INDIREKT

Im folgenden Beispiel wird in einer INDIREKT-Funktion auf eine Arbeitsmappe Bezug genommen, die geschlossen ist. Dadurch wird ein #BEZUG!-Fehler verursacht.

Beispiel für #REF! Fehler, der durch indirekten Verweisen auf eine geschlossene Arbeitsmappe verursacht wird.

Lösung

Öffnen Sie die Arbeitsmappe, auf die verwiesen wird. Der gleiche Fehler tritt auf, wenn Sie auf eine geschlossene Arbeitsmappe mit einer dynamischen Arrayfunktion verweisen.

OLE-Probleme

Wenn Sie einen Ole-Link (Object Linking and Embedding) verwendet haben, der eine Verknüpfung #REF! und starten Sie dann das Programm, das der Link aufruft.

Hinweis: OLE ist eine Technologie, die Sie verwenden können, um Informationen zwischen Programmen gemeinsam zu nutzen.

DDE-Probleme

Wenn Sie ein Thema für dynamischen Datenaustausch (Dynamic Data Exchange, DDE) verwendet haben, das eine E-#REF! überprüfen Sie zuerst, ob Sie auf das richtige Thema verweisen. Wenn Sie noch eine E-Mail #REF! überprüfen Sie ihre Trust Center-Einstellungen für externe Inhalte, wie unter Blockieren oder Aufheben der Blockierung externer Inhalte in Office-Dokumenten beschrieben.

Hinweis: Dynamic Data Exchange (DDE)ist ein etabliertes Protokoll zum Austausch von Daten zwischen Microsoft Windows-basierten Programmen.

Makroprobleme

Wenn ein Makro eine Funktion auf dem Arbeitsblatt ein gibt, die sich auf eine Zelle über der Funktion bezieht, und die Zelle, die die Funktion enthält, in Zeile 1 liegt, gibt die Funktion #REF! da es keine Zellen über Zeile 1 gibt. Überprüfen Sie die -Funktion, um zu überprüfen, ob ein Argument auf eine Zelle oder einen Zellbereich verweist, die nicht gültig ist. Dies kann eine Bearbeitung des Makros im Visual Basic Editor (VBE) erfordern, um diese Situation zu berücksichtigen.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Siehe auch

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Ermitteln von Fehlern in Formeln

Excel-Funktionen (alphabetisch)

Excel-Funktionen (nach Kategorie)

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×