Korrigieren eines Fehlerwerts vom Typ fehler in der Funktion SUMMEWENN/SUMMEWENNS

In diesem Thema werden die häufigeren Ursachen der #VALUE! fehler in den Funktionen SUMMEWENN und SUMMEWENNS, und wie Sie diese beheben können.

Problem: Die Formel verweist auf Zellen in einer geschlossenen Arbeitsmappe.

SummeWENN/SUMMEWENNS-Funktionen, die auf eine Zelle oder einen Bereich in einer geschlossenen Arbeitsmappe verweisen, führen zu #VALUE! -Fehlermeldung zurück.

Note: Dies ist ein bekanntes Problem bei mehreren anderen Excel, z. B. ZÄHLENWENN, ZÄHLENWENNS, ANZAHLBLANK, um nur einige zu nennen. Weitere Informationen finden Sie unter Die Funktionen SUMMEWENN, ZÄHLENWENN und ANZAHLBLANK geben "#VALUE!" Fehler finden Sie weitere Informationen.

Lösung: Öffnen Sie die in der Formel angegebene Arbeitsmappe, und drücken Sie F9, um die Formel zu aktualisieren.

Sie können dieses Problem auch lösen, indem Sie die Funktionen SUMME und WENN zusammen in einer Matrixformel verwenden. Weitere Informationen finden Sie unter Die Funktionen SUMMEWENN, ZÄHLENWENN und ANZAHLBLANK geben #VALUE! zurück. finden Sie weitere Informationen.

Problem: Die Kriterienzeichenfolge ist länger als 255 Zeichen.

Die Funktionen SUMMEWENN/SUMMEWENNS geben falsche Ergebnisse zurück, wenn Sie versuchen, mit ihnen Zeichenfolgen mit mehr als 255 Zeichen abzugleichen.

Lösung: Kürzen Sie die Zeichenfolge, falls möglich. Wenn Sie sie nicht kürzen können, verwenden Sie die Funktion VERKETTEN oder den &-Operator (kaufmännisches Und-Zeichen), um den Wert in mehrere Zeichenfolgen zu unterteilen. Beispiel:

=SUMMEWENN(B2:B12;"lange Zeichenfolge"&"weitere lange Zeichenfolge")

Problem: In SUMMEWENNS ist das Argument Kriterien_Bereich nicht mit dem Argument Summe_Bereich konsistent.

Der Bereichsargumente müssen in SUMMEWENNS immer identisch sein. Das bedeutet, dass die Argumente Kriterien_Bereich und Summe_Bereich auf dieselbe Anzahl von Zeilen und Spalten verweisen müssen.

Im folgenden Beispiel soll die Formel die Summe der täglichen Umsätze von Äpfeln in Bellevue zurückgeben. Das sum_range (C2:C10) entspricht jedoch nicht der gleichen Anzahl von Zeilen und Spalten in den Argumenten criteria_range (A2:A12 & B2:B12). Bei Verwendung der Syntax =SUMMEWENNS(C2:C10;A2:A12;A14;B2:B12;B14) wird das Ergebnis #VALUE! -Fehlermeldung zurück.

Die fehlerhafte Formel lautet =SUMMEWENNS(C2:C10;A2:A12;A14;B2:B12;B14), wobei C2:C10 C2:C12 sein muss

Lösung: Ändern Sie gemäß diesem Beispiel den Summe_Bereich in C2:C12, und probieren Sie die Formel noch mal.

Hinweis:  SUMMEWENN kann Bereiche unterschiedlicher Größen verwenden.

Haben Sie eine Frage zu einer bestimmten Funktion?

Posten Sie eine Frage im Excel-Communityforum

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen oder Unterstützung in der Answers Community erhalten.

Siehe auch

Korrigieren einer #VALUE! #BLOCKIERT!

SUMMEWENN

SUMMEWENNS

Videos zur erweiterten WENN-Funktion

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Ermitteln von Fehlern in Formeln

Alle Excel (alphabetisch)

Alle Excel-Funktionen (nach Kategorie)

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

×