Mit Microsoft anmelden
Melden Sie sich an, oder erstellen Sie ein Konto.
Hallo,
Wählen Sie ein anderes Konto aus.
Sie haben mehrere Konten.
Wählen Sie das Konto aus, mit dem Sie sich anmelden möchten.

Wichtig: In Excel 2016, Excel Mobile und Excel für das Web wurde VERKETTUNG durch die Funktion VERKETTUNG ersetzt. Obwohl VERKETTEN aus Gründen der Abwärtskompatibilität weiterhin verfügbar ist, sollten Sie die Verwendung von TEXTKETTE in Betracht ziehen, da die Funktion robuster ist.

Eins der am gängigsten Szenarios, in denen der Fehler #WERT! bei VERKETTEN auftritt, ist, wenn Sie versuchen, eine Zeichenkette zu erzeugen, die einen Zellbezug enthält, der einen Fehler aufweist, z. B. #WERT!.

Im folgenden Beispiel möchten wir D2, E2 und F2 ver concatet, wobei E2 einen #VALUE! -Fehlermeldung zurück.

#WERT! Fehler in VERKN

Der Fehler in E2 bewirkt, dass die Funktion den Fehler #WERT! anzeigt. Damit sie erfolgreich funktioniert, müssen Sie den Fehler durch einen anderen Wert als den Fehler ersetzen. Sie können eine Formel erstellen, die den Zellbezug auf einen Fehler überprüft, und die, wenn ein Fehler vorliegt, die Textzeichenfolge anzeigt, in der anstelle des Fehlers eine 0 angezeigt wird (alternativ können Sie 0 auch durch Ihren eigenen Text ersetzen, aber Sie müssen den Text dann in Anführungszeichen setzen – "Ihr Text").

Eine Formel wie die folgende funktioniert:

=WENN(ISTFEHLER(E2);VERKETTEN(D2;" "; 0;" "; F2))

Als Problemumgehung verwendete Funktionen WENN und ISTFEHLER zum Verketten einer Zeichenfolge mit dem #VALUE! #BLOCKIERT!

Wie funktioniert das? Die WENN-Funktion verwendet die Funktion WENNFEHLER, um zu ermitteln, ob in E2 ein Fehler vorhanden ist, und, falls einer vorliegt, kombiniert die Funktion VERKETTEN die Werte in D2, E2 und F2 (die Funktion ersetzt den Fehler durch 0), und zeigt die resultierende Textzeichenfolge an. Beachten Sie, dass die Formel auch Leerzeichen (" ") verwendet, um die Werte besser zu trennen.

Beheben Sie #VALUE! Fehler mit VERNATE in Excel 2003 und älteren Versionen

Wenn Sie die E-#VALUE! fehler in Office Excel 2003 oder älteren Versionen, müssen Sie die Option Berechnung von Übergangsformeln (TRANSITION Formula Evaluation, TFE) in Excel. Führen Sie die unter Fehler #VALUE! beschriebenen Schritte aus, wenn Sie Zellen verketten. um das Problem zu beheben.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen oder Unterstützung in der Answers Community erhalten.

Siehe auch

Korrigieren einer #VALUE! #BLOCKIERT!

VERKETTEN

TEXTKETTE (Funktion)

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Ermitteln von Fehlern in Formeln

Alle Excel-Funktionen (alphabetisch)

Alle Excel-Funktionen (nach Kategorie)

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Office Insidern beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×