Verwenden anderer Features zum Identifizieren verknüpfter Datentypen

Verknüpfte Datentypen wurden im Juni 2018 Excel für Microsoft 365 veröffentlicht, und als solches sind andere Features möglicherweise nicht in der Lage, sie zu identifizieren. Dies kann besonders dann der Fall sein, wenn Sie mithilfe anderer Features bedingt identifizieren möchten, ob eine Zelle einen verknüpften Datentyp enthält. In diesem Artikel werden einige Problemumgehungen erläutert, die Sie zum Identifizieren von verknüpften Datentypen in Zellen verwenden können.

Hinweis: Verknüpfte Datentypen sind nur für Clients mit mehreren Mandanten weltweit verfügbar ( Microsoft 365 Standardkonten).

Formeln

Sie können immer Formeln schreiben, die auf Datentypen verweisen. Wenn Sie jedoch den Text einer Zelle mit einem verknüpften Datentyp mithilfe der TEXT-Funktion extrahieren möchten, erhalten Sie eine #VALUE! -Fehlermeldung zurück.

Eine Problemumgehung besteht in der Verwendung der Funktion FELDWERT und dem Angeben des Felds Name für field_name Argument. Im folgenden Beispiel, wenn Zelle A1 einen Aktiendatentyp enthielt, gibt die Formel den Aktiennamen zurück.

=FELDWERT(A1;"Name")

Wenn Zelle A1 jedoch keinen verknüpften Datentyp enthält, gibt die Funktion FELDWERT einen Fehler #FIELD!. Wenn Sie auswerten möchten, ob eine Zelle einen verknüpften Datentyp enthält, können Sie die folgende Formel verwenden, die die IstFEHLER-Funktion verwendet, um zu testen, ob die Funktion FELDWERT einen Fehler zurück gibt.

=WENN(ISTFEHLER(FELDWERT(A2;"Name"));"Diese Zelle hat keinen verknüpften Datentyp";"Diese Zelle hat einen verknüpften Datentyp").

Wenn die Formel zu einem Fehler ausgewertet wird, wird der Text "Diese Zelle hat keinen verknüpften Datentyp" zurückgegeben, andernfalls wird "Diese Zelle hat einen verknüpften Datentyp" zurückgegeben.

Wenn Sie die Warnungen einfach unterdrücken #FIELD! zurück, können Sie verwenden:

=WENNFEHLER(FELDWERT(A1;"Name"),"")

Wenn ein Fehler auftritt, wird eine leere Zelle zurückgegeben.

Bedingte Formatierung

Sie können eine Zelle bedingt formatieren, basierend darauf, ob sie über einen verknüpften Datentyp verfügt oder nicht. Zuerst markieren Sie die Zellen, die die bedingte Formatierung benötigen, und wechseln dann zu Start >Bedingte Formatierung > Neue Regel > Formel verwenden... Für die Formel verwenden Sie Folgendes:

=NICHT(ISTFEHLER(FELDWERT(A1;"Name")))

Dabei steht Zelle A1 für die oberste Zelle des Bereichs, den Sie auswerten möchten. Wenden Sie dann das formatieren an.

Wenn in diesem Beispiel Zelle A1 einen gültigen Feldnamen für "Name" enthält, gibt die Formel WAHR zurück, und die Formatierung wird angewendet. Wenn Zelle A1 keinen verknüpften Datentyp enthält, gibt die Formel FALSCH zurück, und es wird keine Formatierung angewendet. Sie können nicht entfernen, wenn Sie Zellen hervorheben möchten, die keine gültigen verknüpften Datentypen enthalten.

VBA

Es gibt mehrere VBA-methoden (Visual Basic for Applications), die Sie verwenden können, um zu ermitteln, ob eine Zelle oder ein Bereich verknüpfte Datentypen enthält. In diesem ersten Verfahren wird die HasRichDataType-Eigenschaft verwendet. 

Bei beiden Verfahren werden Sie aufgefordert, einen Zellbereich auszuwählen, der ausgewertet werden soll, und dann ein Meldungsfeld mit den Ergebnissen zurückzukehren.

Sub IsLinkedDataType()
    Dim c As Range
    Dim rng As Range
    Dim strResults As String
    
    Set rng = Application.InputBox("Select a range to check for linked data types", Type:=8)
    
    For Each c In rng
      '    Check if the HasRichDataType is TRUE or FALSE
        If c.HasRichDataType = True Then
        '   The cell holds a linked data type
            strResults = strResults & c.Text & " - Linked data type" & vbCrLf
        Else
            strResults = strResults & c.Text & " - Not a linked data type" & vbCrLf
        End If
    Next c

    MsgBox "Your range contains the following details" & vbCrLf & vbCrLf & strResults, vbInformation + vbOKOnly, "Results"
    
End Sub

Im nächsten Verfahren wird die LinkedDataTypeState-Eigenschaft verwendet.

Sub IsLinkedDataTypeState()
    Dim c As Range
    Dim rng As Range
    Dim strResults As String
    
    Set rng = Application.InputBox("Select a range to check for linked data types", Type:=8)
    
    For Each c In rng
   '    Check if the LinkedDataTypeState is 1 (TRUE) or 0 (FALSE)
        If c.LinkedDataTypeState = 1 Then
        '   The cell holds a linked data type
            strResults = strResults & c.Text & " - Linked data type" & vbCrLf
        Else
            strResults = strResults & c.Text & " - Not a linked data type" & vbCrLf
        End If
    Next c
    
   MsgBox "Your range contains the following details" & vbCrLf & vbCrLf & strResults, vbInformation + vbOKOnly, "Results"

End Sub

Bei diesem endgültigen Codeausschnitt handelt es sich um eine benutzerdefinierte Funktion (User Defined Function, UDF), auf die Sie wie bei jeder anderen Formel Excel verweisen. Geben Sie einfach =fn_IsLinkedDataType(A1) ein,wobei A1 die Zelle ist, die Sie auswerten möchten.

Public Function fn_IsLinkedDataType(c As Range)
'   Function will return TRUE if a referenced cell contains a linked data type
    If c.HasRichDataType = True Then
      fn_IsLinkedDataType = "Linked data type"
    Else
        fn_IsLinkedDataType = "Not a linked data type"
    End If
End Function

Wenn Sie eines dieser Beispiele verwenden möchten, drücken Sie ALT+F11, um den Visual Basic-Editor (VBE) zu öffnen. Wechseln Sie dann zu >-Modul einfügen ,und fügen Sie den Code in das neue Fenster ein, das auf der rechten Seite geöffnet wird. Wenn Sie fertig sind, können Sie alt+Q verwenden, um Excel zu beenden. Wenn Sie eines der ersten beiden Beispiele ausführen möchten, wechseln Sie zur Registerkarte Entwickler> Code> Makros> wählen Sie das Makro aus, das Sie ausführen möchten, in der Liste aus, und wählen Sie dann Ausführen aus.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen oder Unterstützung in der Answers Community erhalten.

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

×