Verwenden von Matrixkonstanten in Matrixformeln

Wenn Sie eine Matrixformel eingeben, verwenden Sie in der Regel einen Zellbereich in Ihrem Arbeitsblatt, aber Sie müssen dies nicht tun. Sie können auch Arraykonstantenverwenden, Werte, die Sie in der Bearbeitungsleiste in geschweifte Klammern eingeben: {}. Dann können Sie Ihre Konstante so benennen , dass Sie noch einfacher zu verwenden ist.

Sie können Konstanten in ihren Arrayformeln oder selbst verwenden.

  1. Geben Sie in der Arrayformel eine öffnende geschweifte Klammer, die gewünschten Werte und eine schließende geschweifte Klammer ein. Hier ist ein Beispiel: = Summe (a1: E1 * {1; 2; 3; 4; 5})

    Die Konstante befindet sich innerhalb der geschweiften Klammern ({)}, und ja, Sie geben diese geschweiften Klammern wirklich manuell ein.

  2. Geben Sie die restliche Formel ein, und drücken Sie STRG + UMSCHALT + EINGABETASTE.

    Die Formel sieht ungefähr wie {= Summe (a1: E1 * {1; 2; 3; 4; 5})}aus, und die Ergebnisse sehen wie folgt aus:


    Eine Matrixkonstante, die in einer SUMMEN-Formel geschachtelt ist

    Die Formel, die mit "a1" mit "1" und "B1" multipliziert wird usw., wodurch Sie davon abhalten, 1, 2, 3, 4, 5 in Zellen auf dem Arbeitsblatt zu platzieren.

Verwenden einer Konstanten zum Eingeben von Werten in einer Spalte

Wenn Sie Werte in einer einzelnen Spalte wie 3 Zellen in Spalte C eingeben möchten, können Sie Folgendes ausführen:

  1. Wählen Sie die Zellen aus, die verwendet werden sollen.

  2. Geben Sie ein Gleichheitszeichen und ihre Konstante ein. Trennen Sie die Werte in der Konstante durch Semikolons, keine Kommas, und wenn Sie Text eingeben, umgeben Sie ihn mit doppelten Anführungszeichen. Beispiel: = {"Quartal 1"; " Quarter2 ";" Quartal 3 "}

  3. Drücken Sie STRG+UMSCHALT+EINGABETASTE. Die Konstante sieht wie folgt aus:

    Ein vertikale Matrixkonstane, in der Text verwendet wird

    In Geek-Ausdrücken ist dies eine eindimensionale vertikale Konstante.

Verwenden einer Konstanten zum Eingeben von Werten in einer Zeile

Wenn Sie Werte in einer einzelnen Zeile schnell eingeben möchten, beispielsweise in den Zellen F1, G1 und H1, gehen Sie wie folgt vor:

  1. Wählen Sie die Zellen aus, die verwendet werden sollen.

  2. Geben Sie ein Gleichheitszeichen und ihre Konstante ein, aber dieses Mal trennen Sie die Werte durch Kommas, nicht durch Semikolons. Beispiel: = {1; 2; 3; 4; 5}

  3. Drücken Sie STRG + UMSCHALT + EINGABETASTE, und die Konstante sieht wie folgt aus:

    Eine eindimensionale horizontale Matrixkonstante

    In Geek-Ausdrücken ist dies eine eindimensionale horizontale Konstante.

Verwenden einer Konstanten zum Eingeben von Werten in mehrere Spalten und Zeilen

  1. Wählen Sie die gewünschten Zellen aus.

    Stellen Sie sicher, dass die Anzahl der Zeilen und Spalten, die Sie auswählen, der Anzahl der Werte in der Konstanten entspricht. Wenn Ihre Konstante beispielsweise Daten in vier Spalten und drei Zeilen schreibt, wählen Sie die Anzahl der Spalten und Zeilen aus.

  2. Geben Sie ein Gleichheitszeichen und ihre Konstante ein. Trennen Sie in diesem Fall die Werte in jeder Zeile durch Kommas, und verwenden Sie am Ende jeder Zeile ein Semikolon. Beispiel:

    ={1.2.3.4;5.6.7.8;9.10.11.12}

  3. Drücken Sie STRG + UMSCHALT + EINGABETASTE, und:

    Eine zweidimensionale Matrixkonstante

    In Geek-Ausdrücken handelt es sich um eine zweidimensionale Konstante, da Sie Spalten und Zeilen ausfüllt. Wenn Sie sich Fragen, können Sie keine dreidimensionale Konstante erstellen, was bedeutet, dass Sie eine Konstante in einer anderen nicht verschachteln können.

Verwenden einer Konstante in einer Formel

Nachdem Sie nun mit Arraykonstanten vertraut sind, finden Sie hier ein funktionierendes Beispiel.

  • Geben Sie in eine leere Zelle diese Formel ein (oder kopieren und Einfügen), und drücken Sie dann STRG + UMSCHALT + EINGABETASTE:

    =SUMME(A1:E1*{1.2.3.4.5})

    In der Zelle A3 wird der Wert 85 angezeigt.

    Was ist geschehen? Sie haben den Wert in a1 um 1 multipliziert, den Wert in Zelle B2 um 2 usw., dann addiert die Funktion Summe diese Ergebnisse. Sie können auch die Formel als = Summe (a1 * 1; B1 * 2; C1 * 3; D1 * 4; E1 * 5) eingeben.

Wenn Sie möchten, können Sie beide Wertegruppen als Matrixkonstanten eingeben:

=SUMME({3.4.5.6.7}*{1.2.3.4.5})

Um dies zu versuchen, kopieren Sie die Formel, wählen Sie eine leere Zelle aus, fügen Sie die Formel in die Bearbeitungsleiste ein, und drücken Sie dann STRG + UMSCHALT + EINGABETASTE. Sie sehen dasselbe Ergebnis.

Hinweise: Suchen Sie nach diesen Problemen, wenn Ihre Konstanten nicht funktionieren:

  • Stellen Sie sicher, dass Sie Ihre Werte mit dem richtigen Zeichen voneinander trennen. Wenn Sie ein Komma oder ein Semikolon weglassen oder wenn Sie eine an der falschen Stelle platzieren, sieht die Matrixkonstante möglicherweise nicht richtig aus, oder es wird eine Warnmeldung angezeigt.

  • Möglicherweise haben Sie einen Zellbereich ausgewählt, der nicht der Anzahl der Elemente in Ihrer Konstante entspricht. Wenn Sie beispielsweise eine Spalte mit sechs Zellen für die Verwendung mit einer Konstante von fünf Zellen auswählen, wird der Fehler #N/a in der leeren Zelle angezeigt. Wenn Sie nicht genügend Zellen auswählen, werden die Werte, die keine entsprechende Zelle enthalten, von Excel ausgelassen.

  • Weitere Informationen zu Matrixformeln:

Seitenanfang

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×