Zählen von Zeichen in Zellen

Wenn Sie die Zeichen in Zellen zählen müssen, verwenden Sie die Länge-Funktion, die Buchstaben, Zahlen, Zeichen und alle Leerzeichen zählt. Der Text "Heute ist es 32 Grad warm, und deshalb gehe ich schwimmen." enthält (ohne die Anführungszeichen) 58 Zeichen: 44 Buchstaben, zwei Zahlen, zehn Leerzeichen, ein Komma und einen Punkt.

Wenn Sie die Funktion verwenden möchten, geben Sie in der Bearbeitungsleiste = Länge (Zelle) ein, und drücken Sie dann die Eingabetaste auf der Tastatur.

Mehrere Zellen: Wenn Sie dieselbe Formel auf mehrere Zellen anwenden möchten, geben Sie die Formel in die erste Zelle ein, und ziehen Sie dann das Ausfüllkästchen nach unten (oder über den Zellbereich).

Mehrmaliges Eingeben der Funktion LÄNGE in einem Arbeitsblatt

Um die Gesamtanzahl aller Zeichen in mehreren Zellen abzurufen, verwenden Sie die Funktion Summe zusammen mit Länge. In diesem Beispiel zählt die Länge-Funktion die Zeichen in jeder Zelle, und die Summe-Funktion addiert die Anzahl:

= Summe ((Länge ( cell1 ), Länge ( cell2 ), (Länge ( cell3 ) ))).

Kleiner Test gefällig?

Nachfolgend finden Sie einige Beispiele, die zeigen, wie die Länge-Funktion verwendet wird.

Kopieren Sie die folgende Tabelle, und fügen Sie Sie in Zelle a1 in einem Excel-Arbeitsblatt ein. Ziehen Sie die Formel von B2 in B4, um die Länge des Texts in allen Zellen in Spalte A anzuzeigen.

Textzeichenfolgen

Formeln

Der schnelle braune Fuchs.

=LÄNGE(A2)

Der schnelle braune Fuchs sprang.

Franz jagte im komplett verwahrlosten Taxi quer durch Bayern.

Zählen von Zeichen in einer Zelle

  1. Klicken Sie auf Zelle B2.

  2. Geben Sie = Länge (a2)ein.

Die Formel zählt die Zeichen in Zelle a2, die bis 27 summiert, einschließlich aller Leerzeichen und des Punkts am Ende des Satzes.

Hinweis: Länge zählt alle Leerzeichen nach dem letzten Zeichen.
 

Zählen von Zeichen in mehreren Zellen

  1. Klicken Sie auf Zelle B2.

  2. Drücken Sie STRG + C, um die Zelle B2 zu kopieren, wählen Sie dann die Zellen B3 und B4 aus, und drücken Sie dann STRG + V, um die Formel in die Zellen B3: B4 einzufügen.

Dadurch wird die Formel in die Zellen B3 und B4 kopiert, und die Funktion zählt die Zeichen in jeder Zelle (20, 27 und 45).

Zählen einer Gesamtsumme von Zeichen

  1. Klicken Sie in der Beispielarbeitsmappe auf die Zelle B6.

  2. Geben Sie in der Zelle =SUMME(LÄNGE(A2);LÄNGE(A3);LÄNGE(A4)) ein, und drücken Sie die EINGABETASTE.

Damit werden die Zeichen in jeder der drei Zellen gezählt und addiert (92).

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×