Symptome
Microsoft BizTalk-Hostinstanzen und die Admin-Konsole werden nicht gestartet, wenn der Standardwebproxy deaktiviert ist. Beispielsweise enthält eine Konfigurationsdatei wie BTSNTSvc.exe.config oder machine.config die folgende Einstellung:
Hinweis
- <system.net>
- <defaultProxy enabled="False" />
- </system.net>
In dieser Situation wird die folgende Fehlermeldung angezeigt:
Fehlerquelle: Microsoft.BizTalk.CommonSettings
Fehlerbeschreibung: Der Typinitialisierer für "Microsoft.BizTalk.CommonSettings.CBizTalkSettingsLookup" hat eine Ausnahme ausgelöst.
Status
Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.
Lösung
Dieses Problem wurde im folgenden kumulativen Update für BizTalk Server behoben:
- Kumulatives Update 2 für BizTalk Server 2020
Referenzmaterial
Informationen zu den Service Packs und der Liste der kumulativen Updates für BizTalk Server finden Sie im folgenden Artikel der Microsoft Knowledge Base:
2555976 Service Pack und liste kumulativer Updates für BizTalk Server
Weitere Informationen zu BizTalk Server Hotfixes finden Sie im folgenden Artikel der Microsoft Knowledge Base:
2003097 Informationen zu BizTalk-Hotfixes und unterstützung für kumulative Updates