Http-Server hat die Ausnahme "404 NotFound" zurückgegeben, wenn die serverseitige Synchronisierung in Microsoft Dynamics 365

Dieser Artikel bietet eine Lösung, mit der Sie die Fehlermeldungen beheben können, die auftreten können, wenn Sie versuchen, ein Postfach in Microsoft Dynamics 365 zu testen und zu aktivieren.

Gilt für: Microsoft Dynamics C5 2016
Ursprüngliche KB-Nummer: 3214661

Problembeschreibung

Wenn Sie ein Postfach in Microsoft Dynamics 365 (früher als Microsoft Dynamics CRM Online bezeichnet) testen und aktivieren, tritt im Bereich Warnungen einer der folgenden Fehler auf:

  • Der Postfachname <> wurde nicht synchronisiert, da beim Herstellen einer Verbindung mit dem E-Mail-Server ein Fehler aufgetreten ist. Der Besitzer des zugeordneten E-Mail-Serverprofils <Email Serverprofilname> wurde benachrichtigt.
  • Der Postfachpostfachname <> hat Termine, Kontakte und Aufgaben nicht synchronisiert, da beim Herstellen einer Verbindung mit dem Microsoft Exchange-Server ein Fehler aufgetreten ist. Der Besitzer des zugeordneten E-Mail-Serverprofils <Email Serverprofilname> wurde benachrichtigt.
  • Die Testnachricht der E-Mail-Nachricht kann nicht gesendet werden, weil beim Herstellen einer Verbindung mit dem E-Mail-Server ein Fehler aufgetreten ist. Der Postfachname <> wurde nicht synchronisiert. Der Besitzer des zugeordneten E-Mail-Serverprofils <Email Serverprofilname> wurde benachrichtigt.

Jeder der obigen Fehler enthält auch den folgenden Fehlercode:

Email Serverfehlercode: Der HTTP-Server hat die Ausnahme "404 NotFound" zurückgegeben.

Ursache

Dieser Fehler kann aus einem der folgenden Gründe auftreten:

  1. Das Postfach für den Benutzer konnte nicht gefunden werden, weil die E-Mail-Adresse nicht korrekt ist oder das Postfach derzeit nicht verfügbar ist.
  2. Die Konfiguration des zugeordneten Email Serverprofils ist nicht ordnungsgemäß so konfiguriert, dass das Postfach gefunden werden kann.

Lösung

Führen Sie die folgenden Schritte aus, um dieses Problem zu beheben:

  1. Überprüfen Sie, ob die E-Mail-Adresse des Postfachdatensatzes in Microsoft Dynamics 365 mit der E-Mail-Adresse in Exchange übereinstimmt. Der Fehler enthält einen Link zum Postfachdatensatz in Microsoft Dynamics 365. Sie können diesen Link verwenden, um das Feld Email Adresse schnell zu überprüfen. Wenn die E-Mail-Adresse korrekt ist, überprüfen Sie, ob das Postfach verfügbar ist, indem Sie es mit Ihrer E-Mail-Anwendung wie Microsoft Outlook oder Outlook Web Access öffnen.
  2. Überprüfen Sie die Konfiguration des zugeordneten Email Serverprofils. Wenn Sie Microsoft Dynamics 365 (online) mit Exchange lokal verwenden, stellen Sie sicher, dass Sie ein Exchange Server (Hybrid)-E-Mail-Serverprofil verwenden. Verwenden Sie ein Exchange Online profil nur für Benutzer, die Postfächer in Exchange Online haben.

Weitere Informationen

Wenn Sie Details anzeigen auswählen, werden Fehlerdetails wie die folgenden angezeigt:

ActivityId: <GUID>
Fehler: System.Net.WebException: Fehler bei der Anforderung mit HTTP status 404: Nicht gefunden.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
unter Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndFindItem(IAsyncResult asyncResult)
bei Microsoft.Crm.Asynchronous.EmailConnector.FindItemsStep.EndCall()
unter Microsoft.Crm.Asynchronous.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation()

ActivityId: <GUID>
Fehler: System.Net.WebException: Fehler bei der Anforderung mit HTTP status 404: Nicht gefunden.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
unter Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndCreateItem(IAsyncResult asyncResult asyncResult)
unter Microsoft.Crm.Asynchronous.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()

T:593
ActivityId: <GUID>
Ausnahme: Nicht behandelt Ausnahme: Microsoft.Exchange.WebServices.Data.ServiceRequestException: Fehler bei der Anforderung. Der Remoteserver hat einen Fehler zurückgegeben: (404) Nicht gefunden.
at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.EndGetEwsHttpWebResponse(IEwsHttpWebRequest request, IAsyncResult asyncResult asyncResult)
unter Microsoft.Exchange.WebServices.Data.SimpleServiceRequestBase.EndInternalExecute(IAsyncResult asyncResult asyncResult)
at Microsoft.Exchange.WebServices.Data.MultiResponseServiceRequest'1.EndExecute(IAsyncResult asyncResult asyncResult)
at Microsoft.Exchange.WebServices.Data.ExchangeService.EndSyncFolderHierarchy(IAsyncResult asyncResult asyncResult)
unter Microsoft.Crm.Asynchronous.EmailConnector.MonitoredExchangeService.EndSyncFolderHierarchy(IAsyncResult asyncResult asyncResult)
unter Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncSteps.ExchangeSyncAsyncRemoteStep'2.AfterCall()
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncSteps.ExchangeSyncAsyncRemoteStep'2.E...