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Problembeschreibung

Angenommen, Sie verwenden den Microsoft Dynamics CRM 2011-Client für Microsoft Office Outlook, und die Ordnerumleitung ist auf dem Client aktiviert. Wenn Sie versuchen, ein Element zu verfolgen oder die Funktion Synchronisieren mit CRM in dieser Situation auszuführen, wird eine Fehlermeldung angezeigt, die der folgenden ähnelt:

[2011-09-07 11:11:08.517] Prozess: Outlook | Organisation: 00000000-0000-0000-0000-000000000000 | Thread: 24 | Kategorie: Ausnahme | Benutzer: 00000000-0000-0000-0000-000000000000 | Stufe: Fehler | CrmException.. ctorat CrmException.. ctor (Zeichenfolgenmeldung, Ausnahme innerException, Int32-ErrorCode, boolescher isFlowControlException) bei CrmException.. ctor (Zeichenfolgenmeldung, Ausnahme innerException) bei CrmSqlCeConnection. <öffnen Sie>b__2 (SqlCeException Ex) unter ExceptionFilter. TryFilter (Aktionstext, Prädikat ' 1 Filter, Aktion ' 1 catchClause) unter IdMappingTable. MarkAllItemsNotVisited () >CRM-Ausnahme: Meldung: die SQL CE-Datenbankdatei wird von einem anderen Prozess verwendet, ErrorCode:-2147220970, InnerException: Es ist eine Datei Möglicherweise wird die Datei in einem anderen Prozess verwendet. [ \\<server>\C$\<user>\Microsoft\MSCRM\Client\OutlookSyncCache.sdf ].

Ursache

Dieses Problem tritt aufgrund einer Einschränkung in Microsoft SQL Server 2000 Windows CE Edition 3,5 (SQL Server CE 3,5) auf. 

Fehlerbehebung

HINWEIS: Nachdem Microsoft Dynamics CRM für Outlook Update Rollup 15 angewendet wurde, wird es automatisch auf SQL CE 4,0 aktualisiert. Daher ist die unten aufgeführte Auflösung nur für Update-Rollup 14 und niedriger erforderlich. Führen Sie die folgenden Schritte aus, um Microsoft Dynamics CRM 2011 auszuführen, wenn sich der Anwendungsdatenordner auf einer Remotefreigabe befindet:

  1. Installieren Sie SQL Server CE 4,0. Besuchen Sie dazu die folgende Microsoft-Website:

    http://www.microsoft.com/download/en/details.aspx?id=17876Hinweise

    • Für diesen Schritt sind erhöhte Berechtigungen erforderlich.

    • In SQL Server CE 4,0 müssen 64-Bit-Clients die 32-Bit-Version nicht installieren.

  2. Fügen Sie den folgenden XML-Code unter dem Configuration-Element in der CrmClient {14B13B7A-CA08-40bd-AC60-8C45367E807C}. config-Datei hinzu, die sich im Ordner "Programm Files\MSCRM\Client" befindet:

    <runtime> <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">   <dependentAssembly>      <assemblyIdentity name="System.Data.SqlServerCe" publicKeyToken="89845dcd8080cc91" culture="neutral" />      <bindingRedirect oldVersion="3.5.1.0"      newVersion="4.0.0.0"/>   </dependentAssembly> </assemblyBinding></runtime>

    Hinweise

    • Für diesen Schritt sind erhöhte Berechtigungen erforderlich.

    • Stellen Sie sicher, dass Sie diesen Code vor dem #a0 offerierten abweichen>-Tag hinzufügen.

  3. Darüber hinaus gibt es eine zweite Konfigurationsdatei, die vom Konfigurations-Assistenten aufgerufen wird. Die Datei hat den Namen Microsoft. CRM. Application. Outlook. ConfigWizard. exe. config, und die Datei befindet sich im Ordner c:\Programme\Microsoft Dynamics CRM\Client\ConfigWizard:

    <configuration>  <startup>    <supportedRuntime version="v4.0.30319" />  </startup>  <runtime>    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">      <probing privatePath="..\bin"/>      <dependentAssembly>        <assemblyIdentity name="System.Data.SqlServerCe"        publicKeyToken="89845dcd8080cc91"        culture="neutral" />        <bindingRedirect oldVersion="3.5.1.0"        newVersion="4.0.0.0"/>      </dependentAssembly>    </assemblyBinding>  </runtime>  <system.net>    <defaultProxy useDefaultCredentials="true" />  </system.net></configuration>
  4. Löschen Sie alle SDF-Dateien in den Ordnern % LocalAppData% und % AppData% . Weitere Informationen finden Sie im Abschnitt "Liste der Datenbanken in CRM".Hinweis SDF-Dateien, die in SQL Server CE 3,5 erstellt wurden, sind mit SQL Server CE 4,0 nicht kompatibel.

Warnung

Nachdem Sie ein Upgrade von SQL Server CE 3,5 auf SQL Server CE 4,0 durchgeführt haben, kann es bei der ersten Ausführung von Microsoft Dynamics CRM zu einer Verringerung der Leistung kommen. Dieses Verhalten tritt auf, weil Microsoft Dynamics CRM alle Caches neu erstellen muss. Einige Caches sind von der Größe des Posteingangs betroffen.

Überprüfungsschritte

Führen Sie die folgenden Schritte aus, um zu überprüfen, ob Sie die Auflösung richtig angewendet haben:

  1. Starten Sie Outlook, nachdem Sie alle Schritte von früher im Abschnitt "Lösung" ausgeführt haben.

  2. Stellen Sie sicher, dass das Microsoft Dynamics CRM-Plug-in richtig gestartet wird.

  3. Starten Sie das Tool Prozess-Explorer. Wenn Sie Process Explorer herunterladen möchten, besuchen Sie die folgende Microsoft-Website:

    http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx

  4. Suchen Sie den Prozess " Outlook. exe ", und doppelklicken Sie darauf.

  5. Wählen Sie die Registerkarte .NET Assemblies aus, und erweitern Sie dann AppDomain: SharedDomain , wenn Sie nicht bereits erweitert wurde.

  6. Suchen Sie System. Data. SqlServerCe in der Liste. Stellen Sie sicher, dass der Pfad die folgende Version von SQL Server CE enthält: c:\windows\assembly\ GAC_MSIL \System.Data.sqlserverce\4.0.Hinweis Wenn der Pfad SQL Server CE 3.5.1.0 enthält, funktioniert die Umleitung der Assembly nicht.

Liste der Datenbanken in CRM

  • %LocalAppData%\Microsoft\MSCRM\Client

    • CrmCache. sdfHinweis diese Datei enthält Caches für nicht-Metadaten-Plattformen.

    • {Guid} [true | false]. sdfHinweis diese Datei enthält den internen Speicher des MAPI-Speichers.

    Hinweis Möglicherweise gibt es mehrere Dateien dieser Art für die offline-und Online Nutzung.

  • %AppData%\Microsoft\MSCRM\Client

    • EmailCache. sdfHinweis diese Datei enthält Zuordnungen zwischen CRM-und MAPI-Elementen.

    • OutlookSyncCache. sdf Hinweis diese Datei enthält den internen Status für die Synchronisierung.

Um die Ordnerumleitung in Microsoft Dynamics CRM verwenden zu können, müssen Sie UNC-Pfade (Universal Naming Convention) verwenden.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates von Microsoft finden Sie im folgenden Artikel der Microsoft Knowledge Base:

824684 Beschreibung der Standardterminologie, die zum Beschreiben von Microsoft-Softwareupdates verwendet wirdWenn Sie weitere Informationen zu den Microsoft Business Solutions CRM-Software Hotfix-und Updatepaket-Terminologien erhalten möchten, klicken Sie auf die folgende Artikelnummer, um den Artikel in der Microsoft Knowledge Base anzuzeigen:

887283 Microsoft Business Solutions CRM-Software Hotfix-und Updatepaket-Benennungsstandards

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