Der E-Mail-Routerdienst konnte den Dienst nicht ausführen Standard Hintergrundthreadfehler beim Starten des Microsoft Dynamics CRM E-Mail-Routerdiensts

Dieser Artikel bietet eine Lösung für das Problem, dass beim Starten des Microsoft Dynamics CRM E-Mail-Routerdiensts möglicherweise der Fehler Der E-Mail-Routerdienst konnte den Dienst nicht ausgeführt Standard Hintergrundthreads erhalten.

Gilt für: Microsoft Dynamics CRM 2011
Ursprüngliche KB-Nummer: 954522

Problembeschreibung

Wenn Sie versuchen, den Microsoft Dynamics CRM E-Mail-Routerdienst in Microsoft Dynamics CRM zu starten, wird das folgende Fehlerereignis im Anwendungsprotokoll protokolliert:

Der E-Mail-Routerdienst konnte den Dienst nicht Standard Hintergrundthread ausführen.

Ursache

Dieses Problem tritt auf, weil die Microsoft.Crm.Tools.EmailAgent.SystemState.xml Datei beschädigt ist.

Lösung

Gehen Sie wie folgt vor, um das Problem zu beheben:

  1. Löschen Sie die Microsoft.Crm.Tools.EmailAgent.SystemState.xml-Datei.

    Hinweis

    • Standardmäßig befindet sich die Microsoft.Crm.Tools.EmailAgent.SystemState.xml-Datei im folgenden Ordner: C:\Programme\Microsoft CRM Email\Service.
    • Standardmäßig ist der Dienstordner ein ausgeblendeter Ordner. Um diesen Ordner anzuzeigen, müssen Sie die Einstellungen von Windows Explorer ändern, um ausgeblendete Dateien und ausgeblendete Ordner anzuzeigen.
  2. Starten Sie den Microsoft Dynamics CRM E-Mail-Routerdienst neu.

    Die Microsoft.Crm.Tools.EmailAgent.SystemState.xml Datei wird neu erstellt.

Wenn Microsoft Dynamics CRM Benutzer für eingehende E-Mails den Email Router und nicht ein Weiterleitungspostfach verwenden, besteht die Möglichkeit, dass gelöschte E-Mails nach der Implementierung dieser Lösung an Microsoft Dynamics CRM zurückgegeben werden. Wenn eine E-Mail nicht aus dem Postfach des Benutzers gelöscht wurde, könnte der Email Router die E-Mail eines Benutzers in seinem Posteingang finden, sie nicht in Microsoft Dynamics CRM finden und die E-Mail in Microsoft Dynamics CRM erneut erstellen. Um dies zu vermeiden, sollte die E-Mail zusammen mit Microsoft Dynamics CRM aus dem Postfach des Benutzers gelöscht werden.

Um diese Situation zu vermeiden, erstellen Sie regelmäßig eine Sicherung der folgenden Dateien, und speichern Sie sie auf dem Desktop desselben Servers.

  • Microsoft.Crm.Tools.EmailAgent.Configuration.bin
  • Microsoft.Crm.Tools.EmailAgent.SystemState.Xml

Wenn die Microsoft Dynamics CRM Email Router-Configuration Manager beim Start fehlschlägt oder der Microsoft Dynamics CRM Email Routerdienst nicht gestartet werden kann, ersetzen Sie die beiden oben genannten Dateien in C:\Programme\ Microsoft CRM Email\Service. Starten Sie den Microsoft Dynamics CRM Email Routerdienst neu, und starten Sie dann die Microsoft Dynamics CRM Email Router-Configuration Manager. Wenn die Sicherung dieser Dateien auf dem neuesten Stand ist, verfügt sie über die vollständige Konfiguration des Email Routers.

References

Weitere Informationen finden Sie unter Fehler Email Konfigurations-Manager beim Starten des Microsoft Dynamics CRM Email Router-Configuration Manager nicht lesen konnte.