Das Abwesenheitsfeature in Outlook funktioniert in Microsoft 365 nicht ordnungsgemäß

Symptome

Wenn Sie versuchen, das Out of Office (OOF)-Feature in Outlook in Microsoft 365 zu verwenden, treten die folgenden Symptome auf:

  • Die OOF-Nachricht kann nicht gespeichert werden.
  • Eine alte oder doppelte OOF-Nachricht wird gesendet.
  • Eine OOF-Nachricht wird nicht gesendet, obwohl Sie die OOF-Nachricht aktivieren.

Ursache

Dieses Problem kann aus einem der folgenden Gründe auftreten:

  • Ursache 1: Es gibt einen Backlog von Postfach- Assistent Ereignissen (nur Exchange 2010).
  • Ursache 2: Die OOF-Regelvorlagen sind falsch formatiert oder beschädigt.
  • Ursache 3: Das OOF-Regelkontingent wurde überschritten, und es können keine neuen Regeln erstellt werden.
  • Ursache 4: Die Remotedomäneneinstellung für die Standarddomäne (oder eine bestimmte) Domäne ist nicht so festgelegt, dass OOF-Nachrichten zugelassen werden.

Lösung

Hinweis

Jede der vier Ursachen kann dazu führen, dass eine OOF-Antwort fehlschlägt. Daher muss jede Ursache einzeln ausgeschlossen werden.

Warnung

Die Verwendung des Microsoft Exchange Server MAPI-Editor (MFCMapi) kann Microsoft Exchange Server und die Exchange-Serverpostfächer beschädigen. Laden Sie MFCMAPI von GitHub herunter (scrollen Sie nach unten, und wählen Sie dann Neuestes Release aus).

Führen Sie die Schritte für die jeweilige Ursache aus, um dieses Problem zu beheben.

Lösung 1

  1. Konfigurieren Sie das OOF-Feature. Führen Sie dazu je nach Bedarf eines der folgenden Cmdlets in Windows PowerShell aus:

    Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Disabled
    Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Enabled

  2. Verwenden Sie MFCMapi, um den PR_OOF_STATE Wert zu überprüfen. Gehen Sie dazu wie folgt vor:

    1. Wählen Sie im Standard Fenster von MFCMapi die Option Sitzung und dann Anmelde- und Anzeigespeichertabelle aus, um das Postfach zu öffnen.

    2. Wählen Sie das Profil aus, auf das Sie zugreifen, und scrollen Sie dann im unteren Bereich nach unten, bis der PR_OOF_STATE Wert angezeigt wird. Dieser Wert sollte True sein, wenn Sie das OOF-Feature in Windows PowerShell aktiviert haben, oder False, wenn Sie das OOF-Feature deaktiviert haben. Wenn Sie beispielsweise das OOF-Feature deaktiviert haben, sehen Sie sich den folgenden Screenshot an:

      Screenshot des PR_OOF_STATE Werts.

  3. Wenn der PR_OOF_STATE Wert nicht das erwartete Ergebnis ist, wenden Sie sich an Microsoft-Support, um sie auf Ereignisse in der Warteschlange überprüfen zu lassen (nur Exchange 2010).

Lösung 2

Hinweis

Die Symptome in Ihrem Fall können leicht von diesen abweichen. Beispielsweise kann die OOF-Nachricht nicht wie erwartet gesendet werden, obwohl die OOF-Nachricht ohne Fehler festgelegt werden kann. Diese Schritte gelten jedoch weiterhin.

Um dieses Problem zu beheben, löschen Sie die OOF-Regeln und die OOF-Regelvorlagen aus dem Postfach. Aktivieren Sie dann das OOF-Feature erneut, und testen Sie das Verhalten. Gehen Sie hierzu wie folgt vor.

Hinweis

Sie müssen die OOF-Nachricht nicht sichern, wenn Sie diese Schritte ausführen.

  1. Wählen Sie im Standard Fenster von MFCMapi die Option Sitzung und dann Anmelde- und Anzeigespeichertabelle aus, um das Postfach zu öffnen.

  2. Erweitern Sie den Stammcontainer und den oberen Rand des Informationsspeichers.

  3. Löschen Sie die OOF-Regeln. Gehen Sie dazu wie folgt vor:

    1. Klicken Sie mit der rechten Maustaste auf Posteingang, und wählen Sie dann Regeltabelle anzeigen aus.

      • Wenn das OOF-Feature deaktiviert ist, wird eine OOF-Regel zusammen mit dem folgenden Regelnamen in der Regeltabelle aufgeführt:
        MSFT: TDX-OOF-Regeln

      • Wenn das OOF-Feature aktiviert ist, werden in der Regeltabelle zwei verschiedene OOF-Regeln aufgeführt. Welche Regeln aufgelistet werden, hängt davon ab, ob die Regel nur intern oder sowohl intern als auch extern aktiviert ist. Betrachten Sie beispielsweise den folgenden Screenshot:

        Screenshot der Details des Dialogfelds

      • Wenn die OOF-Vorlagen beschädigt oder falsch formatiert sind, werden diese OOF-Vorlagen in der Regeltabelle aufgeführt. Sie können andere Einträge anzeigen, wenn für den Benutzer andere Regeln aktiviert sind.

    2. Klicken Sie mit der rechten Maustaste auf die OOF-Regeln, und wählen Sie dann Löschen aus.

      Hinweis

      Löschen Sie keine OOF-Regeln mit Ausnahme der regeln, auf die verwiesen wird.

    3. Schließen Sie das Fenster Regeltabelle.

  4. Löschen Sie die OOF-Vorlagen. Gehen Sie dazu wie folgt vor:

    • Klicken Sie mit der rechten Maustaste auf Posteingang, und wählen Sie dann Zugeordnete Inhaltstabelle öffnen aus.
    • Scrollen Sie nach rechts, und erweitern Sie dann die Spalte Nachrichtenklasse .
    • Um die Elemente zu sortieren, wählen Sie die Spalte Nachrichtenklasse aus.
    • Suchen Sie nach den Elementen, deren Message Class einen der folgenden Werte aufweist:
      • IPM. Note.Rules.ExternalOofTemplate.Microsoft
      • IPM.Note.Rules.OofTemplate.Microsoft

Betrachten Sie beispielsweise den folgenden Screenshot:

Screenshot der OOF-Regeln, die gelöscht werden können.

  • Klicken Sie mit der rechten Maustaste auf die Elemente, die zu einer dieser beiden Nachrichtenklassen gehören, und wählen Sie dann Nachricht löschen aus.

    Hinweis

    Löschen Sie keine Elemente, außer auf die verwiesen wird.

    Screenshot der OOF-Regeln, die gelöscht werden können.

  • Wählen Sie im Dialogfeld Element löschen die Option Dauerhaftes Löschen aus, das DELETE_HARD_DELETE (nicht wiederherstellbar) unter Löschformat übergeben wird, und wählen Sie dann OK aus.

    Wählen Sie unter Löschstil die Option Permanent delete passing DELETE_HARD_DELETE (nicht wiederherstellbar) aus.

  • Deaktivieren Sie das OOF-Feature mit den folgenden Befehlen, und aktivieren Sie es dann erneut:

    Set-MailboxAutoReplyConfiguration \<identity> -AutoReplyState Disabled
    Set-MailboxAutoReplyConfiguration \<identity> -AutoReplyState Enabled

  • Überprüfen Sie, ob das OOF-Feature wie erwartet funktioniert und die Symptome nicht mehr auftreten.

Lösung 3

Wenn keine OOF-Antwort mehr zurückgegeben wird, ist es wahrscheinlich, dass das Regelkontingent überschritten wird. Daher können die internen und externen OOF-Regeln nicht erstellt werden. Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:

  1. Erhöhen Sie Ihr Regelkontingent. Führen Sie dazu die Schritte im folgenden Artikel aus:

    Ein Benutzer kann keine neuen Regeln in Outlook oder Outlook Web App

  2. Aufgrund des Zwischenspeicherns von Kontingentinformationen im Informationsspeicher kann es bis zu zwei Stunden dauern, bis die aktualisierten Kontingentwerte wirksam werden.

  3. Wiederholen Sie Auflösung 2.

Lösung 4

Wenn der Wert AllowedOFFType für die Remotedomäne Keine ist, werden OOF-Nachrichten nicht extern ausgelöst. Dieser Wert muss auf Extern festgelegt werden, um externe OOFs zuzulassen. Standardmäßig ist dieser Wert auf Keine festgelegt. Denken Sie daran, dass beim Durchsuchen der Remotedomänen der Standardwert durch bestimmte Einträge überschrieben wird. Wenn der Benutzer also an einen @contoso.com Benutzer sendet und in den Remotedomäneneinstellungen ein Contoso.com Eintrag vorhanden ist, wird der AllowedOOFType-Wert für diesen eintrag verwendet. Wenn kein Eintrag für Contoso.comvorhanden ist, wird die Standard-Remotedomäne (*) verwendet.

Get-RemoteDomain | select Name,AllowedOOFType