Problembeschreibung

Wenn Sie versuchen, das Office (OOF)-Feature in Outlook in Microsoft Office 365 zu verwenden, treten die folgenden Symptome auf:

  • Die Meldung "OOF" kann nicht gespeichert werden.

  • Es wird eine alte oder doppelte Nachricht des unbußeren Nachrichtentexts (OOF) gesendet.

  • Eine OOF-Nachricht wird nicht gesendet, obwohl Sie die Nachricht "OOF" aktivieren.

Ursache

Dieses Problem kann aus einem der folgenden Gründe auftreten:  

  • Ursache 1:Es gibt ein Backlog der Ereignisse des Postfach-Assistenten (nur Exchange 2010).

  • Ursache 2:Die Vorlagen für Die Regeln für OOF sind falsch formatiert oder beschädigt.

  • Ursache 3:Das Kontingent der OOF-Regeln ist überschritten, und es können keine neuen Regeln erstellt werden.

  • Ursache 4:Die Einstellung "Remotedomäne" für die Standarddomäne (oder eine bestimmte Domäne) ist nicht so festgelegt, dass OOF-Nachrichten zulässig sind.

Fehlerbehebung

Hinweis Jede der vier Ursachen kann dazu führen, dass eine Antwort des Antwortungs-OOF fehlschlägt. Daher muss jede Ursache jeweils ausgeschlossen werden.

WarnungDie Verwendung Microsoft Exchange Server MAPI-Editors (MFCMapi) kann zu Beschädigungen Microsoft Exchange Server exchange -Serverpostfächern führen. Laden Sie MFCMAPI von Github herunter (scrollen Sie nach unten, und klicken Sie dann auf "Neueste Version").

Führen Sie die Schritte für die spezifische Ursache aus, um dieses Problem zu beheben. 

Lösung 1

  1. Konfigurieren Sie das OOF-Feature. Führen Sie dazu eines der folgenden Cmdlets in der Windows PowerShell aus:

    Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Disabled

    Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Enabled

  2. Verwenden Sie MFCMapi, um den PR_OOF_STATE zu überprüfen. Gehen Sie dazu wie folgt vor:

    a.       Klicken Sie im Hauptfenster von MFCMapi auf "Sitzung", und klicken Sie dann auf "Anmeldung" und "Speichertabelle anzeigen", um das Postfach zu öffnen.

    b.      Klicken Sie auf das Profil, auf das Sie zugreifen, und scrollen Sie dann im unteren Bereich nach unten, bis PR_OOF_STATE wird. Dieser Wert sollte "True" sein, wenn Sie das Feature "OOF" in "Windows PowerShell"False" aktiviert haben, wenn Sie das Feature "OOF" deaktiviert haben. Wenn Sie beispielsweise das Feature "OOF" deaktiviert haben, sehen Sie sich den folgenden Screenshot an:

    Alternativtext

  3. Wenn der PR_OOF_STATE nicht das erwartete Ergebnis ist, wenden Sie sich an den Microsoft-Support, damit er auf Ereignisse in der Warteschlange überprüft (nur Exchange 2010).

Lösung 2

HinweisDie Symptome in Ihrem Fall können geringfügig von diesen abweichen. Beispielsweise kann die Nachricht nicht wie erwartet gesendet werden, obwohl die OOF-Nachricht ohne Fehler festgelegt werden kann. Diese Schritte gelten jedoch weiterhin.

Um dieses Problem zu beheben, löschen Sie die OOF-Regeln und die Vorlagen für OOF-Regeln aus dem Postfach. Aktivieren Sie dann das Feature "OOF" erneut, und testen Sie das Verhalten. Gehen Sie hierzu wie folgt vor. 

HinweisSie müssen die Meldung "OOF" nicht sichern, wenn Sie diese Schritte ausführen.

  1. Klicken Sie im Hauptfenster von MFCMapi auf "Sitzung", und klicken Sie dann auf "Anmeldung" und "Speichertabelle anzeigen", um das Postfach zu öffnen.

  2. Erweitern Sie den Stammcontainer und den oberen Rand des Informationsspeichers.

  3. Löschen Sie die OOF-Regeln. Gehen Sie dazu wie folgt vor:
     

    1. Klicken Sie mit der rechten Maustaste auf "Posteingang",und klicken Sie dann auf "Tabelle mit Anzeigeregeln".
       

      • Wenn das Feature OOF deaktiviert ist, wird in der Tabelle "Regeln" eine Regel mit dem folgenden Regelnamen aufgeführt: MSFT: TDX-OOF-Regeln

      • Wenn das Feature "OOF" aktiviert ist, sind in der Regeltabelle zwei unterschiedliche OOF-Regeln aufgelistet. Welche Regeln aufgelistet werden, hängt davon ab, ob die Regel nur intern oder sowohl intern als auch extern aktiviert wird. Sehen Sie sich beispielsweise den folgenden Screenshot an:

        Alternativtext

      • Wenn die Vorlagen für OOF beschädigt oder fehlerhaft formatiert sind, werden diese Vorlagen in der Regeltabelle aufgeführt. Wenn der Benutzer andere Regeln aktiviert hat, werden weitere Einträge angezeigt.

    2. Klicken Sie mit der rechten Maustaste auf die OOF-Regeln, und klicken Sie dann auf "Löschen".Hinweis Löschen Sie keine OOF-Regeln außer denen, auf die verwiesen wird.

    3. Schließen Sie das Fenster "Regeltabelle".

  4. Löschen Sie die OOF-Vorlagen. Gehen Sie dazu wie folgt vor:

    • Klicken Sie mit der rechten Maustaste auf"Posteingang", und klicken Sie dann auf "Tabelle mit zugeordneten Inhalten öffnen".

    • Scrollen Sie nach rechts, und erweitern Sie dann die Spalte "Nachrichtenklasse".

    • Um die Elemente zu sortieren, klicken Sie auf die Spalte "Nachrichtenklasse".

    • Suchen Sie nach den Elementen, deren Nachrichtenklasse einer der folgenden Werte ist:

      • IPM. Note.Rules.ExternalOofTemplate.Microsoft

      • IPM. Note.Rules.OofTemplate.Microsoft

Sehen Sie sich beispielsweise den folgenden Screenshot an:

  1. Alternativtext



    • Klicken Sie mit der rechten Maustaste auf die Elemente, die zu einer dieser beiden Nachrichtenklassen gehören, und klicken Sie dann auf "Nachricht löschen". 

      Hinweis Löschen Sie keine Elemente, außer wenn darauf verwiesen wird.

      Alternativtext

    • Wählen Sie im Dialogfeld "Element löschen" unter "Löschstil" die Option "Permanentes Löschen übergeben" DELETE_HARD_DELETE (nicht behebbar)aus,und klicken Sie dann auf "OK".
      Alternativtext

    • Deaktivieren Sie das OOF-Feature, und aktivieren Sie es dann erneut, indem Sie die folgenden Befehle verwenden:

      Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Disabled
      Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Enabled

    • Überprüfen Sie, ob das Feature OOF wie erwartet funktioniert und die Symptome nicht mehr auftreten.

Lösung 3

Wenn keine Antwort mehr zurückgegeben wird, ist das Regelkontingent wahrscheinlich überschritten. Daher können die internen und externen OOF-Regeln nicht erstellt werden. Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:

  1. Erhöhen Sie das Regelkontingent. Führen Sie dazu die Schritte im folgenden Microsoft Knowledge Base-Artikel aus:

    1. 2622933 Ein Benutzer kann in Outlook oder Outlook Web App keine neuen Regeln erstellen

  2. Aufgrund der Zwischenspeicherung von Kontingentinformationen im Informationsspeicher benötigen die aktualisierten Kontingentwerte möglicherweise bis zu zwei Stunden, bis sie wirksam werden.

  3. Repeat Resolution 2.

Auflösung 4

Wenn der Wert "AllowedOFFType" für die Remotedomäne "None"ist, werden keine externen Nachrichten von OOF gesendet. Dieser Wert muss auf "Extern" festgelegt werden, damit externe OOFs zulässig sind. Standardmäßig ist dieser Wert auf "Keine" festgelegt. Denken Sie daran, dass beim Durchsuchen der Remotedomänen der Standardwert durch bestimmte Einträge überschrieben wird. Wenn der Benutzer also an einen @contoso.com-Benutzer sendet und in den Remotedomäneneinstellungen ein Contoso.com-Eintrag vorhanden ist, wird für diesen spezifischen Eintrag der Wert "AllowedOOFType" verwendet. Wenn kein Eintrag für Contoso.com vorhanden ist, wird die Standardmäßige Remotedomäne (*) verwendet.


Get-RemoteDomain | Select Name,AllowedOOFType

Weitere Informationen

Wenn der PR_OOF_STATE nicht das erwartete Ergebnis ist, lesen Sie den folgenden Microsoft Knowledge Base-Artikel:

2705649 Exchange: Die Verarbeitung von OOF-Nachrichten und RBA funktioniert in Exchange 2010 nicht wie erwartet

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