Der Empfänger empfängt keine E-Mails, die ein Microsoft Dynamics CRM Benutzer mithilfe des Microsoft Dynamics CRM Webclients sendet.

Dieser Artikel bietet eine Lösung für das Problem, dass der Empfänger keine E-Mail-Nachrichten empfangen kann, die vom Microsoft Dynamics CRM Webclient gesendet werden.

Gilt für: Microsoft Dynamics CRM 2011
Ursprüngliche KB-Nummer: 915827

Problembeschreibung

Wenn ein Microsoft Dynamics CRM Benutzer eine E-Mail-Nachricht mithilfe des Microsoft Dynamics CRM 2011-Webclients sendet, wird die E-Mail-Nachricht gesendet oder in die Warteschlange eingereiht. Wenn jedoch ein Problem auftritt, wenn der Benutzer die E-Mail-Nachricht sendet, erhält der Benutzer eine der folgenden Fehlermeldungen in der E-Mail-Aktivität.

Fehlermeldung 1

Diese Nachricht wurde noch nicht zur Zustellung übermittelt. Bisher wurden 1 Versuche unternommen.

Fehlermeldung 2

Fehler bei der Nachrichtenübermittlung. Es muss für jede weitere Verarbeitung erneut übermittelt werden.

Darüber hinaus erhalten Sie im MSCRMEmailLog-Ereignisprotokoll eine Fehlermeldung, die der folgenden ähnelt:

Ereignistyp:Fehler
Ereignisquelle:MSCRMEmailLog
Ereigniskategorie:Keine
Ereignis-ID:0
Datum: Datum
Zeit: Zeit
Benutzer: n/v
Computer: ComputerName
Beschreibung: #61042 – Fehler beim Verarbeiten der ausgehenden E-Mail-Nachricht mit dem Betreff "test 3 today CRM:0001011" für SMTP: https://adsrv:81/MS1 für die Zustellung über adsrv. System.Net.Mail.SmtpException: Fehler beim Senden von E-Mails. >--- System.Net.WebException: Verbindung mit dem Remoteserver --- nicht möglich>
System.Net.Sockets.SocketException: Es konnte keine Verbindung hergestellt werden, da der Zielcomputer sie aktiv abgelehnt hat.
unter System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
unter System.Net.Sockets.Socket.InternalConnect(EndPoint remoteEP)
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
--- Ende des --- für die ablaufverfolgung des inneren Ausnahmestapels
at System.Net.ServicePoint.GetConnection(PooledStream PooledStream, Object owner, Boolean async, IPAddress& address, Socket& abortSocket, Socket& abortSocket6, Int32 timeout)
at System.Net.PooledStream.Activate(Object owningObject, Boolean async, Int32 timeout, GeneralAsyncDelegate asyncCallback)
bei System.Net.PooledStream.Activate(Object owningObject, GeneralAsyncDelegate asyncCallback)
at System.Net.ConnectionPool.GetConnection(Object owningObject, GeneralAsyncDelegate asyncCallback, Int32 creationTimeout)
at System.Net.Mail.SmtpConnection.GetConnection(String host, Int32 port)
at System.Net.Mail.SmtpTransport.GetConnection(String host, Int32 port)
unter System.Net.Mail.SmtpClient.GetConnection()
bei System.Net.Mail.SmtpClient.Send(MailMessage message)
--- Ende des --- für die ablaufverfolgung des inneren Ausnahmestapels
bei System.Net.Mail.SmtpClient.Send(MailMessage message)
bei Microsoft.Crm.Tools. Email. Providers.SmtpPollingSendEmailProvider.SendMessage(MailMessage mailMessage)
bei Microsoft.Crm.Tools. Email. Providers.SmtpPollingSendEmailProvider.ProcessMessageInternal(email emailMessage)
bei Microsoft.Crm.Tools. Email. Providers.CrmPollingSendEmailProvider.ProcessMessage(email emailMessage)
bei Microsoft.Crm.Tools. Email. Providers.CrmPollingSendEmailProvider.Run()

Weitere Informationen finden Sie im Hilfe- und Supportcenter unter https://go.microsoft.com/fwlink/events.asp.

Ursache

Microsoft Dynamics CRM basiert auf dem lokalen SMTP-Server, um E-Mail-Nachrichten an den Exchange-Server weiterzuleiten. Dieses Problem tritt aus einem der folgenden Gründe auf:

  • Die SMTP-Konfiguration auf dem Microsoft Dynamics CRM Server ist nicht für die Weiterleitung von E-Mail-Nachrichten an den Exchange-Server konfiguriert.
  • Der Exchange-Server ist nicht so konfiguriert, dass Relaynachrichten vom Microsoft Dynamics CRM-Server zugelassen werden.

Lösung

Gehen Sie wie folgt vor, um das Problem zu beheben:

Schritt 1: Konfigurieren von SMTP auf dem Microsoft Dynamics CRM Server zum Weiterleiten von E-Mail-Nachrichten an den Exchange-Server

  1. Öffnen Sie auf dem Microsoft Dynamics CRM Server Internetinformationsdienste (IIS). Wählen Sie hierzu Start, Verwaltung und dann Internetinformationsdienste-Manager aus.
  2. Erweitern Sie im Internetinformationsdienste-Manager (IIS)-Manager die Option Standard virtueller SMTP-Server, klicken Sie mit der rechten Maustaste auf Domänen, zeigen Sie auf Neu, und wählen Sie dann Domäne aus.
  3. Wählen Sie im Neuen SMTP-Assistenten unter Domänentyp angeben die Option Remote aus, und wählen Sie dann Weiter aus.
  4. Geben Sie Ihren Domänennamen in das Feld Name ein, und wählen Sie dann Fertig stellen aus.
  5. Klicken Sie im rechten Bereich mit der rechten Maustaste auf den Domänennamen, den Sie in den Schritten 2 bis 4 hinzugefügt haben, und wählen Sie dann Eigenschaften aus.
  6. Aktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Weiterleitung eingehender E-Mails an diese Domäne zulassen , und wählen Sie dann Alle E-Mails an Smarthost weiterleiten aus. Geben Sie im Feld unter Alle E-Mails an Smarthost weiterleiten den Namen des Exchange-Servers ein, und wählen Sie dann OK aus.
  7. Starten Sie den SMTP-Dienst auf dem Microsoft Dynamics CRM Server neu. Wählen Sie hierzu Start, Verwaltung und dann Dienste aus. Klicken Sie mit der rechten Maustaste auf Simple Mail Transfer Protocol (SMTP), und wählen Sie dann Neu starten aus.

Schritt 2: Konfigurieren des Exchange-Servers zum Zulassen von Relaynachrichten vom Microsoft Dynamics CRM-Server

Exchange Server 2003

Wenn Sie Microsoft Exchange Server 2003 verwenden, müssen Sie zuerst die Relayeinschränkungen konfigurieren und dann das Connections-Steuerelement überprüfen.

Konfigurieren der Relayeinschränkungen
  1. Wählen Sie Start aus, zeigen Sie auf Programme, zeigen Sie auf Microsoft Exchange, und wählen Sie dann System-Manager aus.

  2. Wählen Sie Server aus, wählen Sie den Namen des Exchange-Servers aus, wählen Sie Protokolle und dann SMTP aus.

  3. Klicken Sie mit der rechten Maustaste auf Den virtuellen SMTP-Standardserver, wählen Sie Eigenschaften und dann die Registerkarte Zugriff aus.

  4. Wählen Sie im Bereich Relayeinschränkungendie Option Relay aus.

  5. Vergewissern Sie sich, dass die Option Nur die folgende Liste ausgewählt ist, und fügen Sie dann den Microsoft Dynamics CRM Server zur Liste hinzu.

    Wenn Sie Microsoft Dynamics CRM 2011 verwenden, stellen Sie sicher, dass Sie der Liste den Server hinzufügen, auf dem der Exchange-Router installiert ist.

  6. Starten Sie den SMTP-Dienst neu. Gehen Sie dazu wie folgt vor:

    1. Wählen Sie Start aus, zeigen Sie auf Programme, zeigen Sie auf Verwaltung, und wählen Sie dann Dienste aus.
    2. Klicken Sie mit der rechten Maustaste auf Simple Mail Transfer Protocol (SMTP), und wählen Sie dann Neu starten aus.
Überprüfen des Connections-Steuerelements
  1. Wählen Sie Start aus, zeigen Sie auf Programme, zeigen Sie auf Microsoft Exchange, und wählen Sie dann System-Manager aus.

  2. Wählen Sie Server aus, wählen Sie den Namen des Exchange-Servers aus, wählen Sie Protokolle und dann SMTP aus.

  3. Klicken Sie mit der rechten Maustaste auf Den virtuellen SMTP-Standardserver, wählen Sie Eigenschaften und dann die Registerkarte Zugriff aus.

  4. Wählen Sie im Bereich Connections Steuerungdie Option Verbindung aus.

  5. Standardmäßig ist die Option Alle außer der folgenden Liste ausgewählt. Wenn der Microsoft Dynamics CRM-Server dieser Liste hinzugefügt wird, müssen Sie sich an den Exchange-Administrator wenden, um den Grund für das Hinzufügen des Microsoft Dynamics CRM Servers zu ermitteln.

    Hinweis

    Damit Microsoft Dynamics CRM E-Mail-Nachrichten ordnungsgemäß funktionieren, muss der Microsoft Dynamics CRM Server eine Verbindung mit dem Exchange-Server herstellen können.

  6. Wenn die Option Nur die folgende Liste ausgewählt ist, müssen Sie den Microsoft Dynamics CRM Server der Liste hinzufügen, damit er eine Verbindung mit dem Exchange-Server herstellen kann.

  7. Wenn Sie Änderungen an den Einstellungen für die Verbindungssteuerung vorgenommen haben, starten Sie den SMTP-Dienst neu. Gehen Sie dazu wie folgt vor:

    1. Wählen Sie Start aus, zeigen Sie auf Programme, zeigen Sie auf Verwaltung, und wählen Sie dann Dienste aus.
    2. Klicken Sie mit der rechten Maustaste auf Simple Mail Transfer Protocol (SMTP), und wählen Sie dann Neu starten aus.

Exchange Server 2007

Wenn Sie Microsoft Exchange Server 2007 verwenden, müssen Sie einen neuen Exchange-Empfangsconnector erstellen, den Connector für den anonymen Benutzer konfigurieren, Protokollberechtigungen für den Empfangsconnector konfigurieren und dann den Microsoft Exchange-Transportdienst auf dem Exchange-Server neu starten.

Erstellen eines Exchange-Empfangsconnectors
  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie Serverkonfiguration.

  3. Wählen Sie Hub-Transport aus.

  4. Klicken Sie mit der rechten Maustaste auf Empfangsconnectors, und wählen Sie dann Neuer Empfangsconnector aus.

  5. Geben Sie einen Namen in das Feld Name ein.

  6. Wählen Sie in der Liste Wählen Sie die beabsichtigte Verwendung für diesen Empfangsconnector aus die Option Intern und dann Weiter aus.

  7. Wählen Sie im Abschnitt Remotenetzwerkeinstellungen die Option Hinzufügen aus, und geben Sie dann die IP-Adresse des Microsoft Dynamics CRM Servers ein.

    Hinweis

    Wenn der Wert 0.0.0.0-255.255.255.255 angezeigt wird, wählen Sie Löschen aus.

  8. Wählen Sie Weiter, Neu und dann Fertig stellen aus.

Konfigurieren des Connectors für den anonymen Benutzer
  1. Klicken Sie mit der rechten Maustaste auf den Exchange-Empfangsconnector, den Sie erstellt haben, und wählen Sie dann Eigenschaften aus.
  2. Wählen Sie die Registerkarte Berechtigungsgruppen aus.
  3. Stellen Sie sicher, dass die Option Angeben, wer eine Verbindung mit dem Empfangsconnector herstellen darf auf Anonyme Benutzer festgelegt ist, wählen Sie Übernehmen und dann OK aus.
Konfigurieren von Protokollberechtigungen für den Empfangsconnector

Hinweis

Sie müssen Windows-Supporttools installiert haben, um diese Schritte ausführen zu können. Nur ein erfahrener Administrator sollte das Tool Adsiedit.msc verwenden.

  1. Starten Sie das Tool Adsiedit.msc.
  2. Erweitern Sie Konfiguration, Dienste, Microsoft Exchange, CN= Erste Organisation, Administrative Gruppen, Exchange Administrative Gruppe, Server, Protokolle und smtp-Empfangsconnectors.
  3. Klicken Sie mit der rechten Maustaste auf den Exchange-Empfangsconnector, den Sie erstellt haben, und wählen Sie dann Eigenschaften aus.
  4. Klicken Sie auf die Registerkarte Sicherheit.
  5. Wählen Sie Anonyme Anmeldung aus.
  6. Aktivieren Sie das Kontrollkästchen Nachrichten an einen beliebigen Empfänger senden , und wählen Sie das Kontrollkästchen Autorisierende Domänensender akzeptieren aus, wählen Sie Übernehmen und dann OK aus.
Starten Sie den Microsoft Exchange-Transportdienst auf dem Exchange-Server neu.
  1. Wählen Sie Start aus, wählen Sie Ausführen aus, geben Sie services.msc ein, und wählen Sie dann OK aus.
  2. Klicken Sie mit der rechten Maustaste auf Microsoft Exchange-Transportdienst, und wählen Sie dann Neu starten aus.