Ein Termin wird während der serverseitigen Synchronisierung unerwartet abgebrochen oder gelöscht.

Dieser Artikel bietet eine Lösung für ein Problem, bei dem ein Termin unerwartet abgesagt oder gelöscht wird, wenn Sie die serverseitige Synchronisierung verwenden.

Gilt für: Microsoft Dynamics 365
Ursprüngliche KB-Nummer: 4345686

Symptome

Wenn Sie die serverseitige Synchronisierung verwenden, um Termine zwischen Microsoft Dynamics 365 und Exchange zu synchronisieren, wird ein Termin unerwartet abgebrochen oder gelöscht.

Ursache

Dieses Problem kann auftreten, wenn der Termin die Bedingungen der Synchronisierungsfilter des Benutzers nicht mehr erfüllt. Wie unter logisch gelöschte Elemente während der Synchronisierung ignorieren erwähnt, gibt es mehrere Gründe, warum ein Termin möglicherweise nicht mehr mit Ihren Synchronisierungsfiltern übereinstimmt, z. B. der Organisator des geänderten Termins, die Synchronisierungsfilter geändert werden oder der Benutzer aufgrund von Änderungen an Sicherheitsrollen oder Freigaben keinen Zugriff mehr auf den Datensatz hat. Standardmäßig sendet die serverseitige Synchronisierung in diesem Szenario einen Löschvorgang an Exchange, was zu einer Terminabsage führt.

Lösung

Es wurde eine konfigurierbare Einstellung eingeführt, mit der Sie dieses Verhalten ändern können. Sie können eines der folgenden Tools verwenden, um die DistinctPhysicalAndLogicalDeletesForExchangeSync Einstellung in True zu ändern:

  1. organisationseinstellungen Editor
  2. OrgDBOrgSettings-Tool für Microsoft Dynamics CRM