Fehler "Crystal Print Engine Error 709 The table could be found" (Crystal Print Engine-Fehler 709 Die Tabelle konnte nicht gefunden werden) beim Ausführen eines benutzerdefinierten Crystal Reports-Berichts

In diesem Artikel finden Sie Lösungen für das Problem, das möglicherweise beim Ausführen eines benutzerdefinierten Crystal Reports-Berichts in Microsoft Dynamics SL 2011 angezeigt wird.

Gilt für: Microsoft Dynamics SL 2011
Ursprüngliche KB-Nummer: 939712

Problembeschreibung

Stellen Sie sich folgendes Szenario vor:

  • Sie führen Microsoft Dynamics SL 2011 aus.
  • Sie verwenden einen benutzerdefinierten Crystal Reports-Bericht.
  • Sie melden sich mithilfe der Windows-Authentifizierung an.

In diesem Szenario wird die folgende Fehlermeldung angezeigt:

Crystal Reports Hilfsanwendung für Solomon IV
Fehler bei SQL-Abfrage abrufen Bericht: C:\Programme\Microsoft Dynamics SL\Usr_Rpts\03730DET. RPT
Crystal Print Engine-Fehler: 709 – Fehler in Datei C:\Programme\Microsoft Dynamics SL\Usr_Rpts\03730DET. RPT:

Die Tabelle konnte nicht gefunden werden.

Ursache 1

Dieser Fehler tritt auf, weil die folgenden Bedingungen erfüllt sind:

  • Der Bericht Crystal Reports verwendet eine oder mehrere benutzerdefinierte Tabellen oder benutzerdefinierte Ansichten.
  • Entweder der E7F575915A2E4897A517779C0DD7CE Microsoft SQL Server-Benutzer oder die MSDSL-SQL Server-Anwendungsrolle verfügt nicht über die erforderlichen Berechtigungen für die benutzerdefinierte Tabelle oder die benutzerdefinierte Ansicht. Siehe Auflösung 1 im Abschnitt "Auflösung".

Ursache 2

Eine ODBC-Verbindung (Open Database Connectivity) ist fälschlicherweise für die Verwendung der Windows-Authentifizierung anstelle der SQL Server-Authentifizierung eingerichtet. Wenn Sie zum ersten Mal einen Crystal Reports-Bericht auf einer neuen Arbeitsstation ausführen, wird eine ODBC-Verbindung für die Microsoft Dynamics SL-Systemdatenbank und für die Microsoft Dynamics SL-Anwendungsdatenbank erstellt. Diese Verbindung sollte für die Verwendung SQL Server-Authentifizierung eingerichtet werden, auch wenn Sie die Windows-Authentifizierung verwenden, um sich bei Microsoft Dynamics SL anzumelden. Siehe Auflösung 2 im Abschnitt Auflösung.

Lösung 1

Weisen Sie der benutzerdefinierten Tabelle oder der benutzerdefinierten Ansicht die entsprechenden Rechte zu. Gehen Sie dazu wie folgt vor:

  1. Starten Sie Microsoft SQL Server Management Studio.
  2. Erweitern Sie Datenbanken, erweitern Sie die Microsoft Dynamics SL-Datenbank, und erweitern Sie dann Tabellen oder Sichten.
  3. Suchen Sie die benutzerdefinierte Tabelle oder die benutzerdefinierte Ansicht in der Liste.
  4. Klicken Sie mit der rechten Maustaste auf die benutzerdefinierte Tabelle oder die benutzerdefinierte Ansicht. Wählen Sie dann Eigenschaften aus.
  5. Wählen Sie im Bereich Seite auswählen die Option Berechtigungen aus.
  6. Wählen Sie HINZUFÜGEN aus, geben Sie MSDSL ein, und klicken Sie dann auf OK.
  7. Aktivieren Sie für Berechtigung auswählen das Kontrollkästchen Gewähren .
  8. Wählen Sie HINZUFÜGEN aus.
  9. Wählen Sie Durchsuchen aus. Aktivieren Sie dann das Kontrollkästchen neben dem E7F575915A2E4897A517779C0DD7CE Benutzer.
  10. Klicken Sie zweimal auf OK.
  11. Aktivieren Sie für die Berechtigung Steuerelement das Kontrollkästchen Gewähren .

Lösung 2

Um dieses Problem zu beheben, löschen Sie die ODBC-Verbindungen, und lassen Sie Microsoft Dynamics SL die Verbindungen neu erstellen. Gehen Sie dazu wie folgt vor:

  1. Wählen Sie Start, Einstellungen und dann Systemsteuerung aus.
  2. Wählen Sie Verwaltung aus.
  3. Wählen Sie Datenquellen (ODBC) aus.
  4. Entfernen Sie auf der Registerkarte Benutzer-DSN alle Einträge für die Microsoft Dynamics SL-Systemdatenbank und für die Microsoft Dynamics SL-Anwendungsdatenbank.
  5. Entfernen Sie auf der Registerkarte System DSN alle Einträge für die Microsoft Dynamics SL-Systemdatenbank und für die Microsoft Dynamics SL-Anwendungsdatenbank.
  6. Melden Sie sich erneut bei Microsoft Dynamics SL an, und versuchen Sie dann erneut, den Bericht zu verwenden. Die Benutzer-DSN-Einträge sollten automatisch neu erstellt werden.