Fehler beim Versuch, Berichte in Microsoft Dynamics AX 2009 bereitzustellen

Problembeschreibung

Wenn Sie versuchen, Microsoft Dynamics AX 2009-Berichte bereitzustellen, wird die folgende Fehlermeldung angezeigt. In der Protokolldatei wird der folgende Fehler angezeigt:

Microsoft Dynamics AX-Bericht Erstellungs Projekt Bereitstellung: ClrBridgeLoader: Schwerwiegender Fehler:

Microsoft. Dynamics. ClrBridge. dll kann nicht geladen werden. Schwerwiegender Fehler: ClrBridge wird nicht geladen.

Ursache

Dieses Verhalten wird verursacht, weil sich Microsoft. Dynamics. BusinessConnectorNet im GAC (: \Windows\assembly-Ordner) nicht in der gleichen Version wie die AX-Kernel Version befindet. Beispiel: AX-Kernel ist Version 5.0.1000.52 (AX 2009 SP1), aber die Microsoft. Dynamics. BusinessConnectorNet ist Version 5.0.593.0 (RTM)

Fehlerbehebung

Wenden Sie Microsoft Dynamics AX 2009 SP1 auf dem Computer an, von dem Sie die Berichte bereitstellen. Sie sollten dann sehen, dass das AX SP1-Installationsprogramm erkannt hat, dass .NET Business Connector aktualisiert werden musste. Wenn dies abgeschlossen ist, überprüfen Sie, ob sich Microsoft. Dynamics. BusinessConnectorNet nun in Version 5.0.1000.52 (identisch mit Ihrem AX-Kernel) befindet. Suchen Sie im Windows-Explorer diese Datei in: \Windows\System32-Ordner, klicken Sie mit der rechten Maustaste auf die Datei, klicken Sie auf Eigenschaften, und klicken Sie dann auf die Registerkarte Version . Die Dateiversion sollte 5.0.1000.52 oder mit der Dateiversion von AX32Serv. exe identisch sein.

Weitere Informationen

Informationen zu einer ähnlichen Fehlermeldung finden Sie unter diesem Link: https://MBS.Microsoft.com/customersource/Documentation/howtodocuments/ax2009_ssrs_ssas_integration.htm 

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Insider beitreten

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×