Fehler "ClrBridge ist nicht geladen" beim Versuch, Berichte in Microsoft Dynamics AX 2009 bereitzustellen

Dieser Artikel enthält eine Lösung für das Problem, dass beim Versuch, Berichte in Microsoft Dynamics AX 2009 bereitzustellen, ein Fehler vom Typ ClrBridge ist nicht geladen angezeigt wird .

Gilt für: Microsoft Dynamics AX 2009
Ursprüngliche KB-Nummer: 2277529

Problembeschreibung

Sie erhalten die folgende Fehlermeldung, wenn Sie versuchen, Microsoft Dynamics AX 2009-Berichte bereitzustellen. In der Protokolldatei wird der folgende Fehler angezeigt:

Microsoft Dynamics AX Reporting Project Deployment: ClrBridgeLoader: Schwerwiegender Fehler:
Microsoft.Dynamics.ClrBridge.dll kann nicht geladen werden. Schwerwiegender Fehler: ClrBridge ist nicht geladen.

Ursache

Dieses Verhalten wird verursacht, weil Microsoft.Dynamics.BusinessConnectorNet im GAC (:\Windows\Assembly-Ordner) nicht dieselbe Version wie die AX-Kernelversion aufweist. Beispiel: Der AX-Kernel ist Version 5.0.1000.52 (AX 2009 SP1), aber microsoft.Dynamics.BusinessConnectorNet ist Version 5.0.593.0 (RTM)

Lösung

Wenden Sie Microsoft Dynamics AX 2009 SP1 auf dem Computer an, auf dem Sie die Berichte bereitstellen. Daraufhin sollte das Microsoft Dynamics AX SP1-Installationsprogramm erkannt haben, dass .NET Business Connector aktualisiert werden muss. Überprüfen Sie anschließend, ob Microsoft.Dynamics.BusinessConnectorNet jetzt Version 5.0.1000.52 aufweist (identisch mit Ihrem AX-Kernel). Suchen Sie in Windows Explorer diese Datei im Ordner :\Windows\System32, klicken Sie mit der rechten Maustaste auf die Datei, wählen Sie Eigenschaften aus, und wählen Sie dann die Registerkarte Version aus. Die Dateiversion sollte 5.0.1000.52 sein oder mit der Dateiversion Ihres AX32Serv.exe identisch sein.