Fehler beim Drucken oder Anzeigen einer Vorschau eines Berichts in Microsoft Dynamics SL: System message 7011

Dieser Artikel enthält mehrere Lösungen für ein Problem, bei dem Sie die Systemnachricht 7011-Fehlermeldung erhalten, wenn Sie einen Bericht in Microsoft Dynamics SL drucken oder in der Vorschau anzeigen.

Gilt für: Microsoft Dynamics SL 2011
Ursprüngliche KB-Nummer: 905595

Problembeschreibung

Betrachten Sie das Szenario, in dem Sie Berichte in einem der folgenden Module drucken oder in der Vorschau anzeigen:

  • Einkauf in Microsoft Dynamics SL
  • Auftragsverwaltung in Microsoft Dynamics SL
  • Bestand in Microsoft Dynamics SL
  • Zeit und Kosten für Projekte in Microsoft Dynamics SL

Wenn Sie diese Aktion ausführen, erhalten Sie eine der folgenden Fehlermeldungen:

Reihe 1:

Systemmeldung 7011– ROI RipARAM get RIPARAM failed for CRPERC.System Message 7011- ROI Get RIPARAM failed for CRPERC. Error=.

Nachdem Sie diese Meldung erhalten haben, erhalten Sie die folgende Fehlermeldung:

Systemmeldung 7011– ROI Get RIPARAM failed for CRPEMSGCNT.System Message 7011- ROI Get RIPARAM failed for CRPEMSGCNT. Error=.

Siehe Ursache 1, 2, 3 und 4.

Serie 2:

Bei der CRPEHLPR MFC-Anwendung ist ein Problem aufgetreten und muss geschlossen werden. Es tut uns leid für die Unannehmlichkeiten.

Gefolgt von:

Systemmeldung 7011– ROI RipARAM get RIPARAM failed for CRPERC.System Message 7011- ROI Get RIPARAM failed for CRPERC. Error=.

Gefolgt von:

System message 7011 – ROI Get RIPARAM failed for CRPEMSGCNT. Error=.

Siehe Ursache 5.

Serie 3:

laufzeitfehler Microsoft Visual C++ runtime library! Programm: Die Anwendung hat angefordert, dass die Runtime auf ungewöhnliche Weise beendet wird. Wenden Sie sich an das Supportteam der Anwendung, um weitere Informationen zu erfahren.

Gefolgt von:

Systemmeldung 7011– ROI RipARAM get RIPARAM failed for CRPERC.System Message 7011- ROI Get RIPARAM failed for CRPERC. Error=.

Gefolgt von:

System message 7011 – ROI Get RIPARAM failed for CRPEMSGCNT. Error=.

Siehe Ursache 6.

Ursache

Dieses Problem tritt aus einem der folgenden Gründe auf.

Ursache 1

Das Feature "Datenausführungsverhinderung" (DATA Execution Prevention, DEP) verhindert, dass einige Dateien erfolgreich ausgeführt werden, wenn sich Die Programme Microsoft Dynamics SL oder Microsoft Business Solutions – Solomon auf einem Computer befinden, auf dem eines der folgenden Betriebssysteme ausgeführt wird:

  • Windows Server 2008 oder Windows Server 2008 R2
  • Windows 7
  • Windows Server 2003 mit Service Pack 1 (SP1)
  • Windows Vista mit Service Pack 1 (SP1)
  • Windows XP Professional mit Service Pack 2 (SP2)

Ursache 2

Es gibt beschädigte Datensätze in der Microsoft Dynamics SL-Anwendungsdatenbank oder in der Anwendungsdatenbank Microsoft Business Solutions – Solomon.

Ursache 3

Die Capicom.dll Datei wurde falsch registriert.

Ursache 4

Microsoft Dynamics SL verwendet Crystal Reports 10. Diese Version von Crystal Reports ist ein Upgrade von einer früheren Version. Daher sind einige Programmeinstellungen nicht mehr kompatibel.

Ursache 5

Dieses Problem tritt auf, weil es eine Unterdrückungsformel für einen Unterbericht gibt, der dem Bericht zugeordnet ist, den Sie drucken möchten.

Ursache 6

Die MSDSL-Anwendungsrolle oder der E7F575915A2E4897A517779C0DD7CE SQL-Benutzer wird nicht ordnungsgemäß mit den Microsoft Dynamics SL-Datenbanken synchronisiert. Oder sowohl die Rolle als auch der Benutzer werden nicht ordnungsgemäß synchronisiert. Diese Situation kann auftreten, wenn die folgenden Bedingungen zutreffen:

  • Sie wählen auf dem Bildschirm Datenbankwartung (98.290.00) das Szenario Alle Besitz- und Sicherheitsupdates synchronisieren aus, und der Bildschirm Datenbankwartung (98.290.00) stammt aus einer früheren Version von Microsoft Dynamics SL.
  • Sie führen das Updateszenario für jede Datenbank aus, die auf demselben instance SQL Server wie eine Microsoft Dynamics SL 7.0-Datenbank vorhanden ist.

Lösung 1

Legen Sie das Feature "Datenausführungsverhinderung" fest, um die ausführung der Crpehlpr.exe-Datei und der Roi.exe-Datei zu aktivieren. Gehen Sie dazu wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und klicken Sie auf Eigenschaften.

  2. Klicken Sie in Windows Server 2003 oder Windows XP auf die Registerkarte Erweitert . Klicken Sie in Windows Vista, Windows 7 oder Windows Server 2008 auf den Link Erweiterte Systemeinstellungen .

  3. Klicken Sie im Abschnitt Leistung auf Einstellungen.

  4. Klicken Sie auf der Registerkarte Datenausführungsverhinderung auf Hinzufügen.

    Hinweis

    Die Standardoption ist Aktivieren von DEP für alle Programme und Dienste mit Ausnahme der von mir ausgewählten Programme und Dienste.

  5. Navigieren Sie zum Installationsverzeichnis des Microsoft Dynamics SL-Programms oder zum Installationsverzeichnis des Programms Microsoft Business Solutions – Solomon. Wenn Sie über ein zusätzliches Laufwerk verfügen, das diesem Installationsverzeichnis zugeordnet ist, müssen Sie die Datei über beide Pfade hinzufügen.

    Beispielsweise installieren Sie Microsoft Dynamics SL 7.0 im folgenden Ordner:

    C:\Program Files\Microsoft Dynamics\SL\Applications

    Auf demselben Computer ordnen Sie das Laufwerk S dem folgenden Ordner zu:

    C:\Program Files\Microsoft Dynamics\SL

    Wenn Sie diesen Schritt ausführen, müssen Sie die Dateien mithilfe der beiden folgenden Pfade hinzufügen:

    • C:\Programme\Microsoft Dynamics\SL\Applications\
    • S:\Applications\
  6. Suchen Sie die folgende Datei, und klicken Sie dann darauf, um die folgende Datei auszuwählen:

    Crpehlpr.exe

  7. Klicken Sie auf Öffnen, dann auf Übernehmen und dann auf OK.

  8. Wiederholen Sie die Schritte 1 bis 7 für die datei Roi.exe.

Lösung 2

Löschen Sie die beschädigten Datensätze aus der Microsoft Dynamics SL-Anwendungsdatenbank oder aus der Anwendungsdatenbank Microsoft Business Solutions – Solomon. Gehen Sie hierzu wie folgt vor.

Hinweis

Bevor Sie die Anweisungen in diesem Artikel befolgen, stellen Sie sicher, dass Sie über eine vollständige Sicherungskopie der Datenbank verfügen, die Sie wiederherstellen können, wenn ein Problem auftritt.

  1. Stellen Sie sicher, dass alle Microsoft Dynamics SL-Benutzer oder alle Microsoft Business Solutions - Solomon-Benutzer abgemeldet sind.

  2. Starten Sie Microsoft SQL Query Analyzer. Oder starten Sie Microsoft SQL Server Management Studio.

  3. Stellen Sie eine Verbindung mit der entsprechenden Microsoft Dynamics SL-Anwendungsdatenbank oder mit der Anwendungsdatenbank Microsoft Business Solutions – Solomon her.

  4. Führen Sie die folgenden Anweisungen aus.

    Delete from Roidetail
    
    Delete from Rptcompany
    
    Delete from Rptruntime
    

Lösung 3

Um dieses Problem zu beheben, registrieren Sie die Capicom.dll-Datei manuell. Gehen Sie dazu wie folgt vor:

  1. Suchen Sie die Capicom.dll-Datei auf dem lokalen Computer. Diese Datei befindet sich standardmäßig im folgenden Ordner:

    SystemDrive:\Windows\System32

  2. Überprüfen Sie, ob die Version der Capicom.dll-Datei 2.1.0.1 oder höher ist. Gehen Sie dazu wie folgt vor:

    1. Klicken Sie mit der rechten Maustaste auf die datei Capicom.dll, und klicken Sie dann auf Eigenschaften.
    2. Überprüfen Sie auf der Registerkarte Version , ob die Dateiversion 2.1.0.1 oder höher ist.
    3. Klicken Sie auf OK.
  3. Klicken Sie mit der rechten Maustaste auf die datei Capicom.dll, und klicken Sie dann auf Öffnen mit.

  4. Klicken Sie im Dialogfeld Windows auf Programm aus einer Liste auswählen, und klicken Sie dann auf OK.

  5. Klicken Sie im Dialogfeld Öffnen mit auf Durchsuchen.

  6. Suchen Sie den folgenden Ordner, und öffnen Sie ihn:

    SystemDrive:\Windows\System32

  7. Doppelklicken Sie auf die datei Regsvr32.exe, und klicken Sie dann auf OK.

  8. Klicken Sie auf OK , wenn die folgende Meldung angezeigt wird:

    RegSvr32 – DllRegisterServer in SystemDrive:\windows\system32\capicom.dll erfolgreich.

Hinweis

Wenn auf einem Arbeitsstationscomputer vor der Registrierung der Capicom.dll-Datei die Fehlermeldung "Systemmeldung 9827" angezeigt wird, müssen Sie auf dem Bildschirm Datenbankwartung (98.290.00) das Szenario "Alle Besitz- und Sicherheitsupdates synchronisieren" erneut ausführen.

Lösung 4

Um dieses Problem zu beheben, aktivieren Sie das Kontrollkästchen Kein Drucker in der Berichtsdatei in Business Objects Crystal Reports. Gehen Sie dazu wie folgt vor:

  1. Öffnen Sie Crystal Reports, und klicken Sie dann auf die Berichtsdatei, um sie zu öffnen.
  2. Klicken Sie auf Datei.
  3. Klicken Sie auf Druckereinrichtung.
  4. Aktivieren Sie das Kontrollkästchen Kein Drucker , und klicken Sie dann auf OK.
  5. Klicken Sie auf Speichern.

Lösung 5

Ändern Sie den Bericht in Business Objects Crystal Reports, um die Unterdrückung für den Unterbericht zu entfernen.

  1. Öffnen Sie in Business Objects Crystal Reports die Berichtsdatei, die den Fehler erzeugt.

  2. Wenn in einem Abschnitt des Berichts ein Unterbericht vorhanden ist, klicken Sie mit der rechten Maustaste auf den Unterbericht. Hinweis: Wenn kein Unterbericht vorhanden ist, funktioniert diese Lösung nicht.

  3. Klicken Sie auf Unterbericht formatieren. Die angezeigte Schaltfläche Formel unterdrücken sollte roten Text enthalten. Das Vorhandensein dieses roten Texts weist darauf hin, dass eine Unterdrückungsformel vorhanden ist. Wenn die Formel Variablen aus dem übergeordneten Bericht verwendet, müssen die Variablen entfernt werden.

    Hinweis

    • Wenn Sie keinen Hinweis erhalten, dass eine Unterdrückungsformel vorhanden ist, funktioniert diese Lösung nicht.
    • Wenn die Unterdrückungsformel eine Kombination aus Unterberichtsvariablen und übergeordneten Berichtsvariablen verwendet, müssen diese Variablen getrennt werden, damit die übergeordneten Berichtsvariablen entfernt werden können.
    • Wenn der Abschnitt, der den Unterbericht enthält, auch andere angezeigte Variablen enthält, müssen die Variablen getrennt werden.
    • Wenn der Abschnitt, der den Unterbericht enthält, bereits über eine Unterdrückungsformel verfügt, müssen Sie entscheiden, ob die Formeln zusammengeführt werden sollen und wie dies geschieht.
  4. Klicken Sie auf Formel unterdrücken, um das Dialogfeld Format-Editor zu öffnen, und klicken Sie dann im Menü Bearbeiten auf Alles auswählen.

    Hinweis

    Wenn die Unterdrückungsformel nur Variablen aus dem Unterbericht verwendet, funktioniert diese Problemumgehung nicht.

  5. Klicken Sie im Menü Bearbeiten auf Kopieren , um die Formel zu kopieren.

  6. Löschen Sie die Formel.

  7. Klicken Sie auf OK , um das Dialogfeld Format-Editor zu schließen.

  8. Klicken Sie mit der rechten Maustaste auf den linken Abschnitt des Bildschirms, in dem der Unterbericht angezeigt wird, und klicken Sie dann auf Abschnittsexperte.

  9. Klicken Sie im Dialogfeld Abschnittsexperte auf Formel unterdrücken, und klicken Sie dann im Menü Bearbeiten auf Einfügen, um die Formel einzufügen.

  10. Klicken Sie auf Speichern und schließen, und klicken Sie dann auf OK.

  11. Klicken Sie im Menü Datei auf Speichern .

Lösung 6

Synchronisieren Sie den Benutzer. Gehen Sie dazu wie folgt vor:

  1. Verwenden Sie SQL Server Management Studio, um die folgende Anweisung für die Microsoft Dynamics SL-Systemdatenbank auszuführen:

    DELETE FROM RPTExtra
    
  2. Wählen Sie auf dem Bildschirm Datenbankwartung (98.290.00) das Szenario Alle Besitz- und Sicherheitsupdates synchronisieren aus, und klicken Sie dann auf Verarbeitung beginnen.