Fehler beim Klicken auf bestimmte Links auf der Seite "Projektcenter" im Geschäftsportal für Microsoft Dynamics SL

Dieser Artikel hilft Ihnen bei der Behebung eines Problems, bei dem Fehlermeldungen angezeigt werden, wenn Sie auf der Seite Projektcenter im Unternehmensportal auf bestimmte Links klicken.

Gilt für: Microsoft Dynamics SL 2011
Ursprüngliche KB-Nummer: 915315

Problembeschreibung

Betrachten Sie die folgenden Szenarien im Business Portal für Microsoft Dynamics SL und für Microsoft Business Solutions – Solomon:

  • Wenn Sie im Unternehmensportal auf der Seite Projektcenter auf den Link Zeit klicken, wird die folgende Fehlermeldung angezeigt:

    Fehler beim Abrufen von Projektmitarbeiterinformationen bei der Zeiteingabe

  • Wenn Sie im Unternehmensportal auf der Seite Projektcenter auf den Link Dokumentgenehmigungen klicken, wird die folgende Fehlermeldung angezeigt:

    Fehler in der Datei "/Anwendung", dass die Ressource in der Genehmigung von Zeit und Kosten nicht gefunden werden kann

  • Auf der Seite Projektcenter im Unternehmensportal wird im Communicator-Webpart die folgende Fehlermeldung angezeigt:

    Fehler beim Abrufen von Projektmitarbeiterinformationen: ERROR

  • Wenn Sie auf der Seite Genehmigungen der Geschäftsleitung für einen Spesenposten auf den Link Bearbeiten oder Ablehnen klicken, wird die folgende Fehlermeldung angezeigt:

    ASP-Fehler in: GRFUNCTION. ASP/IsModuleUnlocked Error #424 Object required

Ursache

Dieses Problem tritt auf, weil einer Rolle keine gültige Backoffice-ID zugewiesen ist.

Hinweis

Im Bereich Benutzer des Unternehmensportals verwalten enthält das Feld Back-Office-ID für eine Rolle, die dem Geschäftsportalbenutzer zugewiesen ist, den Standardwert Nicht angegeben .

Lösung

Um dieses Problem zu beheben, weisen Sie der Rolle, die keine gültige Back-Office-ID hat, eine gültige Back-Office-ID zu. Gehen Sie dazu wie folgt vor:

  1. Melden Sie sich beim Unternehmensportal als Administrator an.
  2. Klicken Sie auf Websiteeinstellungen und dann auf Benutzer des Unternehmensportals verwalten.
  3. Wählen Sie im Benutzerlisten-Webpart die entsprechende Benutzer-ID aus.
  4. Klicken Sie im Webpart Benutzereigenschaften auf die Registerkarte Rollen .
  5. Weisen Sie der Rolle, die über keine gültige Back-Office-ID verfügt, eine gültige Back-Office-ID zu.

Das im Abschnitt Symptome beschriebene Problem gilt nicht für Microsoft Dynamics SL 7.0.