Beim Konfigurieren des Microsoft Dynamics CRM für den Outlook-Client wird die Fehlermeldung objektverweis nicht auf eine instance eines Objekts festgelegt angezeigt.

Dieser Artikel bietet eine Lösung für einen Fehler, der beim Konfigurieren des Microsoft Dynamics CRM für den Outlook-Client auftritt.

Gilt für: Microsoft Dynamics CRM 2011, Dynamics CRM 2013, Microsoft Dynamics CRM 2013 Service Pack 1, Microsoft CRM Client für Microsoft Office Outlook®
Ursprüngliche KB-Nummer: 2986728

Problembeschreibung

Wenn Sie den Microsoft Dynamics CRM 2011- oder CRM 2013 für Outlook-Client für einen Microsoft Dynamics CRM Online instance konfigurieren, wird die folgende Fehlermeldung angezeigt:

Objektverweis nicht auf eine instance eines Objekts festgelegt

Nachdem Sie Ihre Anmeldeinformationen eingegeben haben, wählen Sie Ihre organization aus, und klicken Sie auf OK.

Es liegt ein Problem bei der Kommunikation mit dem Microsoft Dynamics CRM-Server vor. Der Server ist möglicherweise nicht verfügbar. Versuchen Sie es später erneut. Wenn das Problem weiterhin besteht, wenden Sie sich an Ihren Systemadministrator.

Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.

at Microsoft.Crm.Passport.IdCrl.OnlineServicesFederationLogOnManager.GetBrowserClientAuthInfo(String redirectEndpoint, String partner, String policy, String& postData)

at Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider'1.SignIn()

at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.SignIn(Uri endPoint, Credential credentials, AuthUIMode uiMode, IClientOrganizationContext context, Form parentWindow, Boolean retryOnError)

at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.GetAuthProvider(Uri endPoint, Credential credentials, AuthUIMode uiMode, Uri webEndPoint, IClientOrganizationContext context, Form parentWindow)

Microsoft.Crm.Application.Outlook.Config. ServerInfo.LoadUserId()

Microsoft.Crm.Application.Outlook.Config. ServerInfo.Initialize(Uri discoveryUri, OrganizationDetail selectedOrg, String displayName, Boolean isPrimary)

Microsoft.Crm.Application.Outlook.Config. ServerForm.LoadDataToServerInfo()

Microsoft.Crm.Application.Outlook.Config. ServerForm.<InitializeBackgroundWorkers>b__2(Object sender, DoWorkEventArgs e)

bei System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)

at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

Ursache

Dieses Problem tritt auf, wenn Sie eine Version des Microsoft Online Services-Anmelde-Assistenten verwenden, die mit Microsoft Dynamics CRM 2011 oder Microsoft Dynamics CRM 2013 nicht kompatibel ist. Beim Konfigurieren des Microsoft Dynamics CRM für den Outlook-Client und beim Herstellen einer Verbindung mit einem Microsoft Dynamics CRM Online instance werden die einzigen unterstützten Versionen des Microsoft Online Services-Anmelde-Assistenten 7.250.4259.0, 7.250.4287.0 und 7.250.4303.0 unterstützt.

Lösung

Führen Sie die folgenden Schritte aus, um dieses Problem zu beheben:

  1. Wählen Sie Start aus, geben Sieappwiz.cplein, und drücken Sie dann die EINGABETASTE, um das Element Programme und Features in Systemsteuerung zu öffnen.
  2. Deinstallieren Sie den Microsoft Online Services-Anmelde-Assistenten, wenn dessen Version nicht mit 7.250.4259.0, 7.250.4287.0 oder 7.250.4303.0 übereinstimmt.
  3. Laden Sie Version 7.250.4303.0 des Microsoft Online Services-Anmelde-Assistenten herunter, und installieren Sie sie erneut.
  4. Starten Sie Ihre Arbeitsstation neu, und konfigurieren Sie die Microsoft Dynamics CRM für den Outlook-Client, um zu überprüfen, ob das Problem behoben wurde.