Beim Synchronisieren von Terminen, Kontakten und Aufgaben ist ein interner Microsoft Dynamics 365-Fehler aufgetreten.

Dieser Artikel bietet eine Lösung für einen Fehler, der nach der Auswahl von Test & Enable Mailbox on a mailbox record in Dynamics 365 auftritt.

Gilt für: Microsoft Dynamics 365
Ursprüngliche KB-Nummer: 4346733

Symptome

Nachdem Sie Test & Postfach für einen Postfachdatensatz in Dynamics 365 aktivieren ausgewählt haben, wird das Testergebnis Termine, Kontakte und Aufgaben als Fehler angezeigt, und die folgende Meldung wird im Abschnitt Warnungen angezeigt:

"Beim Synchronisieren von Terminen, Kontakten und Aufgaben für das Postfach [Postfachname] ist ein interner Microsoft Dynamics 365 Fehler aufgetreten. Das Postfach wurde nicht synchronisiert. Der Besitzer des zugeordneten E-Mail-Serverprofils [Email Serverprofilname] wurde benachrichtigt.
Email Serverfehlercode: UserPrivilegeError"

Ursache

Wenn diese Fehlermeldung angezeigt wird und der Email Serverfehlercode als UserPrivilegeError angezeigt wird, gibt dies an, dass der Benutzer, dem dieses Postfach gehört, nicht über ausreichende Berechtigungen verfügt. Eine Liste der erforderlichen Berechtigungen finden Sie unter PrivilegeDenied error occurs when using Server-Side Synchronization for a list of required privileges.see PrivilegeDenied error occurs when using Server-Side Synchronization for a list of required privileges.

Wichtig

Vergewissern Sie sich, dass der Besitzer des Postfachdatensatzes mit dem Benutzer identisch ist. Beispiel: Wenn das Postfach ein Benutzerpostfach für Paul Cannon ist, überprüfen Sie, ob der Besitzerwert im Postfachdatensatz für Paul Cannon als Paul Cannon angezeigt wird. Wenn es sich um einen anderen Benutzer handelt, hat dieser Benutzer möglicherweise keinen Zugriff auf das Postfach dieses Benutzers.

Lösung

Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:

  1. Öffnen Sie als Benutzer mit der Rolle Systemadministrator den Postfachdatensatz in Dynamics 365.

    Hinweis

    Die Warnung enthält einen Link zum Postfachdatensatz.

  2. Vergewissern Sie sich, dass das Feld Besitzer im Postfachformular mit dem Namen des Benutzers aufgefüllt ist. Wenn ein anderer Benutzer aufgeführt ist, ändern Sie ihn so, dass er mit diesem Benutzer identisch ist.
  3. Wählen Sie den Link im Feld Besitzer aus, um den Benutzerdatensatz für den besitzenden Benutzer zu öffnen.
  4. Wählen Sie Rollen verwalten aus, um zu sehen, welche Sicherheitsrollen diesem Benutzer zugewiesen sind.
  5. Navigieren Sie zu Einstellungen, wählen Sie Sicherheit und dann Sicherheitsrollen aus.
  6. Öffnen Sie die in Schritt 4 gefundenen Rollen. Eine Liste der erforderlichen Berechtigungen finden Sie unter PrivilegeDenied error occurs when using Server-Side Synchronization for a list of required privileges and verify the user's security role contains these privileges.
  7. Nachdem Sie sich vergewissert haben, dass der Benutzer der Besitzer seines Postfachdatensatzes ist und seine Sicherheitsrolle die erforderlichen Berechtigungen enthält, wählen Sie erneut die Schaltfläche & Postfach aktivieren in ihrem Postfachdatensatz aus. Wenn der Test nicht zu Erfolg führt, überprüfen Sie die Meldung, die im Abschnitt Warnungen angezeigt wird.