Problembeschreibung

Microsoft Dynamics CRM Client für Microsoft Office Outlook kann beim Anheften von Ansichten langsam ausgeführt werden.

Ursache

Wenn eine Ansicht angeheftet ist, werden die Datensätze in der Ansicht in die lokale SQL A0 in {orgid.sdf} abgerufen und zwischengespeichert. Wenn Ansichten angeheftet sind, werden sie einem Benutzer in der "Listenansicht" und nicht in "seitenseitigen Ansichten" angezeigt. Bei jedem Zugriff auf eine angeheftet Ansicht werden Ergebnisse aus den lokalen .sdf-Dateien zurückgegeben.

Diese Daten werden regelmäßig als Hintergrundprozess aktualisiert. Wenn ein Benutzer über mehrere angeheftet Ansichten oder computer mit nicht vielen Ressourcen verfügt, kann dies zu Leistungs- und Ladeproblemen führen.

Fehlerbehebung

Um zu verhindern, dass angeheftet Ansichten Informationen in lokale SQL CE-Caches ziehen, kann auf den Microsoft Dynamics CRM 2011 -Outlook-Clients ein Registrierungsschlüssel festgelegt werden. Dies kann auch zur Verringerung des gesamten Netzwerkdatenverkehrs beitragen, der von einem Microsoft Dynamics CRM 2011-Server auf einen Microsoft Dynamics CRM 2011 Outlook-Clientcomputer gesendet wird.

Wenn dieser Wert auf "1" festgelegt ist, können die Benutzer die Ansichten weiterhin anheften. die Abfrage wird jedoch an den CRM Server gesendet, um die Ergebnisse abzurufen, anstatt sie aus dem lokalen Cache abzurufen.

Wichtig Dieser Abschnitt, diese Methode oder Aufgabe enthält Schritte, die Ihnen mitteilen, wie Sie die Registrierung ändern. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher ist es wichtig, bei der Ausführung der folgenden Schritte sorgfältig vorzugehen. Als Schutzmaßnahme sollten Sie vor der Bearbeitung der Registrierung eine Sicherungskopie erstellen. So ist gewährleistet, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Wenn Sie weitere Informationen zum Sichern und Wiederherstellen der Registrierung erhalten möchten, klicken Sie auf die folgende Artikelnummer, um den Artikel in der Microsoft Knowledge Base zu lesen:
322756Sichern und Wiederherstellen der Registrierung in Windows Um uns das Problem beheben zu lassen, wechseln Sie zum Abschnitt "Beheben des Problems für


mich". Wechseln Sie zum Abschnitt Problem manuell beheben, falls Sie dieses Problem selbst beheben möchten.

Problem automatisch beheben



Um dieses Problem automatisch zu beheben, klicken Sie auf die Schaltfläche oder den Link zum Beheben des Problems. Klicken Sie dann im Dialogfeld Dateidownload auf Ausführen, und führen Sie die Schritte im Fix it-Assistenten aus.




Notizen

  • Dieser Assistent ist möglicherweise nur in Englisch verfügbar. Die automatische Korrektur funktioniert aber auch für andere Sprachversionen von Windows.

  • Wenn Sie sich nicht an dem Computer befinden, auf dem das Problem auftritt, speichern Sie die Fix it-Lösung auf einem USB-Speicherstick oder einer CD, und führen Sie sie anschließend auf dem vom Problem betroffenen Computer aus.


Wechseln Sie dann zum Abschnitt "Wurde das Problemdadurch behoben?"



Problem manuell beheben

Führen Sie die folgenden Schritte aus, um dieses Problem zu
beheben: 1. Melden Sie sich bei den Microsoft Dynamics CRM 2011 -Outlook-Clientcomputern als Benutzer an, der den Microsoft Dynamics CRM 2011 -Outlook-Client installiert hat.
2. Klicken Sie auf Start und auf Ausführen, geben Sie regedit ein, und klicken Sie auf OK. Navigieren Sie zum Registrierungsschlüssel, und HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie anschließend auf DWORD-Wert (32-Bit).
3. Geben Sie "DisableMapiCaching" ein, und drücken Sie dann die EINGABETASTE.
4. Klicken Sie mit der rechten Maustaste auf "DisableMapiCaching", zeigen Sie auf "Neu", und klicken Sie dann auf "DWORD-Wert".
5. Klicken Sie mit der rechten Maustaste auf "DisableMapiCaching", und klicken Sie dann auf "Ändern".
6. Geben Sie im Feld "Wert" den Wert "1" ein, und klicken Sie dann auf "OK".
7. Beenden Sie den Registrierungs-Editor.


Wurde das Problem behoben?

  • Testen Sie, ob das Problem behoben ist. Wenn das Problem beseitigt ist, sind Sie mit diesem Abschnitt fertig. Wenn das Problem noch nicht behoben ist, wenden Sie sich an den Support.

  • Ihr Feedback ist uns wichtig. Wenn Sie Feedback geben oder Probleme mit dieser Lösung melden möchten, hinterlassen Sie bitte einen Kommentar im Blog "Fixit for me",oder senden Sie uns eine E-Mail-Nachricht.

Weitere Informationen

Updaterollup 6 oder höher muss installiert sein, damit der Registrierungsschlüssel "DisableMapiCaching" funktioniert. Weitere Informationen zum Updaterollup 6 finden Sie unter KB 2600640.


Hinweis: Dieser Registrierungsschlüssel ist ungültig, nachdem Updaterollup 14 angewendet wurde. Dies muss mit dem Tool "OrgDbOrgSettings" aktualisiert werden.

OrgDBOrgSettings Tool für Microsoft Dynamics CRM 2011

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Insider beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×