WCF-Fehler treten auf, wenn Dynamics 365 Clients über einen Lastenausgleich kommunizieren

Dieser Artikel bietet eine Lösung für das Problem, dass Sie möglicherweise Fehler von WCF-basierten Clients erhalten, wenn Microsoft Dynamics 365-Webserver für die Kommunikation über einen Lastenausgleich konfiguriert sind.

Gilt für: Microsoft Dynamics CRM 2011, Microsoft Dynamics CRM 2013
Ursprüngliche KB-Nummer: 2981140

Problembeschreibung

Wenn Microsoft Dynamics 365 Webserver hinter einem Lastenausgleich konfiguriert sind, können Ausnahmen von WCF-basierten Clients wie dem Outlook-Client, Email Router oder SDK-Anwendungen auftreten, wenn die Kommunikation über Webdienste erfolgt. Beispiele für diese Ausnahmen können sein:

Ein nicht gesicherter oder falsch gesicherter Fehler wurde von der anderen Partei empfangen.
SecurityContextException

Ursache

Das Problem tritt aufgrund fehlender oder falsch konfigurierter Persistenzeinstellungen auf dem Lastenausgleich auf. Dies kann zu WCF-Fehlern führen, wenn der Webserver versucht, ein Token zu lesen, das von einem anderen Webserver ausgestellt wurde.

Lösung

Microsoft Dynamics 365 erfordert, dass ip-basierte Persistenz auf dem Lastenausgleich konfiguriert wird.