Microsoft Dynamics CRM für Telefon und Tablets kann aufgrund der Länge von TokenLifetime keine Verbindung mit Dynamics CRM organization herstellen

Dieser Artikel bietet eine Lösung für das Problem, dass Microsoft Dynamics CRM für Telefon und Tablets aufgrund der Länge der TokenLifetime Eigenschaft keine Verbindung mit Dynamics CRM organization herstellen kann.

Gilt für: Microsoft Dynamics CRM 2013, Microsoft Dynamics CRM 2013 Service Pack 1
Ursprüngliche KB-Nummer: 3034570

Problembeschreibung

Beim Versuch, eine Microsoft Dynamics CRM organization in einer der Microsoft Dynamics CRM mobilen Clientanwendungen einzurichten, wechselt die Authentifizierung in eine endlose Schleife, in der die Anwendung anscheinend versucht, eine Authentifizierung durchzuführen, aber nicht abgeschlossen wird.

Ursache

Größer als die Standardwerte für die TokenLifetime Eigenschaft in AD FS für die vertrauende Seite können diese Authentifizierungsschleife verursachen.

Lösung

Der empfohlene Wert des TokenLifetime sollte auf den Standardwert 0 festgelegt werden, d. h. 600 Minuten oder 10 Stunden. Wenn Sie stattdessen die Option SSOLifetime im Verbunddienst verwenden, können Sie verhindern, dass Benutzer ihre Anmeldeinformationen zu oft in diesen Microsoft Dynamics CRM mobilen Anwendungen einführen müssen. Der Standardwert von SSOLifetime beträgt 480 Minuten oder 8 Stunden.

Weitere Informationen

Informationen zum Ändern der SSO-Eigenschaft Lifetime von AD FS finden Sie unter Set-ADFSProperties.

Informationen zum Ändern der TokenLifetime Eigenschaft der ADFS-vertrauenden Seite über PowerShell finden Sie unter Anspruchsbasierte Authentifizierung und Ablauf von Sicherheitstoken.