Problembehandlung für einen teilweise freigegebenen Batch in der Kreditorenbuchhaltung in Microsoft Dynamics SL

Dieser Artikel enthält Lösungen für Fehler, die auftreten, wenn Sie versuchen, einen Batch in Der Kreditorenbuchhaltung in Microsoft Dynamics SL freizugeben.

Gilt für: Microsoft Dynamics SL 2011
Ursprüngliche KB-Nummer: 871362

Problembeschreibung

Wenn Sie versuchen, einen Batch in Kreditorenbuchhaltung in Microsoft Dynamics SL freizugeben, wird der Batch nicht freigegeben. Wenn Sie dies untersuchen, sehen Sie, dass der Batch im Dialogfeld Release AP Batches (03.400.00) eine status teilweise freigegeben hat. Möglicherweise wird eine der folgenden Fehlermeldungen in einem Ereignisprotokoll angezeigt:

Systemmeldung 8888: Unerwarteter Fehler beim Freigeben von Batch %s. Bitte wenden Sie sich an Solomon, um Unterstützung bei diesem Batch zu erhalten.

System Message 6019 : Batch ist nicht im Gleichgewicht und wird nicht freigegeben.

Systemmeldung 6909: Das %s-Element wurde bereits von einem anderen Prozess hinzugefügt. Das Programm muss beendet werden.

Ursache

Es gibt mehrere mögliche Ursachen für die Fehlermeldungen.

Hinweis

Wenn keine der folgenden Ursachen zutrifft, führen Sie ein Debugskript aus. Weitere Informationen zum Ausführen eines Debugskripts finden Sie unter Auflösung 2.

  • Während des Veröffentlichungsprozesses wurde die Verbindung zwischen Microsoft Dynamics SL und der instance von SQL Server unterbrochen. Siehe Auflösung 1.
  • Während des Releasevorgangs haben Sie im Dialogfeld Release-AP-Batches (03.400.00) die Option Abbrechen ausgewählt. Siehe Auflösung 1.
  • Die Fehlermeldung System Message 6909 kann auftreten, wenn Sie versuchen, Überprüfungsabstimmungsbatches aus dem Dialogfeld Abstimmung überprüfen (03.060.00) freizugeben, nachdem Sie versucht haben, den Zeitraum in Post zu ändern.
  • In Microsoft Business Solutions – Solomon 6.0 kann Fehler 7318 dazu führen, dass die Systemmeldung 6909 angezeigt wird.

Lösung

Hinweis

Wenn Sie derzeit Microsoft Dynamics SL 2011 oder höhere Versionen verwenden, können Sie den Batch aus dem Dateneingabebildschirm löschen und ihn erneut eingeben.

Lösung 1

Versuchen Sie erneut, den Batch freizugeben. Gehen Sie dazu wie folgt vor:

  1. Öffnen Sie das Dialogfeld Release AP Batches (03.400.00).
  2. Aktivieren Sie das Kontrollkästchen Ausgewählt neben der Batchnummer, auf die im Ereignisprotokoll verwiesen wird.
  3. Wählen Sie Verarbeitung beginnen aus.

Lösung 2

Wenn Sie Microsoft SQL Server 2000 ausführen, führen Sie das AP_6019_DEBUG-Skript in SQL Query Analyzer aus, und senden Sie dann die Skriptergebnisse und das Ereignisprotokoll an microsoft Customer Support Services. Führen Sie dazu die folgenden Schritte aus. Es ist auch ein Video verfügbar, das den Prozess der Ausführung des AP-Debugskripts schrittweise durchläuft:

  1. Laden Sie die AP_6019_DEBUG.sql-Datei herunter.

    Microsoft hat diese Datei auf Viren überprüft. Microsoft verwendete die aktuellste Virenerkennungssoftware, die zum Zeitpunkt der Veröffentlichung der Datei verfügbar war. Die Datei wird auf Servern mit verbesserter Sicherheit gespeichert, die nicht autorisierte Änderungen an der Datei verhindern.

  2. Wählen Sie Start aus, zeigen Sie auf Alle Programme, zeigen Sie auf Microsoft SQL Server, und wählen Sie dann Abfrageanalyse aus.

  3. Geben Sie im Dialogfeld Verbindung mit SQL Server herstellen den Namen des instance SQL Server Namen in das Feld SQL Server ein, und wählen Sie dann SQL Server Authentifizierung aus.

  4. Geben Sie sa in das Feld Anmeldename ein, geben Sie das Kennwort in das Feld Kennwort ein , und wählen Sie dann OK aus.

  5. Wählen Sie auf der Symbolleiste der Abfrageanalyse die Anwendungsdatenbank aus.

  6. Wählen Sie im Menü Extrasdie Option Optionen und dann die Registerkarte Ergebnisse aus.

  7. Wählen Sie im Feld Ziel für Standardergebnissedie Option Ergebnisse in Text aus.

  8. Wählen Sie im Feld Ergebnisausgabeformatdie Option Tabstopptrennzeichen und dann OK aus.

  9. Ersetzen Sie XXXXXX durch Ihre sechsstellige Batchnummer.

  10. Drücken Sie F5, um das Skript auszuführen.

  11. Klicken Sie nach Abschluss der Ausführung des Skripts auf das untere Fenster.

  12. Klicken Sie im Menü Datei auf Speichern unter.

  13. Geben Sie im Feld Dateinameden Namen IncidentAP ein. Ersetzen Sie Incident durch Ihre tatsächliche Incidentnummer.

  14. Wählen Sie im Feld Dateityp die Option Berichtsdateien (*.rpt) und dann Speichern aus.

  15. Zippen Sie diese Datei zusammen mit dem Ereignisprotokoll, und übermitteln Sie die Dateien dann an den Microsoft-Kundendienst.

Wenn Sie Microsoft SQL Server 2005 oder Microsoft SQL Server 2008 ausführen, führen Sie das AP_6019_DEBUG-Skript in SQL Server Management Studio aus, und senden Sie dann die Skriptergebnisse und das Ereignisprotokoll an den Microsoft-Kundendienst. Gehen Sie dazu wie folgt vor:

  1. Laden Sie die AP_6019_DEBUG.sql Debugdatei herunter.

    Die folgende Datei steht im Microsoft Dynamics-Datei-Exchange Server zum Download zur Verfügung: AP_6019_DEBUG.sql.

    Microsoft hat diese Datei auf Viren überprüft. Microsoft verwendete die aktuellste Virenerkennungssoftware, die zum Zeitpunkt der Veröffentlichung der Datei verfügbar war. Die Datei wird auf Servern mit verbesserter Sicherheit gespeichert, die nicht autorisierte Änderungen an der Datei verhindern.

  2. Starten Sie SQL Server Management Studio, melden Sie sich beim Server an, und ändern Sie dann die Ausgabeformatierung. Gehen Sie dazu wie folgt vor:

    1. Klicken Sie im Menü Datei auf Optionen.
    2. Wählen Sie Abfrageergebnisse aus.
    3. Wählen Sie im Feld Standardziel für Ergebnissedie Option Ergebnisse als Text aus.
    4. Erweitern Sie Abfrageergebnisse, und erweitern Sie dann die instance SQL Server.
    5. Wählen Sie Ergebnisse in Text aus.
    6. Wählen Sie im Feld Ausgabeformat die Option Tabstopptrennzeichen aus.
    7. Aktivieren Sie das Kontrollkästchen Spaltenüberschriften in das Resultset einschließen .
    8. Wählen Sie OK aus, um das Dialogfeld Optionen zu schließen.
  3. Wählen Sie im Menü Datei die Option Öffnen aus, suchen Sie die AP_6019_DEBUG.sql Datei, und doppelklicken Sie dann auf die AP_6019_DEBUG.sql Datei.

  4. Ersetzen Sie den Platzhalter XXXXXX durch die sechsstellige Batchnummer des angehaltenen Batches.

  5. Drücken Sie F5.

  6. Klicken Sie nach Abschluss des Skripts mit der linken Maustaste auf den unteren Bereich des Fensters.

  7. Klicken Sie im Menü Datei auf Speichern unter.

  8. Geben Sie im Feld Dateinameden Namen IncidentAP ein.

    Hinweis

    Ersetzen Sie den Platzhalter Incident durch die Batchnummer des angehaltenen Batches.

  9. Wählen Sie im Feld Dateityp die Option Berichtsdateien (*.rpt) aus.

  10. Klicken Sie auf Speichern.

  11. Komprimieren Sie die Datei.

  12. Übermitteln Sie die komprimierte Datei zusammen mit dem Ereignisprotokoll an den Microsoft-Kundendienst.

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