Problembeschreibung

Probleme bei der Migration einer Sicherung von SQL Server Connector für Microsoft Azure Key Vault 1.0.4.0 oder früher auf SQL Server Connector für Microsoft Azure Key Vault 1.0.5.0.

Ursache

Ein Update wurde in Version 1.0.5.0 von SQL Server Connector für Microsoft Azure Key Vault ändertwie Fingerabdrücke berechnet. In 1.0.5.0, diese Berechnung entspricht der Logik, die vom Programm-Modul zur Unterstützung des folgenden Migrationsszenario:

Von: Lokale Microsoft SQL Server, die erweiterbare Key Management (EKM)

An: Microsoft Azure SQL-Datenbank, schalten Sie Ihren eigenen Schlüssel (BYOK) Unterstützung für Transparente Data Encryption (DSA) verwendet

Aufgrund dieser Änderung können Sie Probleme beim Wiederherstellen von Datenbank-Backups von Version 1.0.4.0 oder früher.

Lösung

Kopieren von SQL Server Connector für Microsoft Azure Key Vault 1.0.4.0 oder früher sql2 Instanz Server.

  1. Führen Sie die folgende Abfrage auf dem Server sql2 CRYPTOGRAPHIC PROVIDER, Version 1.0.4.0 ändern.

    ALTER CRYPTOGRAPHIC PROVIDER AzureKeyVaultProvider

    = DATEI

    "Dateipfad\dateiname\SQL Server Connector für Microsoft Azure Schlüssel Vault\1.0.4.0\Microsoft.AzureKeyVaultService.EKM.dll"

  2. Mithilfe der 1.0.4.0 einen neuen asymmetrischen Schlüssel Anbieter.

    ASYMMETRISCHE SCHLÜSSEL TDE_KEY_1040 ERSTELLEN

    VOM PROVIDER AzureKeyVaultProvider

    MIT PROVIDER_KEY_NAME = 'key1'

    CREATION_DISPOSITION = OPEN_EXISTING

    Jetzt werden kann die Sicherung wiederhergestellt.

  3. Führen Sie die folgende Abfrage auf sql2 CRYPTOGRAPHIC PROVIDER, Version 1.0.5.0 wiederherzustellen.

    ALTER CRYPTOGRAPHIC PROVIDER AzureKeyVaultProvider

    = DATEI

    "Dateipfad\dateiname\SQL Server Connector für Microsoft Azure Schlüssel Vault\1.0.5.0\Microsoft.AzureKeyVaultService.EKM.dll"

  4. Zu den neuen Fingerabdruck zu verwenden, führen Sie die folgende Abfrage mit den gleichen asymmetrischen Schlüssel oder die neue Version asymmetrischen Schlüssel.

    Datenbank-CHIFFRIERSCHLÜSSEL ändern

    Verschlüsselung mit ASYMMETRISCHEN Schlüssel KeyName1050Version SERVER

Weitere Informationen

Angenommen Sie, die folgenden Instanzen von Microsoft SQL Server bereitzustellen:

  • SQL Server-Instanz sql1 hat SQL Server Connector für Microsoft Azure Key Vault 1.0.4.0 bereitgestellt.

  • SQL Server-Instanz sql2 hat SQL Server Connector für Microsoft Azure Key Vault 1.0.5.0 bereitgestellt.

Die folgende Abfrage zum Erstellen von Instanzen der sql1 und sql2 einen ASYMMETRISCHEN Schlüssel aus den gleichen ASYMMETRISCHEN Schlüssel in Azure Key Vault bereitstellen.

CREATE ASYMMETRIC KEY TDE_KEY

FROM PROVIDER AzureKeyVaultProvider

WITH PROVIDER_KEY_NAME = 'key1',

CREATION_DISPOSITION = OPEN_EXISTING

Beachten Sie, dass die Fingerabdrücke abweicht. Version 1.0.5.0 Fingerabdruck ist länger als der Fingerabdruck Version 1.0.4.0.

Beispiel für 1.0.4.0 Fingerabdruck:

- 0x2C5677D76F76D77F80

Beispiel für Version 1.0.5.0 Fingerabdruck:

- 0x373B314B78E8D59A0925494558FEF14B726216C5

Hinweis   Beide asymmetrische Schlüssel werden von derselben Quelle erstellt.

Problem bei der Sicherung und Wiederherstellung führt.

Beispiel:

  • Sie haben eine Sicherung, die durch einen asymmetrischen Schlüssel in Azure Key Vault sql1 Instanz verschlüsselt.

  • Sql2 Instanz hat einen asymmetrischen Schlüssel erstellt.

Beim Wiederherstellen der Sicherung sql2 Instanz die Wiederherstellung schlägt fehl und gibt eine Fehlermeldung zurück, die der folgenden ähnelt:

Msg 33111, Ebene 16, Status 4, Zeile Zeilennummer

Server asymmetrischen Schlüssel mit dem Fingerabdruck '0x2C5677D76F76D77F80' wurde nicht gefunden.

Die Abfrage den Fingerabdruck jedes Schlüssels abrufen lautet wie folgt:

select thumbprint,* from master.sys.asymmetric_keys

Abfrage den Fingerabdruck bedeutsam TDE abgerufen lautet wie folgt:

select DatabaseName(ddek.database_id) as DatabaseName,ak.name as[Asymmetric key Name], ak.thumbprint From sys.dm_database_encryption_keys ddek inner join master.sys.asymmetric_keys ak on ak.thumbprint=ddek.encryptor_thumbprint

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

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