Meldung "Zugriff verweigert" im Berichts-Viewer im Business Portal für Microsoft Dynamics SL

Dieser Artikel bietet eine Lösung für eine Meldung Vom Zugriff verweigert, die angezeigt wird, wenn Sie versuchen, einen Bericht mithilfe des Berichts-Viewers auf einer Geschäftsportal-Centerseite zu drucken oder zu exportieren.

Gilt für: Microsoft Dynamics SL 2011
Ursprüngliche KB-Nummer: 2790389

Problembeschreibung

Wenn Sie versuchen, einen Bericht mithilfe des Berichts-Viewers auf einer Business Portal Center-Seite zu drucken oder zu exportieren, erhalten Sie möglicherweise eine Fehlermeldung, die der folgenden ähnelt:

Zugriff verweigert. Fehler in Datei 6d948fe1-9c3d-4b8b-ae1c-e960e689072d {0CAC72C2-BC49-43B9-83A4-85D206A99313}.rpt: Zugriff auf Berichtsdatei verweigert. Ein anderes Programm kann es verwenden.

Ursache

Der Berichts-Viewer verfügt nicht über Leseberechtigungen für das temporäre Verzeichnis im Profil der Anwendungspoolidentität.

Lösung

Erstellen Sie ein Windows-Profil für die Anwendungspoolidentität auf dem Webserver, und weisen Sie dann der Gruppe Jeder leseberechtigungen für das temporäre Verzeichnis zu, das im Profil enthalten ist. Gehen Sie dazu wie folgt vor:

  1. Melden Sie sich mit den Windows-Anmeldeinformationen der Anwendungspoolidentität, die der Website zugeordnet ist, auf der das Business Portal installiert ist, beim Webserver an, auf dem Business Portal installiert ist.

  2. Navigieren Sie zum temporären Verzeichnis im Profil der Anwendungspoolidentität. C:\Users\<USER NAME>\AppData\Local\Temp

  3. Klicken Sie mit der rechten Maustaste auf das Verzeichnis Temp, und wählen Sie dann Eigenschaften aus.

  4. Wählen Sie auf der Registerkarte Sicherheitdie Option Bearbeiten und dann Hinzufügen aus.

  5. Wählen Sie Speicherorte aus, suchen Sie den Namen des Webservers, und wählen Sie dann OK aus.

  6. Geben Sie im Feld Geben Sie die zu markierenden Objektnamen ein den Namen Jeder ein, und wählen Sie dann OK aus.

  7. Wählen Sie Übernehmen und dann OK aus.

Weitere Informationen

Führen Sie die folgenden Schritte aus, um den Namen des Identitätsbenutzers für den Anwendungspool zu ermitteln, der von Business Portal verwendet wird:

  1. Wählen Sie Start, Alle Programme, Verwaltung und dann Internetinformationsdienste-Manager aus.

  2. Erweitern Sie im IIS-Manager den Servernamen, und wählen Sie dann Anwendungspools aus.

  3. Klicken Sie mit der rechten Maustaste auf den Namen des Anwendungspools, der der Website zugeordnet ist, auf der das Geschäftsportal gehostet wird, wählen Sie Erweiterte Einstellungen aus, und notieren Sie sich den Wert Identität .