Verwendung von XML Notepad zur Erstellung eines XML-Dokuments


Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
296560 How to use XML Notepad to create an XML document

Zusammenfassung


Microsoft XML Notepad ist eine Anwendung, die Ihnen die schnelle und einfache Erstellung und Bearbeitung von XML-Dokumenten ermöglicht. Mit diesem Tool wird die Struktur Ihrer XML-Daten in grafischer Form in einer Baumstruktur angezeigt. Es werden zwei Fenster angezeigt: ein Fenster für die Struktur und eines für die Werte. Sie können Elemente, Attribute, Kommentare und Text zum XML-Dokument hinzufügen, indem Sie im linken Fenster die Baumstruktur erstellen und Werte in den entsprechenden Textfeldern des rechten Fensters eingeben.

Weitere Informationen


Gehen Sie folgendermaßen vor, um mit XML Notepad ein wohlgeformtes XML-Dokument zu erstellen:
  1. Klicken Sie zum Öffnen von XML Notepad auf Start, zeigen Sie auf Programme, zeigen Sie auf Microsoft XML Notepad, und klicken Sie auf Microsoft XML Notepad. Zwei Fenster werden angezeigt. Im Fenster "Structure" (Struktur) auf der linken Seite wird der Anfang einer XML-Baumstruktur angezeigt, in der ein Stammelement (Root_Element) und ein untergeordnetes Element (Child_Element) bereits erstellt wurden. Im Fenster "Values" (Werte) können in leeren Textfeldern entsprechende Werte eingegeben werden.
  2. Ändern Sie das Stammelement auf "Catalog" und das untergeordnete Element auf "Book", und fügen Sie ein Attribut und drei untergeordnete Elemente zum untergeordneten Element "Book" hinzu. Hinweis: Fügen Sie die folgenden Werte ohne Apostroph ein. XML Notepad fügt Apostrophe je nach Anforderungen Ihres XML-Dokuments ein.

    1. Um ein Attribut für "Book" einzufügen, klicken Sie mit der rechten Maustaste auf Book, zeigen Sie auf Insert (Einfügen), und klicken Sie auf Attribute (Attribut). Geben Sie neben dem Würfelsymbol ID ein. Markieren Sie ID und geben Sie Bk101 im entsprechenden Textfeld im Wertefenster ein.
    2. Klicken Sie mit der rechten Maustaste auf das Ordnersymbol neben "Book", zeigen Sie auf Insert (Einfügen), und klicken Sie auf Child Element (Untergeordnetes Element). Ein Blattsymbol wird angezeigt. Geben Sie neben diesem Symbol Author (Autor) ein und dann im entsprechenden Textfeld im Wertefenster Gambardella, Matthew.
    3. Fügen Sie zwei weitere untergeordnete Elemente hinzu: Title und Genre. Geben Sie in den entsprechenden Textfeldern im Wertefenster XML Developer's Guide und Computer ein.
  3. Klicken Sie mit der rechten Maustaste auf ein vorhandenes "Book"-Element, und klicken Sie auf Duplicate (Duplizieren), um ein weiteres untergeordnetes Element zum Stammknoten hinzuzufügen. Geben Sie die gewünschten Werte ein.
  4. Markieren Sie den Knoten, zu dem Sie einen Textknoten hinzufügen möchten, um Text zu vorhandenen Elementen hinzuzufügen. Klicken Sie im Menü Insert (Einfügen) auf Text.
  5. Markieren Sie den Knoten, nach dem oder in dem der Kommentar eingefügt werden soll, um Kommentare zu vorhandenen Elementen hinzuzufügen. Klicken Sie im Menü Insert (Einfügen) auf Comment (Kommentar). Wenn der markierte Knoten erweitert ist, wird der Kommentar innerhalb des markierten Knotens eingefügt. Wenn der markierte Knoten komprimiert ist, wird der Kommentar nach dem markierten Knoten eingefügt.
  6. Wenn Sie den Typ eines Knotens ändern möchten, markieren Sie diesen Knoten. Zeigen Sie im Menü Tools (Extras) auf Change To (Ändern zu), und klicken Sie auf den gewünschten Typ.

    Hinweis: Sie können den Typ des Stammknotens oder den Typ von Knoten mit untergeordneten Elementen nicht ändern.
  7. Klicken Sie im Menü View (Ansicht) auf Source (Quelle), um die XML-Quelle anzuzeigen. Die Ausgabe entspricht etwa diesem Beispiel:
    <catalog>
    <book id="bk101">
    <author>Gambardella, Matthew</author>
    <title>XML Developer's Guide</title>
    <genre>Computer</genre>
    text1
    </book>
    <!--Comment1-->
    <book id="bk102">
    <!--Comment2-->
    <author>Ralls, Kim</author>
    <title>Midnight Rain</title>
    <genre>Fantasy</genre>
    </book>
    </catalog>
    Die folgende Meldung wird unten im Fenster "View" (Ansicht) angezeigt (sinngemäß):
    The current XML definition is well formed. (Die aktuelle XML-Definition ist korrekt formuliert).
    Die XML-Deklaration oder Verarbeitungsanweisungen müssen mit einem externen Editor wie z. B. Microsoft Editor hinzugefügt werden.

  8. Klicken Sie im Menü Datei auf Sichern, um das XML-Dokument zu sichern. Klicken Sie im Menü File (Datei) auf Exit (Beenden), um XML Notepad zu beenden.

Informationsquellen


Weitere Informationen finden Sie auf folgenden Websites:
Microsoft Online XML Developer Center
http://msdn2.microsoft.com/de-de/xml/default.aspx

World Wide Web Consortium
http://www.w3.org
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.