Fehlermeldung, wenn Sie das Anwendungsprotokoll auf dem Computer überprüfen, die Microsoft Dynamics AX 4.0 AOS-Dienste ausgeführt wird: "RPC-Ausnahme 1726 trat Sitzung 10"

Gilt für: Microsoft Dynamics AX 4.0Axapta Object Server

Problembeschreibung


Wenn Sie das Anwendungsprotokoll auf einem Computer, die Microsoft Dynamics AX 4.0 Application Object Server (AOS) Services ausgeführt wird überprüfen, möglicherweise Fehlermeldungen angezeigt, die den folgenden ähneln:
Fehlermeldung 1
Typ: Informationen
Ereignis Quelle: Dynamics Server 17
Date:7/4/2007
Zeit: 12:30:14 Uhr
Kategorie: keine
Beschreibung
Objektserver 01: RPC-Fehler: RPC-Ausnahme 1726 in Sitzung 10 ist aufgetreten
Fehlermeldung 2
Typ: Informationen
Ereignis Quelle: Dynamics Server 01
Kategorie: keine
Ereignis-ID:110
Date:7/4/2007
Zeit: 12:30:33 Uhr
User:N/A
Computer:ComputerName
Beschreibung
Objektserver 01: Kein Ping von 10. Beendet die Sitzung.
Die erste Fehlermeldung kann die zweite Fehlermeldung zugeordnet werden. Endet der AOS-Server die Sitzung 10, wird jede Sitzung, die RPC-Fehlermeldungen gibt reagiert. Wenn zu viele Sitzungen reagiert und RPC-Fehlermeldungen, heruntergefahren der AOS-Server.

Ursache


Dieses Problem kann auftreten, da Benutzer Microsoft Dynamics AX nicht ordnungsgemäß beendet. Beispielsweise beendet Benutzer Microsoft Dynamics AX-Prozess mithilfe des Task-Managers.

RPC 1726 ist eine allgemeine Fehlermeldung. Jedoch kann RPC 1726 Fehlermeldung die "kein Ping 10. zugeordnet werden Beenden der Sitzung"Fehlermeldung. In diesem Fall ist das Problem normalerweise Benutzer Microsoft Dynamics AX nicht ordnungsgemäß beenden zurückzuführen.

Problemlösung


Wenn Sie dieses Problem in Microsoft Dynamics AX-Client auftritt, beenden Sie den Client nicht durch Drücken von STRG + ALT + ENTF. Verwenden Sie STRG + UNTBR und warten Sie, bis das System reagiert erneut oder wenden Sie sich an den Microsoft Dynamics AX-Administrator oder ein anderer Benutzer hat Rechte Formular Onlinebenutzer empfohlen. Der Administrator oder der Benutzer kann Sitzung die Clientsitzung Herunterfahren klicken.

Weitere Informationen


Wenn Sie das Problem auf dem AOS-Server ist wichtig, die Sitzung ist und was die Benutzer tun, um das Problem zu bestimmen.

Führen Sie hierzu das folgende Skript:
select * from sysuserlog where logouttime = 0 and sessionid = <X> 
Hinweis Ersetzen Sie < X > Sitzung in der RPC-Fehlermeldung angezeigt wird. Beachten Sie aus den Ergebnissen der Abfrage Spalten ID und COMPUTERNAME . Die Werte der Spalte anzugeben, die in und von wo protokolliert wird.

In der Regel entstehen RPC-Ausnahmen von der Anwendung nicht ordnungsgemäß beendet. Jedoch möglicherweise Ausnahmen auch ein Geschäftsprozess hängen oder sehr lange dauert.

Referenzen


Klicken Sie für weitere Informationen auf die folgende Artikelnummer, um den Artikel in der Microsoft Knowledge Base anzuzeigen:

953375 wie eine Benutzer-ID suchen, mit der Sitzung-ID ist, eine "RPC-Fehler: RPC-Ausnahme 1726 in Sitzung [SessionID] ist aufgetreten" Fehlermeldung im Anwendungsprotokoll auf dem AOS-Server in Microsoft Dynamics AX

953374 erhalten Sie eine Warnung im Anwendungsprotokoll auf dem AOS-Server in Microsoft Dynamics AX: "SPID Sitzungsbezeichner [SessionID] [SPID_number] ist weiterhin in der Datenbank vorhanden. Löschen Sie die SPID aus der Datenbank"