Fehlermeldung beim Entwerfen von Berichten in Microsoft Dynamics NAV 2009: "die RDLC-Datei ist kein wohlgeformtes XML-Dokument"

Gilt für: Dynamics NAV 2009

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Problembeschreibung


Das folgende Szenario in Microsoft Dynamics NAV 2009. Das Layout für einen Bericht im Berichts-Designer ändern. Laden Sie dann das Layout geändert. In diesem Szenario wird die folgende Fehlermeldung angezeigt:
Die RDLC-Datei ist kein wohlgeformtes XML-Dokument.

Darüber hinaus wird das geänderte Layout nicht geladen.

Ursache


Dieses Problem tritt auf, wenn der Pfad des temporären Ordners regionale Zeichen oder ß, Á, Æ, Å Ø enthält. Der Pfad des temporären Ordners kann basierend auf der Benutzer-ID generiert werden. Daher tritt dieses Problem auch die Benutzer-ID regionale Zeichen enthält.

PROBLEMUMGEHUNG


Um dieses Problem zu umgehen, ändern Sie die TEMP und TMP Umgebungsvariablen auf Ordner, die keine regionalen Zeichen.

Problemlösung


Ein unterstützter Hotfix ist inzwischen von Microsoft erhältlich. Der Hotfix behebt das in diesem Artikel beschriebene Problem. Wenden Sie den Hotfix nur auf Systeme, bei die dieses spezielle Problem auftritt.

Um dieses Problem sofort beheben möchten, wenden Sie sich an Ihre Microsoft Dynamics-Partner oder den technischen Support für Microsoft Dynamics und zugehörige Produkte, um den Hotfix zu erhalten. Haben Sie Onlinesupport kann Anmeldung bei Microsoft Dynamics Website und eine neue Supportanfrage erstellen. Zu diesem Zweck besuchen Sie die folgende Microsoft-Website:Sie können auch technischen Support für Microsoft Dynamics und zugehörige Produkte telefonisch. Zu diesem Zweck besuchen Sie die folgende Microsoft-Website:

PartnerKundenIn besonderen Fällen bestimmt Gebühren fallen normalerweise Support aufrufen Wenn Experte Support für Microsoft Dynamics und zugehörige Produkte storniert werden können, dass ein bestimmtes Update Ihr Problem behebt. Die normalen Supportkosten gilt für zusätzliche Fragen und Problemen, die nicht für das betreffende Update qualifizieren.



Beziehen des Microsoft Dynamics NAV-Hotfixes oder Dateien aktualisieren

Nachdem Sie einen Microsoft Dynamics NAV-Hotfix oder eine Updatedatei vom technischen Support für Microsoft Dynamics angefordert, werden ein Hyperlink in einer E-mail erhalten Sie.


Die E-mail enthält einen Hyperlink und ein Kennwort. Hyperlinks können Sie den Microsoft Dynamics NAV-Hotfix oder die Updatedateien herunterladen. Wenn Sie auf den Hyperlink klicken, öffnet das Dialogfeld Dateidownload-Sicherheitshinweis . Dann werden Sie ausführen, speichern oder den Download Abbrechen.


Wenn Sie auf Ausführenklicken, den Download und die Extraktion der Dateien gestartet. Sie müssen einen Ordner für die neuen Dateien und geben Sie das Kennwort.


Wenn Sie auf Speichernklicken, müssen Sie einen Pfad zum Speichern der komprimierten Datei angeben. Beim Öffnen der Datei, die Sie gespeichert, werden Sie aufgefordert, einen Pfad für die Dateien angeben. Sie müssen das Kennwort in der E-mail angeben.


Wenn Sie auf Abbrechenklicken, wird der Downloadvorgang beendet.



Installieren von Microsoft Dynamics NAV-Hotfix oder eine Updatedatei

Microsoft Dynamics NAV-Plattform Hotfixes und Updates werden als einzelne Dateien zur Verfügung gestellt. Um eine Microsoft Dynamics NAV-Hotfix oder ein Update zu installieren, müssen Sie die vorhandenen Microsoft Dynamics NAV-Installationsdateien mit den Hotfix oder die Updatedateien ersetzen. Gehen Sie hierzu folgendermaßen vor:

Schritt 1: Ersetzen Sie die Installationsdatei für Microsoft Dynamics NAV-client

In Microsoft Dynamics NAV-Client-Installation die folgenden Dateien durch Ersetzen der Hotfix oder Update-Datei.
DateinameDateiversionDateigrößeDatumZeitPlattform
Dbm.dll6.0.28463.0444,21625-Jan-200916:37x86
Fin.exe6.0.28463.012,240,71225-Jan-200916:38x86
Finhlink.exe6.0.28463.0452,42425-Jan-200916:38x86
Finsql.exe6.0.28463.012,326,72025-Jan-200916:38x86
Nc_netb.dll6.0.28463.0108,35225-Jan-200916:38x86
Nc_tcp.dll6.0.28463.0108,35225-Jan-200916:38x86
Nc_tcps.dll6.0.28463.0153,42425-Jan-200916:38x86
Ndbcs.dll6.0.28463.01,337,15225-Jan-200916:37x86
Slave.exe6.0.28463.0161,60025-Jan-200916:38x86

Hinweis Microsoft Dynamics NAV-Client ist in der Regel im folgenden Verzeichnis installiert.


C:\Programme\Microsoft c:\Programme\Microsoft Dynamics NAV\60\Classic

Ersetzen Sie die vorhandenen Microsoft Dynamics NAV-Dateien gehen Sie folgendermaßen vor:
  1. Schließen Sie Microsoft Dynamics NAV.
  2. Suchen Sie das Installationsverzeichnis des Microsoft Dynamics NAV-Client.
  3. Kopieren Sie die heruntergeladenen Dateien.
  4. Fügen Sie die heruntergeladenen Dateien in das Installationsverzeichnis des Microsoft Dynamics NAV-Client.
  5. Klicken Sie im Dialogfeld Ersetzen von Dateien bestätigen auf Ja, um die Dateien im Installationsverzeichnis überschreiben.

Schritt 2: Ersetzen Sie die Installationsdatei für Microsoft Dynamics NAV-Datenbankserver

Wenn Sie Native-Option in Microsoft Dynamics NAV-Datenbankserver-Installation ausführen, ersetzen Sie die folgenden Dateien mit den Hotfix oder Update-Datei.

Hinweis Wenn Sie die Option SQL ausführen, überspringen Sie diesen Schritt.
DateinameDateiversionDateigrößeDatumZeitPlattform
Dbm.dll6.0.28463.0444,21625-Jan-200916:37x86
Nc_netb.dll6.0.28463.0108,35225-Jan-200916:38x86
Nc_tcp.dll6.0.28463.0108,35225-Jan-200916:38x86
Nc_tcps.dll6.0.28463.0153,42425-Jan-200916:38x86
Slave.exe6.0.28463.0161,60025-Jan-200916:38x86

Gehen Sie folgendermaßen vor, um diese Dateien zu ersetzen:
  1. Suchen Sie das Installationsverzeichnis des Microsoft Dynamics NAV-Datenbankserver.



    Hinweis Microsoft Dynamics NAV Database Server wird in der Regel im folgenden Verzeichnis installiert:
    C:\Programme\Microsoft c:\Programme\Microsoft Dynamics NAV\60\Database Server\
  2. Beenden Sie Microsoft Dynamics NAV Database Server, wenn er ausgeführt wird.
  3. Kopieren Sie die heruntergeladenen Dateien.
  4. Fügen Sie die Dateien in das Installationsverzeichnis des Microsoft Dynamics NAV-Server heruntergeladen.
  5. Wenn Sie aufgefordert werden, klicken Sie auf Ja, um die Dateien im Installationsverzeichnis überschreiben.
  6. Starten Sie Microsoft Dynamics NAV-Datenbankserver.

Schritt 3: Ersetzen Sie die Installationsdatei für Microsoft Dynamics NAV Application Server

Ersetzen Sie in der Microsoft Dynamics NAV Application Server-Installation die folgenden Dateien.
DateinameDateiversionDateigrößeDatumZeitPlattform
Dbm.dll6.0.28463.0444,21625-Jan-200916:37x86
Nas.exe6.0.28463.02,070,32825-Jan-200916:38x86
Nassql.exe6.0.28463.02,152,27225-Jan-200916:38x86
Nc_netb.dll6.0.28463.0108,35225-Jan-200916:38x86
Nc_tcp.dll6.0.28463.0108,35225-Jan-200916:38x86
Nc_tcps.dll6.0.28463.0153,42425-Jan-200916:38x86
Ndbcs.dll6.0.28463.01,337,15225-Jan-200916:37x86
Slave.exe6.0.28463.0161,60025-Jan-200916:38x86
Gehen Sie folgendermaßen vor, um die Dateien zu ersetzen.
  1. Beenden Sie Microsoft Dynamics NAV Application Server.
  2. Suchen Sie das Microsoft Dynamics NAV Application Server-Installationsverzeichnis.


    Hinweis Microsoft Dynamics NAV Application Server wird in der Regel im folgenden Verzeichnis installiert:
    C:\Programme\Microsoft c:\Programme\Microsoft Dynamics NAV\60\Application Server\
  3. Kopieren Sie die heruntergeladenen Dateien.
  4. Fügen Sie die heruntergeladenen Dateien in Microsoft Dynamics NAV Application Server-Installationsverzeichnis.
  5. Klicken Sie auf Ja, um die Dateien im Verzeichnis überschreiben.
  6. Starten Sie Microsoft Dynamics NAV Application Server.

Schritt 4: Ersetzen Sie die Installationsdatei für Microsoft Dynamics NAV ODBC-Treiber

Wenn Sie Microsoft Dynamics NAV ODBC-Treiber installiert haben, ersetzen Sie die folgenden Dateien der Microsoft Dynamics NAV ODBC-Treiber-Installation.
DateinameDateiversionDateigrößeDatumZeitPlattform
Dbm.dll6.0.28463.0444,21625-Jan-200916:37x86
Nc_netb.dll6.0.28463.0108,35225-Jan-200916:38x86
Nc_tcp.dll6.0.28463.0108,35225-Jan-200916:38x86
Nc_tcps.dll6.0.28463.0153,42425-Jan-200916:38x86
Slave.exe6.0.28463.0161,60025-Jan-200916:38x86
Gehen Sie folgendermaßen vor, um die Dateien zu ersetzen.
  1. Suchen Sie das Installationsverzeichnis von Microsoft Dynamics NAV ODBC-Treiber.


    Hinweis Microsoft Dynamics NAV ODBC-Treiber wird in der Regel im folgenden Verzeichnis installiert:
    C:\Programme\Microsoft c:\Programme\Microsoft Dynamics NAV\60\ODBC
  2. Kopieren Sie die heruntergeladenen Dateien.
  3. Fügen Sie die heruntergeladenen Dateien in das Installationsverzeichnis von Microsoft Dynamics NAV ODBC-Treiber.
  4. Klicken Sie auf Ja, um die Dateien im Verzeichnis überschreiben.

Status


Microsoft hat bestätigt, dass es einen Fehler in den Microsoft-Produkten gibt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen


Klicken Sie für weitere Informationen auf die folgende Artikelnummer, um den Artikel in der Microsoft Knowledge Base anzuzeigen:

824684 Erläuterung von der standardmäßigen Standardbegriffen bei Microsoft Softwareupdates

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