Fehlermeldungen im Bildschirm "Database Maintenance (98.290.00)" Microsoft Dynamics SL 7.0: "Nicht behandelte Ausnahme" und "Laufzeitfehler 429"

Gilt für: Dynamics SL 2011

Problembeschreibung


Wenn Sie versuchen, einen Updateszenarien im Bildschirm Wartung (98.290.00) Microsoft Dynamics SL ausführen, erhalten Sie eine der folgenden Fehlermeldungen angezeigt:



Nachricht 1
Nicht behandelte Ausnahme in einer Anwendung. Wenn Sie auf Weiter klicken, wird die Anwendung diesen Fehler ignorieren und weiterhin versuchen. Wenn Sie auf Beenden klicken, wird die Anwendung sofort beendet.



Die COM-Klassenfactory für die Komponente mit CLSID abrufen

[A440BD76-CFE - 4D 46-AB1F-15F238437A3D] konnte aufgrund des folgenden Fehlers: 80040154.
Nachricht 2
Laufzeitfehler 429 "kann keine ActiveX-Komponente Objekt erstellen"

Die COM-Klassenfactory für die Komponente mit CLSID {10020200-E260-11CF-AE68-00AA004A34d} abrufen

Ursache


1. dieses Problem tritt auf, weil die SQLDMO.dll-Datei nicht auf dem lokalen Computer registriert ist.


2. dieses Problem tritt auf, weil die Datei Capicom.dll nicht auf dem lokalen Computer registriert ist.

Problemlösung


Verwenden Sie eine oder mehrere der folgenden Lösungsvorschläge entsprechend Ihrer Situation.

Lösung 1

Registrieren Sie die Datei SQLDMO.dll manuell. Gehen Sie hierzu folgendermaßen vor:
  1. Suchen Sie die SQLDMO.dll auf dem lokalen Computer. Standardmäßig befindet sich diese Datei im Ordner c:\Program Files\Microsoft SQL Server\MSSQL\80\Tools\Binn.
  2. Maustaste auf SQLDMO.dll Datei und klicken Sie dann auf Öffnen mit.

  3. Klicken Sie im Dialogfeld Windows klicken Sie auf Programm aus einer Liste auswählen, und klicken Sie auf OK.

  4. Klicken Sie im Dialogfeld Öffnen mit auf Durchsuchen.

  5. Suchen Sie und öffnen Sie folgenden Ordner:
    Systemlaufwerk : \Windows\System32.
  6. Doppelklicken Sie auf die Datei Regsvr32.exe, und klicken Sie dann auf OK.

  7. Klicken Sie auf OK , wenn die folgende Meldung angezeigt wird:
    RegSvr32 - erfolgreich DllRegisterServer in SQLDMO.dll.
Hinweis Wenn SQLDMO.dll-Datei kann nicht registriert oder keine SQLDMO.dll-Datei in das Binn-Verzeichnis vorhanden ist, fahren Sie mit "Lösung 3".


Lösung 2

  1. Suchen Sie die Datei CAPICOM.dll auf dem lokalen Computer. Diese Datei wird standardmäßig in Systemlaufwerk : \Windows\System32.
  2. Die Datei CAPICOM.dll Maustaste Klicken
  3. Klicken Sie im Dialogfeld Windows klicken Sie auf Programm aus einer Liste auswählen, und klicken Sie auf OK.
  4. Klicken Sie im Dialogfeld Öffnen mit auf Durchsuchen.
  5. Suchen und öffnen Sie folgenden Ordner: Systemlaufwerk : \Windows\System32.
  6. Doppelklicken Sie auf die Datei Regsvr32.exe, und klicken Sie dann auf OK.
  7. Klicken Sie auf OK , wenn die folgende Meldung angezeigt wird:
    RegSvr32 - erfolgreich DllRegisterServer in CAPICOM.dll.

Hinweis Wenn SQLDMO.dll-Datei kann nicht registriert oder keine SQLDMO.dll-Datei im Verzeichnis vorhanden ist, fahren Sie mit "Lösung 4".

Lösung 3

SQLDMO.dll-Datei kann nicht registriert werden oder es ist keine Datei SQLDMO.dll im Verzeichnis Binn, kann dies bedeuten, dass das Binn-Verzeichnis unvollständig ist. Ist dies der Fall, kopieren Sie das Verzeichnis Binn von einer Workstation arbeiten und das Binn-Verzeichnis auf der Arbeitsstation, der der Fehler aufgetreten. Führen Sie Lösung 1.

Liegen keine anderen Arbeitsstationen aus dem Sie können das Binn-Verzeichnis zu das Verzeichnis Binn neu Microsoft Dynamics SL Unterstützung erhalten.


Resolution 4

Die Datei CAPICOM.dll kann nicht registriert werden oder die Datei fehlt, gehen Sie zu dem Server oder einer anderen Maschine kopieren Sie die Datei CAPICOM.dll aus dieser Quelle und Einfügen auf der Arbeitsstation wurden Fehler erhielt. Führen Sie Lösung 2.

Liegen keine anderen Arbeitsstationen aus dem Sie können CAPICOM.dll, erhalten Sie Hilfe beim Abrufen der Datei CAPICOM.dll Microsoft Dynamics SL-Unterstützung.

Hinweis Normale Steueranspruch Richtlinien anwenden, wenn eine Support-Anfrage initiiert wird.