Der Postfachalias eines Benutzers enthält die "?" Zeichen unerwartet nach dem Ausführen des Cmdlets "Enable-Mailbox" um ein Postfach für den Benutzer in einer Exchange Server 2010-Umgebung erstellen

Gilt für: Exchange Server 2010 StandardMicrosoft Exchange Server 2010 Enterprise

Problembeschreibung


In einer Microsoft Exchange Server 2010-Umgebung führen Sie Enable-Mailbox -Cmdlet zum Erstellen eines Postfachs für einen vorhandenen Active Directory-Benutzer. Postfach-Alias des Benutzers enthält das Zeichen "?" jedoch unerwartet beendet. Dieses Problem tritt auf, wenn Folgendes zutrifft:
  • Enable-Mailbox -Cmdlet ohne Alias Parameter ausführen.
  • Der Anzeigename des Benutzers enthält das Zeichen ",".

Ursache


Dieses Problem tritt auf, weil das Enable-Mailbox -Cmdlet in Exchange Server 2010 wird Postfach-Alias des Benutzers, der den Anzeigenamen des Benutzers anhand der Alias -Parameter nicht angegeben ist. Das Zeichen "," ist jedoch kein gültiges Zeichen für den Alias -Parameter. Daher enthält der Anzeigenamen dieses Zeichen, konvertiert Exchange Server 2010 das Zeichen "?"-Zeichen.

Problemlösung


Installieren Sie zum Beheben dieses Problems das folgende Updaterollup:
2425179 Beschreibung des Updaterollup 2 für Exchange Server 2010 Servicepack 1

PROBLEMUMGEHUNG


Es gibt zwei Methoden, um dieses Problem zu umgehen.
  1. Mit Exchange-Verwaltungskonsole:
    Sie können ein Postfach für ein einzelnes Benutzerkonto gleichzeitig aktivieren. So können Sie den Postfachalias angeben. Weitere Informationen zum Aktivieren eines Postfachs für einen vorhandenen Benutzer in Exchange-Verwaltungskonsole finden Sie auf folgender Microsoft-Website:
    Hinweis aktivieren Postfächer für mehrere Benutzer gleichzeitig unterbindet die Postfachattribute Alias angeben. Postfach-Aliase können Exchange Server 2010 nicht ordnungsgemäß generiert werden.
  2. Mithilfe der Exchange-Verwaltungsshell:
    Sie können Alias -Parameter angeben, wenn Sie Enable-Mailbox -Cmdlet in der Exchange-Verwaltungsshell ausführen. Weitere Informationen über das Cmdlet " Enable-Mailbox " finden Sie auf folgender Microsoft-Website:

Status


Microsoft hat bestätigt, dass es sich um ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt „Eigenschaften“ aufgeführt sind.