Πώς μπορείτε να χρησιμοποιήσετε μια μακροεντολή για να προσθέσετε ετικέτες σε σημεία δεδομένων σε ένα γράφημα διασποράς xy ή σε ένα γράφημα φυσαλίδας στο Excel

Σύνοψη

Στο Microsoft Excel, δεν υπάρχει ενσωματωμένη εντολή που συνδέεται αυτόματα ετικέτες κειμένου σημεία δεδομένων σε ένα γράφημα (διασποράς) ή φυσαλίδας. Ωστόσο, μπορείτε να δημιουργήσετε ένα Microsoft Visual Basic για εφαρμογές μακροεντολή που εκτελεί αυτή τη διαδικασία. Αυτό το άρθρο περιέχει ένα δείγμα μακροεντολής που εκτελεί αυτήν την εργασία σε ένα γράφημα διασποράς XY. Ωστόσο, μπορεί να χρησιμοποιηθεί το ίδιο κωδικό για ένα γράφημα φυσαλίδας.

Περισσότερες πληροφορίες

Η Microsoft παρέχει παραδείγματα προγραμματισμού μόνο για επεξήγηση, χωρίς καμία εγγύηση, είτε σιωπηρή είτε ρητή. Αυτό περιλαμβάνει, ενδεικτικά, τις σιωπηρές εγγυήσεις εμπορευσιμότητας ή καταλληλότητας για συγκεκριμένο σκοπό. Αυτό το άρθρο προϋποθέτει ότι είστε εξοικειωμένοι με τη γλώσσα προγραμματισμού που παρουσιάζεται, καθώς και με τα εργαλεία που χρησιμοποιούνται για τη δημιουργία διαδικασιών και τον εντοπισμό σφαλμάτων σε αυτές. Οι μηχανικοί υποστήριξης της Microsoft μπορούν να σας εξηγήσουν τη λειτουργικότητα μιας συγκεκριμένης διαδικασίας. Ωστόσο, δεν θα τροποποιήσουν αυτά τα παραδείγματα για να παράσχουν πρόσθετες λειτουργίες, ούτε θα δημιουργήσουν διαδικασίες για να καλύψουν τις συγκεκριμένες απαιτήσεις σας. Του δείγματος κώδικα σε αυτό το άρθρο προϋποθέτει ότι τα δεδομένα και τις ετικέτες, που συσχετίζονται είναι διατεταγμένα σε ένα φύλλο εργασίας σύμφωνα με την ακόλουθη μορφή:
  • Η πρώτη στήλη περιέχει τις ετικέτες δεδομένων.
  • Στη δεύτερη στήλη περιέχει τις τιμές x του γραφήματος xy (διασποράς).
  • Η τρίτη και επόμενες στήλες περιέχουν τις τιμές y για το γράφημα xy (διασποράς).
ΣΗΜΕΊΩΣΗ: Αν και το παράδειγμα που περιέχει μόνο μία στήλη δεδομένων για τις τιμές y, μπορείτε να χρησιμοποιήσετε περισσότερες από μία σειρές δεδομένων.

Για να χρησιμοποιήσετε τις μακροεντολές σε αυτό το άρθρο, δημιουργήστε ένα γράφημα χρησιμοποιώντας τα ακόλουθα δεδομένα:
   A1: Labels       B1: X Values   C1: Y Values
A2: DataPoint1 B2: 12 C2: 5
A3: DataPoint2 B3: 9 C3: 7
A4: DataPoint3 B4: 5 C4: 3
A5: DataPoint4 B5: 4 C5: 8
A6: DataPoint5 B6: 1 C6: 4
ΣΗΜΕΊΩΣΗ: Ο πίνακας πρέπει να περιέχει κενές στήλες και τη στήλη που περιέχει τις ετικέτες δεδομένων δεν πρέπει να διαχωρίζεται από τη στήλη που περιέχει τις τιμές x. Ετικέτες και τιμές πρέπει να είναι διατεταγμένα σε ακριβώς τη μορφή που περιγράφεται σε αυτό το άρθρο. (Το επάνω αριστερό κελί δεν χρειάζεται να είναι το κελί A1.)

Για να επισυνάψετε ετικέτες κειμένου σημεία δεδομένων σε ένα γράφημα xy (διασποράς), ακολουθήστε τα εξής βήματα:
  1. Στο φύλλο εργασίας που περιέχει τα δεδομένα του δείγματος, επιλέξτε την περιοχή κελιών B1:C6.
  2. Στο Microsoft Office Excel 2003 και σε παλαιότερες εκδόσεις του Excel, ακολουθήστε τα εξής βήματα:
    1. Από το μενού " Εισαγωγή ", κάντε κλικ στο γράφημα .
    2. Στο παράθυρο διαλόγου " Οδηγός γραφήματος - Βήμα 1 από 4 - Τύπος γραφήματος ", κάντε κλικ στην καρτέλα " Βασικοί τύποι ". Στην περιοχή Τύπος γραφήματος XY (διασποράς), κάντε κλικ και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.
    3. Στο παράθυρο διαλόγου " Οδηγός γραφήματος - Βήμα 2 από 4 - δεδομένα προέλευσης γραφήματος ", κάντε κλικ στην καρτέλα Περιοχή δεδομένων . Σύμφωνα με τη σειρά, κάντε κλικ στην επιλογή στήλεςκαι, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.
    4. Στο παράθυρο διαλόγου " Οδηγός γραφήματος - Βήμα 3 από 4 - Επιλογές γραφήματος ", κάντε κλικ στο κουμπί " Επόμενο".
    5. Στο παράθυρο διαλόγου " Οδηγός γραφήματος - βήμα 4 από 4 - Θέση γραφήματος ", κάντε κλικ στην επιλογή ως νέο φύλλο εργασίας και, στη συνέχεια, κάντε κλικ στο κουμπί Τέλος.
    Στο Microsoft Office Excel 2007, ακολουθήστε τα εξής βήματα:
    1. Κάντε κλικ στην καρτέλα " Εισαγωγή ", κάντε κλικ στο κουμπί
      Διασπορά στα γραφήματα ομάδα και στη συνέχεια επιλέξτε έναν τύπο.
    2. Στην καρτέλα " Σχεδίαση ", κάντε κλικ στο κουμπί Μετακίνηση γραφήματος στην ομάδα θέση , κάντε κλικ στο κουμπί
      Νέο φύλλο , και στη συνέχεια κάντε κλικ στο κουμπί OK.
  3. Πιέστε το συνδυασμό πλήκτρων ALT + F11 για να ξεκινήσετε την Επεξεργασία Visual Basic.
  4. Στο μενού " Εισαγωγή ", κάντε κλικ στην εντολή " λειτουργική μονάδα".
  5. Πληκτρολογήστε το ακόλουθο δείγμα κώδικα στο φύλλο λειτουργικής μονάδας:
    Sub AttachLabelsToPoints()
    'Dimension variables.
    Dim Counter As Integer, ChartName As String, xVals As String

    ' Disable screen updating while the subroutine is run.
    Application.ScreenUpdating = False

    'Store the formula for the first series in "xVals".
    xVals = ActiveChart.SeriesCollection(1).Formula

    'Extract the range for the data from xVals.
    xVals = Mid(xVals, InStr(InStr(xVals, ","), xVals, _
    Mid(Left(xVals, InStr(xVals, "!") - 1), 9)))
    xVals = Left(xVals, InStr(InStr(xVals, "!"), xVals, ",") - 1)
    Do While Left(xVals, 1) = ","
    xVals = Mid(xVals, 2)
    Loop

    'Attach a label to each data point in the chart.
    For Counter = 1 To Range(xVals).Cells.Count
    ActiveChart.SeriesCollection(1).Points(Counter).HasDataLabel = _
    True
    ActiveChart.SeriesCollection(1).Points(Counter).DataLabel.Text = _
    Range(xVals).Cells(Counter, 1).Offset(0, -1).Value
    Next Counter

    End Sub
  6. Πιέστε το συνδυασμό πλήκτρων ALT + Q για να επιστρέψετε στο Excel.
  7. Μεταβείτε στο φύλλο γραφήματος.
  8. Στο Excel 2003 και σε παλαιότερες εκδόσεις του Excel, τοποθετήστε το δείκτη στη μακροεντολή στο μενού Εργαλεία και, στη συνέχεια, κάντε κλικ στην εντολή μακροεντολές. Κάντε κλικ στο κουμπί AttachLabelsToPointsκαι, στη συνέχεια, κάντε κλικ στην επιλογή Εκτέλεση για να εκτελέσετε τη μακροεντολή.

    Στο Excel 2007, κάντε κλικ στην καρτέλα " Προγραμματιστής ", κάντε κλικ στο κουμπί
    Επιλέξτε μακροεντολή στην ομάδα κώδικας ,
    AttachLabelsToPoints, και στη συνέχεια κάντε κλικ στην επιλογή Εκτέλεση.
Η μακροεντολή επισυνάπτει τις ετικέτες στα κελιά a2: a6 στα σημεία δεδομένων στο γράφημα.
Ιδιότητες

Αναγνωριστικό άρθρου: 213750 - Τελευταία αναθεώρηση: 10 Ιαν 2017 - Αναθεώρηση: 1

Microsoft Office Excel 2007, Microsoft Excel 2002 Standard Edition, Microsoft Excel 2000 Standard Edition, Microsoft Excel 97 Standard Edition, Microsoft Excel X for Mac, Microsoft Excel 2001 για Mac, Microsoft Excel 98 για Macintosh, Microsoft Office Excel 2003, Microsoft Excel 2010

Σχόλια