A connection test in the Conferencing Add-in for Office Outlook is unsuccessful where only an A record is available but no SRV record is available in an Office Communications Server environment

Symptoms

Consider the following scenario:
  • In a Microsoft Office Communications Server (OCS) environment, only an A record for the OCS front-end server is available. No Service Location (SRV) record for automatic client logon is available.
  • You try to use the Test Connection function in the Conferencing Add-in for Office Outlook, which uses automatic discovery.
In this scenario, the connection test is unsuccessful. Therefore, you cannot schedule conference calls in the Conference Add-in for Office Outlook.

Cause

This issue occurs because the result of a DNS query against an A record does not match the corresponding settings on the OCS front-end server. 

Resolution

To fix this problem, install the following cumulative update:
2433228 Description of the update for the Live Meeting Conferencing Add-in for Outlook: November 2010

Workaround

To work around this issue, use one of the following methods:
  • Use an SRV record instead of an A record for the OCS front-end server in the OCS environment. For more information, click the following link to view the Microsoft TechNet article:
     
    Create and Verify DNS Records for Your Server or Pool
  • In Advanced Connection Settings in Conferencing Add-in for Office Outlook, specify the following settings to comply with the settings on the OCS front-end server:
    • Server name and port number.
    • Connection protocol.
    Note: You can also use a Group Policy to automate this step.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
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