Τρόπος αντιμετώπισης κατεστραμμένων εγγράφων του Word για Mac

Σύνοψη

Αυτό το άρθρο παρέχει διαδικασίες αντιμετώπισης προβλημάτων που μπορείτε να χρησιμοποιήσετε για να εντοπίσετε κατεστραμμένα αρχεία του Microsoft Word για Mac και, σε ορισμένες περιπτώσεις, να ανακτήσετε αυτά τα αρχεία.

Τα αρχεία κατεστραμμένων εγγράφων μπορεί να προκαλέσει οποιοδήποτε πρόγραμμα για να ασυνήθιστη συμπεριφορά. Αυτή η συμπεριφορά παρουσιάζεται επειδή το πρόγραμμα λαμβάνει εσφαλμένες πληροφορίες από το κατεστραμμένο αρχείο.

Περισσότερες πληροφορίες

Τρόπος εντοπισμού ενός κατεστραμμένου αρχείου

Κατεστραμμένα αρχεία προκαλούν συχνά συμπεριφορά που δεν αποτελεί μέρος του σχεδιασμού του προγράμματος--για παράδειγμα, συνεχής επανάληψη σελιδοποίησης, εσφαλμένη έγγραφο διάταξη και μορφοποίηση, μη αναγνώσιμοι χαρακτήρες στην οθόνη, μηνύματα λάθους κατά την επεξεργασία, σύστημα σταματά να ανταποκρίνεται ή διακόπτεται η λειτουργία του κατά τη φόρτωση ή προβολή του αρχείου ή οποιαδήποτε άλλη ασυνήθιστη συμπεριφορά, η οποία δεν είναι δυνατό να αποδοθεί στην κανονική λειτουργία του προγράμματος. Οι συμπεριφορές αυτές μπορεί επίσης να προκληθεί από παράγοντες διαφορετικούς από την καταστροφή του εγγράφου. Για να εξαλείψετε άλλους παράγοντες, ακολουθήστε αυτές τις συμβουλές αντιμετώπισης προβλημάτων:

  • Ελέγξτε για παρόμοια συμπεριφορά σε άλλα έγγραφα.
  • Ελέγξτε για παρόμοια συμπεριφορά σε άλλα προγράμματα.
  • Λαμβάνει το εν λόγω αρχείο σε άλλον υπολογιστή και προσπαθήστε να αναπαραγάγετε τη συμπεριφορά.
  • Χρησιμοποιήστε ένα διαφορετικό πρόγραμμα οδήγησης εκτυπωτή και προσπαθήστε να αναπαραγάγετε τη συμπεριφορά. Για να χρησιμοποιήσετε ένα διαφορετικό πρόγραμμα οδήγησης εκτυπωτή, ακολουθήστε τα εξής βήματα:

    1. Επιλέξτε την επιλογή στο μενού της Apple .
    2. Στην επιλογή, επιλέξτε ένα διαφορετικό πρόγραμμα οδήγησης εκτυπωτή και, στη συνέχεια, κλείστε την επιλογή.
    3. Στο Word για Mac, επιλέξτε Διαμόρφωση σελίδας στο μενού " αρχείο ", για να βεβαιωθείτε ότι το πρόγραμμα οδήγησης εκτυπωτή που έχετε επιλέξει στο η επιλογή είναι επιλεγμένο στο Word για Mac.
  • Μετονομάστε τυχόν πρότυπα που επισυνάπτονται στο έγγραφο και στη συνέχεια προσπαθήστε να αναπαραγάγετε τη συμπεριφορά.
  • Ξεκινήστε ξανά τον υπολογιστή με τις επεκτάσεις απενεργοποιημένες για να απενεργοποιήστε οποιαδήποτε προγράμματα τρίτων κατασκευαστών που εκτελούνται (όπως προγράμματα-and-stay-resident [TSR], προγράμματα διαχείρισης γραμματοσειρών και προφυλάξεις οθόνης). Στη συνέχεια, προσπαθήστε να αναπαραγάγετε τη συμπεριφορά. Για πρόσθετες πληροφορίες σχετικά με την εκκίνηση του υπολογιστή με επεκτάσεις off, κάντε κλικ στον αριθμό του άρθρου παρακάτω, για να προβάλετε το άρθρο της Γνωσιακής Βάσης της Microsoft:

    263159 Τρόπος αντιμετώπισης προβλημάτων διενέξεων επέκτασης σε Macintosh
Εάν το ζήτημα παρουσιάζεται μόνο με ένα μεμονωμένο έγγραφο αφού εκτελέσετε τα παραπάνω βήματα, το έγγραφο είναι πιθανόν κατεστραμμένο. Εάν το πρόγραμμα κλείσει απρόσμενα πριν από το κλείσιμο του αρχείου και έχει ενεργοποιημένη την επιλογή " Αυτόματη Ανάκτηση ", ένα αρχείο αυτόματης ανάκτησης ενδέχεται να έχουν δημιουργηθεί. Μπορείτε να χρησιμοποιήσετε αυτό το αρχείο αυτόματης ανάκτησης για να ανακτήσετε το εν λόγω αρχείο.

Τη δυνατότητα αυτόματης ανάκτησης στο Word για Mac επιχειρεί να αποκαταστήσει αυτόματα το κείμενο από ένα έγγραφο που ήταν ανοιχτά όταν το Word για Mac σταμάτησε να ανταποκρίνεται. Όταν επανεκκινήσετε το Word για Mac μετά σταματά να ανταποκρίνεται ("κολλάει"), θα εμφανιστεί ένα παράθυρο διαλόγου με το ακόλουθο μήνυμα:
Το Word εντόπισε καταστροφή αρχείου κατά το άνοιγμα του Ονόματος αρχείου. Μέρος αυτού του εγγράφου μπορεί να ανακτηθεί. Προσπάθεια αποκατάστασης τώρα;
ΣΗΜΕΊΩΣΗ: Αυτή η αποκατάσταση μπορεί να διαρκέσει αρκετά, ανάλογα με το μέγεθος του εγγράφου και το ποσό των ζημιών στο έγγραφο.

Μετά την ανάκτηση του εγγράφου, αμέσως να χρησιμοποιήσετε την εντολή " Αποθήκευση ως " από το μενού αρχείο για να αποθηκεύσετε το έγγραφο με νέο όνομα αρχείου. Αυτό εξασφαλίζει ότι το αρχικό έγγραφο θα είναι διαθέσιμο για άλλες προσπάθειες ανάκτησης. Αυτή η μέθοδος αυτόματης ανάκτησης οριζόντια όλες μορφοποίηση, γραφικά και αντικείμενα από το έγγραφο.

Άλλες μέθοδοι που αναγράφονται παρακάτω σε αυτό το άρθρο ενδέχεται να σας επιτρέψει να ανακτήσετε από την αρχική μορφοποίηση από το κατεστραμμένο έγγραφο.

Για περισσότερες πληροφορίες σχετικά με τη δυνατότητα αυτόματης ανάκτησης, ανατρέξτε στο θέμα "Αποτροπή απώλειας της και ανάκτηση χαθεί έγγραφα του Word" στο Word για Mac Βοήθεια.

Πώς να διορθώσετε ένα κατεστραμμένο έγγραφο

Υπάρχουν αρκετές τεχνικές που μπορείτε να χρησιμοποιήσετε για να προσπαθήσετε να διορθώσετε ένα κατεστραμμένο έγγραφο. Η μέθοδος που χρησιμοποιείτε εξαρτάται από τον τύπο και τη σοβαρότητα της ζημίας και τον τύπο της συμπεριφοράς που είναι παρουσίασε. Αν και πολλές από αυτές τις μεθόδους συνήθως επιτυγχάνουν, δεν όλων των κατεστραμμένων εγγράφων είναι δυνατό να ανακτηθεί. Διατήρηση αντιγράφου ασφαλείας ενός εγγράφου είναι ο καλύτερος τρόπος για να εξασφαλίσετε την αποκατάσταση.

Οι παρακάτω διαδικασίες αντιμετώπισης προβλημάτων διαιρούνται σε δύο ενότητες: "Εάν το αρχείο μπορεί να ανοίξει στο Word για Mac" και "Εάν το αρχείο δεν είναι δυνατό να ανοίξει στο Word για Mac." Χρησιμοποιήστε την κατάλληλη ενότητα για την περίπτωσή σας.

Εάν το αρχείο μπορεί να ανοίξει σε Word για Mac

Εάν μπορείτε να ανοίξετε το αρχείο στο Word για Mac, χρησιμοποιήστε μία από τις ακόλουθες μεθόδους.

Μέθοδος 1: Μετατροπή του αρχείου σε άλλη μορφή

Μετατρέψτε το αρχείο σε άλλη μορφή και, στη συνέχεια, να το μετατρέψετε σε την εγγενή μορφή.

Αυτή είναι η ευκολότερη και πιο ολοκληρωμένη μέθοδος ανάκτησης. να την δοκιμάζετε πάντα πρώτα. Αποθηκεύστε το αρχείο σε μορφή εμπλουτισμένου κειμένου (RTF). Αυτή η μορφή διατηρεί τη μορφοποίηση του Word για Mac έγγραφο. Αφού αποθηκεύσετε το αρχείο σε μορφή RTF, ανοίξτε ξανά το αρχείο στο Word για Mac και, στη συνέχεια, να το μετατρέψετε από RTF. Εάν αυτή η μέθοδος είναι επιτυχής, η καταστροφή αρχείου καταργείται κατά τη μετατροπή.

Για να αποθηκεύσετε το αρχείο ως RTF, ακολουθήστε τα εξής βήματα:

  1. Στο μενού αρχείο , κάντε κλικ στο κουμπί Αποθήκευση ως.
  2. Κάντε κλικ στη λίστα μορφή και, στη συνέχεια, επιλέξτε Μορφή εμπλουτισμένου κειμένου.
  3. Αλλάξτε το όνομα του εγγράφου. (Αυτό συνιστάται έτσι ώστε να μπορείτε να συνεχίσετε με τα υπόλοιπα βήματα, χρησιμοποιώντας το αρχικό έγγραφο δεν έχει τροποποιηθεί.)
  4. Κάντε κλικ στο κουμπί Αποθήκευση.
Εάν η καταστροφή παραμείνει μετά την αποθήκευση του αρχείου ως RTF, προσπαθήστε να αποθηκεύσετε το αρχείο σε μία από τις ακόλουθες μορφές αρχείου:

  • Άλλες μορφές επεξεργασίας κειμένου
  • Μόνο κείμενο
ΣΗΜΕΊΩΣΗ: αποθήκευση ενός αρχείου σε μορφή μόνο κειμένου συχνά διορθώνει το θέμα της ζημίας. Ωστόσο, όλη η μορφοποίηση χάνεται, συμπεριλαμβανομένων των γραφικών και το πεδίο κωδικών στο Word για Mac. Αυτή η μέθοδος απαιτεί περισσότερες επαναδιαμόρφωση; Επομένως, χρησιμοποιήστε τη μόνο όταν αποτύχει άλλες μορφές αρχείων για να διορθώσετε το πρόβλημα.


Για πρόσθετες πληροφορίες σχετικά με την απώλεια της Visual Basic για εφαρμογές κώδικα στο Word για Mac έγγραφα τα οποία μετατρέπονται σε άλλες μορφές αρχείων, κάντε κλικ στον αριθμό του άρθρου παρακάτω, για να προβάλετε το άρθρο της Γνωσιακής Βάσης της Microsoft:

184153 WD98: ο κώδικας VBA χάνεται μετά τη μετατροπή σε άλλη μορφή εγγράφου

Μέθοδος 2: Αντιγραφή τα πάντα εκτός από το τελευταίο σημάδι παραγράφου σε ένα νέο έγγραφο

Word για Mac συσχετίζει μια μεγάλη ποικιλία μορφοποίησης με το τελευταίο σημάδι παραγράφου, ιδιαίτερα μορφοποίηση ενότητας και στυλ. Εάν αντιγράψετε τα πάντα στο αρχείο, εκτός από το τελευταίο σημάδι παραγράφου σε ένα νέο αρχείο, το σφάλμα ενδέχεται να παραμείνει στο αρχικό έγγραφο.

Για να αντιγράψετε τα πάντα εκτός από το τελευταίο σημάδι παραγράφου στο έγγραφο, ακολουθήστε τα εξής βήματα:

  1. Ανοίξτε το έγγραφο που παρουσιάζει τη συμπεριφορά περιττό.
  2. Στο μενού Επεξεργασία , κάντε κλικ στο κουμπί Επιλογή όλων.
  3. Με το έγγραφο που επιλέξατε, πιέστε το πλήκτρο κατεύθυνσης ΕΝΤΟΛΉ + SHIFT + ΑΡΙΣΤΕΡΟ ΒΕΛΟΣ. (Αυτό καταργεί μόνο το τελευταίο σημάδι παραγράφου από την επιλογή.)
  4. Στο μενού Επεξεργασία , επιλέξτε Αντιγραφή.
  5. Στο μενού " αρχείο ", επιλέξτε " Νέο έγγραφο".
  6. Στο νέο έγγραφο, επιλέξτε " Επικόλληση " από το μενού Επεξεργασία .

    ΣΗΜΕΊΩΣΗ: στο νέο έγγραφο, ίσως χρειαστεί να εφαρμόσετε ξανά τη μορφοποίηση ενότητας ή τη μορφοποίηση του στυλ.

Μέθοδος 3: Αντιγράψτε τα μη κατεστραμμένα τμήματα του αρχείου σε ένα νέο αρχείο

Ορισμένες φορές μπορείτε να καθορίσετε τη θέση του σφάλματος στο αρχείο σας, εξετάζοντας το αρχείο ή τον έλεγχο του αρχείου για να προσδιορίσετε πότε η συμπεριφορά. Ένας άλλος τρόπος για να προσδιορίσετε ποια περιοχή του αρχείου είναι κατεστραμμένο είναι να αντιγράψετε είτε μία σελίδα κάθε φορά ή μιας σειράς σελίδων σε ένα νέο αρχείο. Αποθηκεύστε το νέο αρχείο και, στη συνέχεια, ελέγξτε για την αρχική συμπεριφορά. Εάν η συμπεριφορά δεν παρουσιάζεται, συνεχίστε να αντιγράφετε σελίδες, αποθηκεύοντας και δοκιμή μέχρι να παρουσιαστεί η αρχική συμπεριφορά.

Εάν μπορείτε να βρείτε ποια περιοχή του αρχείου είναι κατεστραμμένο, μπορείτε να αντιγράψετε τα πάντα εκτός από το κατεστραμμένο τμήμα σε ένα νέο αρχείο και, στη συνέχεια, ακολουθήστε τα εξής βήματα για να αναδημιουργήστε το έγγραφό σας:

  1. Αντιγράψτε τα μη κατεστραμμένα τμήματα του εγγράφου σας και να τα επικολλήσετε σε ένα νέο αρχείο (δεν μπορείτε να επιλέξετε το τελευταίο σημάδι παραγράφου από αυτήν την επιλογή, επειδή αυτό το σημάδι παραγράφου μπορεί να περιέχουν κάποιες λανθασμένες πληροφορίες).
  2. Αποθηκεύστε ένα αντίγραφο του κατεστραμμένου εγγράφου σε μορφή μόνο κειμένου.
  3. Ανοίξτε το αρχείο μόνο για κείμενο.
  4. Αντιγράψτε το κείμενο από αυτό το αρχείο, και στη συνέχεια επικολλήστε το αρχείο που περιέχει το μη κατεστραμμένο τμήμα του αρχείου σας.
  5. Μορφοποιήστε ξανά τις ενότητες του εγγράφου που επικολλήσατε στο βήμα 4 και, στη συνέχεια, αποθηκεύστε το ανακτημένο έγγραφο.

Εάν το αρχείο δεν είναι δυνατό να ανοίξει στο Word για Mac

Εάν δεν μπορείτε να ανοίξετε το αρχείο στο Word για Mac, χρησιμοποιήστε μία από τις ακόλουθες μεθόδους ανάλογα με την περίπτωση.

Μέθοδος 1: Εισαγάγετε το αρχείο σε ένα κενό έγγραφο

Εάν δεν μπορείτε να ανοίξετε ένα αρχείο για να αντιγράψετε ολόκληρο το κείμενο (εκτός από το τελευταίο σημάδι παραγράφου), ενδέχεται να μπορέσετε να εισαγάγετε το αρχείο σε ένα νέο έγγραφο. Αυτό εισάγει ένα νέο σημάδι της τελευταίας παραγράφου σε αρχείο που διορθώνετε. Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα:

  1. Δημιουργήστε ένα νέο έγγραφο με βάση το πρότυπο Normal.
  2. Στο μενού " Εισαγωγή ", κάντε κλικ στο αρχείο. Επιλέξτε το κατεστραμμένο έγγραφο και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

Μέθοδος 2: Χρησιμοποιήστε την εντολή "Επικόλληση σύνδεσης" για να ανοίξετε το έγγραφο με μια σύνδεση

Αυτή η μέθοδος χρησιμοποιεί ένα έγγραφο "dummy" για να δημιουργήσετε μια σύνδεση και στη συνέχεια μεταβαίνει στη σύνδεση ανάμεσα στο "dummy" έγγραφο και το κατεστραμμένο έγγραφο.

Ακολουθήστε αυτά τα βήματα για να χρησιμοποιήσετε μια λειτουργία επικόλλησης σύνδεσης για να ανοίξετε ένα κατεστραμμένο έγγραφο:

  1. Κλείστε όλα τα ανοιχτά έγγραφα στο Word για Mac και, στη συνέχεια, ανοίξτε ένα νέο κενό έγγραφο.
  2. Τύπος δοκιμής.
  3. Επιλέξτε τη λέξη δοκιμής. Στο μενού Επεξεργασία , κάντε κλικ στο κουμπί " Αντιγραφή".
  4. Στο μενού αρχείο , κάντε κλικ στην επιλογή Δημιουργία και, στη συνέχεια, ανοίξτε ένα νέο κενό έγγραφο.
  5. Στο μενού Επεξεργασία , κάντε κλικ στην εντολή " Ειδική επικόλληση". Στο πλαίσιο διαλόγου " Ειδική επικόλληση ", κάντε κλικ στο κουμπί " Επικόλληση σύνδεσης". Στο πλαίσιο ως , κάντε κλικ στην επιλογή Μορφοποιημένο κείμενο (RTF)και, στη συνέχεια, κάντε κλικ στο κουμπί OK.
  6. Στο μενού Επεξεργασία , κάντε κλικ στην εντολή " συνδέσεις".
  7. Στο παράθυρο διαλόγου " συνδέσεις ", κάντε κλικ στην επιλογή " Αλλαγή αρχείου προέλευσης". Στο παράθυρο διαλόγου Άνοιγμα , εντοπίστε και επιλέξτε το έγγραφο που θέλετε να ανακτήσετε. Κάντε κλικ στο κουμπί Άνοιγμα και, στη συνέχεια, κάντε κλικ στο κουμπί OK.
  8. Όταν ανοίγει το έγγραφο, κάντε κλικ στην επιλογή " Αποθήκευση ως " από το μενού αρχείο . Πληκτρολογήστε ένα νέο όνομα για το έγγραφο και, στη συνέχεια, κάντε κλικ στο κουμπί Αποθήκευση.
  9. Έχοντας ανοιχτό το έγγραφο, κάντε κλικ στο κουμπί " συνδέσεις " από το μενού Επεξεργασία .
  10. Στο παράθυρο διαλόγου " συνδέσεις ", κάντε κλικ στο κουμπί Διακοπή συνδέσεων. Στο παράθυρο διαλόγου που εμφανίζεται, κάντε κλικ στο κουμπί Ναι για να καταργηθεί η σύνδεση.
ΣΗΜΕΊΩΣΗ: αφού έχει διακοπεί η σύνδεση, θα πρέπει να αποθηκεύσετε το έγγραφο πριν να κλείσετε ή να τροποποιήσετε.

Μέθοδος 3: Ανοίξτε το αρχείο χρησιμοποιώντας τη δυνατότητα "Ανάκτηση κειμένου από οποιοδήποτε αρχείο"

Ως τελευταία λύση, μπορείτε να χρησιμοποιήσετε το ειδικό πρόγραμμα μετατροπής "Ανάκτηση κειμένου από οποιοδήποτε αρχείο" για να ανοίξετε το κατεστραμμένο έγγραφα με μη αυτόματο τρόπο. Αυτός ο μετατροπέας καταργεί όλη η μορφοποίηση, γραφικά και ενσωματωμένα αντικείμενα από το αρχείο και παραμένουν μόνο αναγνώσιμο κείμενο (ASCII χαρακτήρες). Εξαιτίας του τρόπου ότι Word για αρχεία εγγράφων Mac είναι οργανωμένα και αποθηκευτεί, το κείμενο μπορεί να είναι ασυνεχές ή να αναπαραχθεί.

Με ακόμη και η απλούστερη αρχεία σημαντική αναδιαμόρφωση είναι απαραίτητη. Με μικρότερα αρχεία, μπορείτε να ανοίξετε ένα νέο έγγραφο του δεύτερου και το αντίγραφο και να επικολλήσετε κείμενο από το ανακτημένο έγγραφο σε νέο έγγραφο, επειδή υπάρχει πολύ ανεπιθύμητο κείμενο που ανακτήθηκαν.

Για να χρησιμοποιήσετε το πρόγραμμα μετατροπής "Ανάκτηση κειμένου από οποιοδήποτε αρχείο" για να ανοίξετε ένα έγγραφο, ακολουθήστε τα εξής βήματα:

  1. Στο μενού αρχείο , κάντε κλικ στο " Άνοιγμα".
  2. Κάντε κλικ στη λίστα Εμφάνιση και, στη συνέχεια, κάντε κλικ στην επιλογή Ανάκτηση κειμένου από οποιοδήποτε αρχείο.
  3. Εντοπίστε το φάκελο που περιέχει το κατεστραμμένο αρχείο και, στη συνέχεια, επιλέξτε το αρχείο.
  4. Κάντε κλικ στο κουμπί Άνοιγμα.
ΣΗΜΕΊΩΣΗ: Η διαδικασία αποκατάστασης μπορεί να διαρκέσει αρκετά, ανάλογα με το μέγεθος του εγγράφου και τον τύπο της βλάβης. Μόλις ολοκληρώνεται η αποκατάσταση, κάντε κλικ στο κουμπί " Άνοιγμα " από το μενού αρχείο , και στη συνέχεια αλλάξτε Τύπος αρχείων στη λίστα σε Έγγραφα του Word ή Δυνατότητα ανάγνωσης αρχείων.

ΣΥΜΒΟΥΛΉ: Αποθηκεύστε το ανακτημένο αρχείο με νέο όνομα σε αυτό το σημείο. Αυτό εμποδίζει την αθέλητη αντικατάσταση του αρχικού εγγράφου και εξασφαλίζει ότι το αρχικό έγγραφο παραμένει διαθέσιμο για άλλες προσπάθειες ανάκτησης.


Μέθοδος 4: Άνοιγμα ως αντιγράφου

Για να ανοίξετε ένα αντίγραφο του κατεστραμμένου εγγράφου, ακολουθήστε τα εξής βήματα:
  1. Κλείστε όλα τα ανοιχτά έγγραφα.
  2. Κάντε κλικ στην επιλογή Άνοιγμα από το μενού αρχείο .
  3. Επιλέξτε Copy από το Άνοιγμα της λίστας.
  4. Επιλέξτε το κατεστραμμένο αρχείο.
  5. Κάντε κλικ στο κουμπί Άνοιγμα.
Ιδιότητες

Αναγνωριστικό άρθρου: 285393 - Τελευταία αναθεώρηση: 23 Ιαν 2017 - Αναθεώρηση: 1

Σχόλια