Τρόπος δημιουργίας ενός έργου αυτοματισμού χρησιμοποιώντας MFC και μια βιβλιοθήκη τύπων

ΣΗΜΑΝΤΙΚΟ: Αυτό το άρθρο είναι προϊόν λογισμικού μηχανικής μετάφρασης της Microsoft και όχι ανθρώπινης μετάφρασης. Η Microsoft σάς προσφέρει άρθρα που είναι προϊόντα ανθρώπινης αλλά και μηχανικής μετάφρασης έτσι ώστε να έχετε πρόσβαση σε όλα τα άρθρα της Γνωσιακής Βάσης μας στη δική σας γλώσσα. Ωστόσο, ένα άρθρο που έχει προκύψει από μηχανική μετάφραση δεν είναι πάντα άριστης ποιότητας. Ενδέχεται να περιέχει λεξιλογικά, συντακτικά ή γραμματικά λάθη, όπως ακριβώς τα λάθη που θα έκανε ένας μη φυσικός ομιλητής επιχειρώντας να μιλήσει τη γλώσσα σας. Η Microsoft δεν φέρει καμία ευθύνη για τυχόν ανακρίβειες, σφάλματα ή ζημίες που προκύψουν λόγω τυχόν παρερμηνειών στη μετάφραση του περιεχομένου ή χρήσης του από τους πελάτες της. Επίσης, η Microsoft πραγματοποιεί συχνά ενημερώσεις στο λογισμικό μηχανικής μετάφρασης.

Η αγγλική έκδοση αυτού του άρθρου είναι η ακόλουθη:178749
Αυτό το αρχείο έχει αρχειοθετηθεί. Προσφέρεται “ως έχει” και δεν θα ενημερώνεται πια.
Περίληψη
Αυτό το άρθρο παρουσιάζει, λεπτομερώς τον τρόπο αυτοματοποίησης ενοποίηση στοιχείων COM συμβατό με εφαρμογές όπως το Microsoft Εφαρμογές του Office.
Περισσότερες πληροφορίες
Ενότητα που ακολουθεί δείχνει πώς μπορείτε να δημιουργήσετε μια MFC το έργο. Το παράδειγμα που αυτοματοποιεί το Microsoft Excel. Μπορείτε να χρησιμοποιήσετε τα βήματα πρώτα 8 για κάθε έργο, και να τροποποιήσετε τα βήματα 9 έως 15, όταν εργάζεστε με μια άλλη εφαρμογή.

Δημιουργία ενός έργου αυτοματισμού

  1. Με το Microsoft Developer Studio, ξεκινήστε μια νέα AppWizard MFC" (exe) "έργο με όνομα"autoproject".
  2. Στο βήμα 1 του AppWizard το MFC, επιλέξτε "Παράθυρο διαλόγου με βάση" για τον τύπο εφαρμογής και, στη συνέχεια, κάντε κλικ στο κουμπί "Τέλος".

    Το νέο έργο Εμφανίζεται στο παράθυρο διαλόγου πληροφορίες και να δείχνει ότι οι κλάσεις, δημιουργία περιλαμβάνουν:
          Application: CAutoProjectApp in AutoProject.h and AutoProject.cpp      Dialog: CAutoProjectDlg in AutoProject.h and AutoProjectDlg.cpp						
    Κάντε κλικ στο κουμπί OK για να δημιουργήσετε το έργο.
  3. Ανοίγει το πλαίσιο διαλόγου "idd_autoproject_dialog" με το Visual Στούντιο σχεδίασης/επεξεργασίας της περιοχής. Τροποποίηση σύμφωνα με τις οδηγίες στην επόμενη δύο βήματα.
  4. Καταργήστε το στοιχείο ελέγχου της ετικέτας (IDC_STATIC) και το κουμπί "Άκυρο" (IDCANCEL).
  5. Αλλάξτε το όνομα του κουμπιού OK για να "idrun" και τη λεζάντα "Εκτέλεση". Κλείστε τη φόρμα σχεδίασης του παραθύρου διαλόγου AutoProject.rc.
  6. Κάντε κλικ στο κουμπί "ClassWizard" από το μενού Προβολή (ή πιέστε το συνδυασμό πλήκτρων CTRL + W).
  7. Επιλέξτε το IDRUN Select tab. χάρτες μήνυμα από τα αναγνωριστικά αντικειμένων πλαίσιο λίστας και επιλέξτε "bn_clicked" στο πλαίσιο λίστας μηνυμάτων. Κάντε κλικ στο κουμπί Προσθήκη λειτουργίας και αποδεχτείτε το όνομα της συνάρτησης "onrun". Κάντε κλικ στο κουμπί OK για να κλείσετε το ClassWizard.

    ΣΗΜΕΊΩΣΗ: Αυτό το βήμα προσθέτει μια δήλωση για τη συνάρτηση μέλος "OnRun()", στην κεφαλίδα του αρχείου με το όνομα AutoProjectDLG.h. Αυτό το βήμα προσθέτει επίσης ένα Άδειασμα λειτουργία χειρισμού μηνυμάτων skeleton με το όνομα CAutoProjectDlg::OnRun() για να το το αρχείο που ονομάζεται AutoProjectDLG.cpp.
  8. Κάντε κλικ στο κουμπί "ClassWizard" από το μενού Προβολή (ή πιέστε το συνδυασμό πλήκτρων CTRL + W).
  9. Επιλέξτε ο στηλοθέτης. αυτοματισμού, κάντε κλικ στο κουμπί Προσθήκη κατηγορίας και επιλέξτε "από μια βιβλιοθήκη τύπων." Περιήγηση για να επιλέξετε τη βιβλιοθήκη αντικειμένων για την εφαρμογή που θέλετε να αυτοματοποιήσετε (αυτό το παράδειγμα, αν αυτοματοποιείτε το Excel 97, επιλέξτε το Βιβλιοθήκη αντικειμένων του Microsoft Excel 8.0. η προεπιλεγμένη θέση είναι C:\Program Files\Microsoft Office\Office\Excel8.olb).

    Εάν αυτοματοποιείτε Το Microsoft Excel 2000, επιλέξτε βιβλιοθήκη αντικειμένων του Microsoft Excel 9.0 για τα οποία η προεπιλεγμένη θέση είναι η Office\Office\Excel9.olb του C:\Program Files\Microsoft.

    Εάν αυτοματοποιείτε το Microsoft Excel 2002 και το Microsoft Office Excel 2003, το βιβλιοθήκη αντικειμένων είναι ενσωματωμένο στο αρχείο Excel.exe. Η προεπιλεγμένη θέση για Excel.exe στο Office 2002 είναι C:\program Files\Microsoft Office\Office10\Excel.exe. Είναι η προεπιλεγμένη θέση για το αρχείο Excel.exe στο Office 2003 C:\Program Files\Microsoft Office\Office11\Excel.exe. Αφού επιλέξετε βιβλιοθήκη του κατάλληλου αντικειμένου, κάντε κλικ στο κουμπί Άνοιγμα. Επιλέξτε όλες τις κατηγορίες με την επιβεβαίωση Κλάσεων λίστας και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

    ΣΗΜΕΊΩΣΗ: Το πλαίσιο λίστας με την επιβεβαίωση Στο παράθυρο διαλόγου κατηγορίες περιέχει όλες τις διασυνδέσεις IDispatch (τα οποία είναι σχεδόν πανομοιότυπη με κλάσεις) στη βιβλιοθήκη τύπων του Microsoft Excel. Με το κάτω μισό του παραθύρου διαλόγου, θα δείτε ότι το όνομα ενός αρχείου εφαρμογής Excel8.cpp περιέχει προγράμματα που δημιουργούνται κλάσης που προέρχεται από ColeDispatchDriver(), και το αρχείο κεφαλίδας κατάλληλη δήλωση ονομάζεται Excel8.h. (Για το Excel 2002 και Excel 2003, τα αρχεία ονομάζονται Excel.cpp και Excel.h.)
  10. Κάντε κλικ στο κουμπί OK για να κλείσετε το παράθυρο διαλόγου MFC ClassWizard.
  11. Προσθέστε τον ακόλουθο κώδικα για το Η συνάρτηση CAutoProjectApp::InitInstance(), η οποία φορτώνει και ενεργοποιεί το COM υπηρεσίες βιβλιοθήκης:
          BOOL CAutoProjectApp::InitInstance()      {         if(!AfxOleInit())  // Your addition starts here         {            AfxMessageBox("Could not initialize COM dll");            return FALSE;         }                 // End of your addition         AfxEnableControlContainer();      .      .      .      }					
  12. Προσθέστε την ακόλουθη γραμμή για το # περιλαμβάνουν προτάσεις κατά το επάνω από το αρχείο προγράμματος AutoProject.cpp:
          #include <afxdisp.h>					
  13. Προσθέστε την εντολή συμπερίληψη για excel8.h μετά τη συμπερίληψη δήλωση για το stdafx.h στην κορυφή του αρχείου προγράμματος AutoProjectDlg.cpp:
          #include "stdafx.h"      #include "excel8.h" // excel.h in the case of Excel 2002 and Excel 2003.					
  14. Προσθέστε κώδικα αυτοματοποίησης του CAutoProjectDlg::OnRun(), έτσι ώστε να εμφανίζεται όπως φαίνεται παρακάτω:
          void CAutoProjectDlg::OnRun()      {          _Application app;  // app is the Excel _Application object          // Start Excel and get Application object...         if(!app.CreateDispatch("Excel.Application"))         {            AfxMessageBox("Couldn't start Excel.");         }         else         {            //Make Excel Visible and display a message          app.SetVisible(TRUE);          AfxMessageBox ("Excel is Running!");         }      }					
  15. Δημιουργία και εκτέλεση του έργου. ΑΠΟΤΕΛΈΣΜΑΤΑ: Όταν κάνετε κλικ στο κουμπί Εκτέλεση κουμπί στο παράθυρο διαλόγου, το Microsoft Excel θα ξεκινήσει. Ενεργοποίηση του Παράθυρο διαλόγου Auto_Excel πλαίσιο και να κλείσετε το πλαίσιο μηνύματος. Το Microsoft Excel θα κλείσει πότε τελειώνει τη συνάρτηση CAutoProjectDlg::OnRun(), επειδή η εφαρμογή μεταβλητή θα εισήλθε εκτός του πεδίου εφαρμογής.

Πρόσθετες σημειώσεις

Αφού προσθέσετε τους κλάδους από μια βιβλιοθήκη τύπων για σας έργο (όπως που στο βήμα 9 ανωτέρω), θα παρατηρήσετε ότι έχουν πολλές κλάσεις έχουν προστεθεί στο έργο. Στο ClassView, μπορείτε να κάνετε κλικ σε μια κατηγορία για να δείτε τα καθήκοντα που κλάσης και κατόπιν κάντε διπλό κλικ στο μέλος που λειτουργούν σε προβάλετε τον ορισμό των καθηκόντων αυτών στο αρχείο εφαρμογής Excel8.cpp.

Πρέπει να περάσετε τον ορισμό μιας συνάρτησης μέλος, αν θέλετε να Επαληθεύστε το τύπο επιστροφής ή αν χρειάζεται να αλλάξετε μια λειτουργία εφαρμογής. Οποιαδήποτε ώρα μπορείτε να αλλάξετε έναν ορισμό της συνάρτησης, θυμηθείτε να αλλάξετε τη δήλωση της το αρχείο Excel8.h. Κατά αυτόν τον τρόπο, φροντίστε να αλλάξετε τη σωστή λειτουργία δήλωση. Μερικές φορές, έχουν το ίδιο όνομα μέλους λειτουργίες των πολλαπλών classes--GetApplication() είναι μία τέτοια παράδειγμα.

Παρόλο που τα βήματα άνω απεικονίζουν τον τρόπο με τον αυτοματισμό του Microsoft Excel, μπορείτε να εφαρμόσετε το ίδιο ιδέες για την αυτοματοποίηση της σε άλλες εφαρμογές. Η παρακάτω λίστα περιλαμβάνει τα ονόματα των αρχείων για βιβλιοθήκες τύπων των εφαρμογών του Microsoft Office:
   Application                           Type Library   --------------------------------------------------   Microsoft Access 97                   Msacc8.olb   Microsoft Jet Database 3.5            DAO350.dll   Microsoft Binder 97                   Msbdr8.olb   Microsoft Excel 97                    Excel8.olb   Microsoft Graph 97                    Graph8.olb   Microsoft Office 97                   Mso97.dll   Microsoft Outlook 97                  Msoutl97.olb   Microsoft PowerPoint 97               Msppt8.olb   Microsoft Word 97                     Msword8.olb   Microsoft Access 2000                 Msacc9.olb   Microsoft Jet Database 3.51           DAO360.dll   Microsoft Binder 2000                 Msbdr9.olb   Microsoft Excel 2000                  Excel9.olb   Microsoft Graph 2000                  Graph9.olb   Microsoft Office 2000                 Mso9.dll   Microsoft Outlook 2000                Msoutl9.olb   Microsoft PowerPoint 2000             Msppt9.olb   Microsoft Word 2000                   Msword9.olb    Microsoft Access 2002                 Msacc.olb   Microsoft Excel 2002                  Excel.exe   Microsoft Graph 2002                  Graph.exe    Microsoft Office 2002                 MSO.dll   Microsoft Outlook 2002                MSOutl.olb   Microsoft PowerPoint 2002             MSPpt.olb   Microsoft Word 2002                   MSWord.olb   Microsoft Office Access 2003          Msacc.olb   Microsoft Office Excel 2003           Excel.exe   Microsoft Graph 2003                  Graph.exe    Microsoft Office 2003                 MSO.dll   Microsoft Office Outlook 2003         MSOutl.olb   Microsoft Office PowerPoint 2003      MSPpt.olb   Microsoft Office Word 2003            MSWord.olb				
ΣΗΜΕΊΩΣΗ: Η προεπιλεγμένη θέση για αυτές τις βιβλιοθήκες τύπων είναι C:\Program Files\Microsoft Office\Office (Office 2002 η διαδρομή είναι C:\...\Office10 και για το Office 2003 η διαδρομή είναι C:\...\Office11), εκτός για Dao350.dll ή Dao360.dll, και 10(MSO.dll) του Microsoft Office. Η προεπιλεγμένη θέση για Dao350.dll/Dao360.dll είναι C:\Program Files\Common Files\Microsoft Shared\Dao. Η προεπιλεγμένη θέση αρχείου MSO.dll είναι C:\Program Files\Common Files\Microsoft Shared\Office10 για το Office 2002 και C:\Program Files\Common Files\Microsoft Shared\Office11 για το Office 2003.
Αναφορές
Αυτό το άρθρο παρουσιάζει μια συγκεκριμένη προσέγγιση για τη δημιουργία ενός πλαίσιο διαλόγου έργου. Αν θα θέλατε να δείτε πιο γενική τεκμηρίωση σχετικά με τη διαδικασία δημιουργίας ενός έργου VC ++ με το Microsoft Developer Studio περιβάλλον, υπάρχει ένα εξαιρετικό πρόγραμμα εκμάθησης, μπορείτε να αποκτήσετε πρόσβαση χρησιμοποιώντας τη Visual InfoView στούντιο. Για να ανοίξετε το πρόγραμμα εκμάθησης, κάντε κλικ στο κουμπί αναζήτησης στο μενού "Βοήθεια". Κάντε κλικ στο κουμπί η καρτέλα ευρετήριο και πληκτρολογήστε τα εξής:
εργασία με έργα
Κάντε κλικ στο κουμπί λίστα θεμάτων. Επιλέξτε το θέμα "κεντρική σελίδα: εργασία με Έργα"και κάντε κλικ στο κουμπί" Εμφάνιση ".Για περισσότερες πληροφορίες σχετικά με την αυτοματοποίηση εφαρμογών του Office, κάντε κλικ στον αριθμό του άρθρου παρακάτω, για να προβάλετε το άρθρο της Γνωσιακής Βάσης της Microsoft:
222101Πώς να εντοπίσετε και να χρησιμοποιήσετε την τεκμηρίωση του μοντέλου αντικειμένου του Office
Πλαίσιο λίστας αυτοματισμού ole IDispatch

Προειδοποίηση: Αυτό το άρθρο έχει μεταφραστεί αυτόματα

Ιδιότητες

Αναγνωριστικό άρθρου: 178749 - Τελευταία αναθεώρηση: 12/05/2015 08:16:05 - Αναθεώρηση: 4.0

Microsoft Foundation Class Library 4.2, Microsoft Office XP Developer Edition, Microsoft Office 2000 Developer Edition

  • kbnosurvey kbarchive kbautomation kbhowto kbinterop kbmt KB178749 KbMtel
Σχόλια