Σφάλματα προσαρμογής συμβατότητας για την έκδοση του .NET Framework και την υποστήριξη πλατφόρμας

ΣΗΜΑΝΤΙΚΟ: Αυτό το άρθρο έχει μεταφραστεί χρησιμοποιώντας λογισμικό μηχανικής μετάφρασης της Microsoft και μπορείτε να το διορθώσετε χρησιμοποιώντας την τεχνολογία Community Translation Framework (CTF) (Πλαίσιο μετάφρασης κοινότητας). Η Microsoft παρέχει μηχανική μετάφραση, επεξεργασία μετά τη μηχανική μετάφραση από την κοινότητα και άρθρα μεταφρασμένα από επαγγελματίες προκειμένου να έχετε πρόσβαση σε όλα τα άρθρα της Γνωσιακής βάσης σε πολλές γλώσσες. Τα άρθρα μηχανικής μετάφρασης και αυτά που επεξεργάζονται ύστερα από μηχανική μετάφραση ενδέχεται να περιέχουν σφάλματα στο λεξιλόγιο, στη σύνταξη ή/και στη γραμματική. Η Microsoft δεν φέρει καμία ευθύνη για τυχόν ανακρίβειες, σφάλματα ή ζημίες που προκύψουν λόγω τυχόν παρερμηνειών στη μετάφραση του περιεχομένου ή χρήσης του από τους πελάτες μας. Για περισσότερες πληροφορίες σχετικά με το CTF, μεταβείτε στην τοποθεσία http://support.microsoft.com/gp/machine-translation-corrections/el.

Η αγγλική έκδοση αυτού του άρθρου είναι η ακόλουθη: 2715633
Σημείωση Το άρθρο αυτό παρουσιάζει επιδιόρθωση συμβατότητας εφαρμογής μηνύματα λάθους. Εάν ένας τελικός χρήστης, δοκιμάστε η ανάλυση Όταν παρουσιαστεί ένα σφάλμα επιδιόρθωση συμβατότητας εφαρμογών "Πρέπει να ενεργοποιήσετε το .NET Framework από το πλαίσιο διαλόγου δυνατότητες των Windows." Για οποιαδήποτε άλλα σφάλματα προσαρμογής συμβατότητας, το ακροατήριο για το περιεχόμενο είναι ο προμηθευτής app ή προγραμματιστής, θα πρέπει να επικοινωνήσετε με τον προμηθευτή της εφαρμογής για να τους ενημερώσετε ότι υπάρχει κάποιο πρόβλημα σε αυτήν την εφαρμογή.
Σφάλμα: "Πρέπει να ενεργοποιήσετε το .NET Framework από το παράθυρο διαλόγου 'Δυνατότητες των Windows'"
Μήνυμα σφάλματος
Δεν ήταν δυνατή η εκκίνηση αυτής της εφαρμογής. Πρέπει να ενεργοποιήσετε το .NET Framework από το παράθυρο διαλόγου "Δυνατότητες των Windows" (από τον Πίνακα Ελέγχου, επιλέξτε "Προγράμματα", "Ενεργοποίηση ή απενεργοποίηση των δυνατοτήτων των Windows").
Αιτία
Αυτό το ζήτημα παρουσιάζεται επειδή η εφαρμογή δεν έχει ρυθμιστεί έτσι ώστε να δίνει τη δυνατότητα για να προσδιορίσετε την κατάλληλη έκδοση του χρόνου εκτέλεσης .NET Framework. Ο αντίστοιχος κώδικας συμβατότητας προγράμματος είναι SHIM_GOTO_CONTROLPANEL.
Προτεινόμενη αντιμετώπιση
Για να επιλύσετε αυτό το πρόβλημα, ενεργοποιήστε το .NET Framework 3.5 που είναι μια δυνατότητα του λειτουργικού συστήματος στα Windows 7 και Windows 8.

Για τα Windows 8

Από προεπιλογή, το .NET Framework 3.5 είναι απενεργοποιημένο στα Windows 8. Για να το ενεργοποιήσετε, ακολουθήστε τα εξής βήματα:
  1. Στην οθόνη έναρξης, πληκτρολογήστε τα πρώτα γράμματα τουΠίνακας ελέγχου, και στη συνέχεια επιλέξτεΠίνακας ελέγχουαπό τη λίστα των εφαρμογών.
  2. ΣτοΠίνακας ελέγχου, επιλέξτεΠρογράμματα. (Ή επιλέξτεΠρογράμματα και δυνατότητεςΕάν δεν χρησιμοποιείτε την προβολή κατηγοριών προεπιλογή.)
  3. ΣτοΠρογράμματα και δυνατότητες, επιλέξτεΕνεργοποίηση ή απενεργοποίηση των δυνατοτήτων των WindowsΓια να ανοίξετε τοΔυνατότητες των Windowsπαράθυρο διαλόγου.
  4. ΣτοΔυνατότητες των Windows, επιλέξτε το.NET framework 3.5 (περιλαμβάνει .NET 2.0 και 3.0)το πλαίσιο ελέγχου και στη συνέχεια επιλέξτεΟΚ.

Για τα Windows 7

Από προεπιλογή, το .NET Framework 3.5 είναι ενεργοποιημένο στα Windows 7, επομένως αυτό το σφάλμα παρουσιάζεται μόνο εάν είχε προηγουμένως απενεργοποιηθεί η δυνατότητα. Για να ενεργοποιήσετε ξανά το .NET Framework 3.5, ακολουθήστε τα εξής βήματα:
  1. Από το μενού "Έναρξη", επιλέξτεΠίνακας ελέγχου.
  2. ΣτοΠίνακας ελέγχου, επιλέξτεΠρογράμματα. (Ή επιλέξτεΠρογράμματα και δυνατότητεςΕάν δεν χρησιμοποιείτε την προβολή κατηγοριών προεπιλογή.)
  3. ΣτοΠρογράμματα και δυνατότητες, επιλέξτεΕνεργοποίηση ή απενεργοποίηση των δυνατοτήτων των WindowsΓια να ανοίξετε τοΔυνατότητες των Windowsπαράθυρο διαλόγου.
  4. ΣτοΔυνατότητες των Windows, επιλέξτε τοMicrosoft .NET Framework 3.5.1το πλαίσιο ελέγχου και στη συνέχεια επιλέξτεΟΚ.

Αποποίηση ευθυνών λύση άλλου κατασκευαστή

Οι πληροφορίες και η λύση σε αυτό το έγγραφο αντιπροσωπεύουν την τρέχουσα άποψη της Microsoft Corporation για αυτά τα θέματα κατά την ημερομηνία της δημοσίευσης. Αυτή η λύση είναι διαθέσιμη μέσω της Microsoft ή μια υπηρεσία παροχής τρίτων κατασκευαστών. Δεν συνιστάται ειδικά κάθε τρίτο πάροχο ή λύση άλλου κατασκευαστή η οποία ενδέχεται να περιγράφεται σε αυτό το άρθρο. Ενδέχεται να υπάρξουν άλλες τρίτες υπηρεσίες παροχής ή λύσεις τρίτων κατασκευαστών που περιγράφει αυτό το άρθρο. Επειδή σας πρέπει να ανταποκρίνεται στις μεταβαλλόμενες συνθήκες της αγοράς, οι πληροφορίες αυτές πρέπει να δεν ερμηνεύεται ως δέσμευση από τη Microsoft. Εμείς δεν μπορεί να εγγυηθεί ή την ακρίβεια των πληροφοριών ή για οποιαδήποτε λύση που παρουσιάζεται από τη Microsoft ή από οποιονδήποτε τρίτο πάροχο που αναφέρθηκαν.

Η Microsoft δεν παρέχει καμία εγγύηση και αποκλείει όλες τις παρατηρήσεις, ΟΡΩΝ και ΕΓΓΥΗΣΕΩΝ ρητή, σιωπηρή ή εκ του νόμου. Αυτά περιλαμβάνουν αλλά δεν περιορίζονται σε παραστάσεις, εγγυήσεις ή συνθήκες τίτλων, μη παραποίηση/απομίμηση, ικανοποιητικής κατάστασης, εμπορευσιμότητας και καταλληλότητας για συγκεκριμένο σκοπό, όσον αφορά οποιαδήποτε υπηρεσία, λύση, προϊόν, ή άλλο υλικό ή πληροφορίες. Σε καμία περίπτωση Microsoft θα ευθύνη για οποιαδήποτε λύση άλλου κατασκευαστή που αναφέρει το παρόν άρθρο.

Σφάλμα: "Δεν ήταν δυνατή η εκκίνηση αυτής της εφαρμογής"
Μήνυμα σφάλματος
Δεν ήταν δυνατή η εκκίνηση αυτής της εφαρμογής.
Αιτία
Η εφαρμογή δεν έχει ρυθμιστεί έτσι ώστε να δίνει τη δυνατότητα να προσδιορίσετε την κατάλληλη έκδοση του χρόνου εκτέλεσης .NET Framework. Ο αντίστοιχος κωδικός συμβατότητας προγράμματος είναι SHIM_NOVERSION_FOUND.
Προτεινόμενη αντιμετώπιση
Δεν μπορείτε να διορθώσετε το πρόβλημα ρύθμισης παραμέτρων μόνοι σας. Επικοινωνήστε με τον προμηθευτή της εφαρμογής για να επιλύσετε αυτό το ζήτημα.
Σφάλμα: "Βασίζεται σε μια έκδοση του .NET Framework που δεν υποστηρίζεται σε αυτήν τη συσκευή"
Μήνυμα σφάλματος
Δεν ήταν δυνατή η εκκίνηση αυτής της εφαρμογής. Βασίζεται σε μια έκδοση του .NET Framework που δεν υποστηρίζεται σε αυτήν τη συσκευή.
Αιτία
Αυτό το ζήτημα παρουσιάζεται επειδή η εφαρμογή δεν δημιουργήθηκε για να εκτελεστεί σε αυτήν τη συσκευή. Για παράδειγμα, ίσως προσπαθείτε να εκτελέσετε μια εφαρμογή που έχει δημιουργηθεί για επεξεργαστή Intel σε μια συσκευή που χρησιμοποιεί έναν επεξεργαστή ARM. Ο αντίστοιχος κωδικός συμβατότητας προγράμματος είναι SHIM_UNSUPPORTED_PLATFORM.
Προτεινόμενη αντιμετώπιση
Δεν μπορείτε να διορθώσετε το πρόβλημα ρύθμισης παραμέτρων μόνοι σας. Επικοινωνήστε με τον προμηθευτή της εφαρμογής για να εγκαταστήσετε την κατάλληλη έκδοση της εφαρμογής.
Σχετικά με μηνύματα λάθους συμβατότητας εφαρμογών
Κατά την εκκίνηση μιας εφαρμογής του Microsoft .NET Framework, ένα πρόγραμμα προσαρμογής συμβατότητας καθορίζει ποια έκδοση από του χρόνου εκτέλεσης κοινής γλώσσας (CLR) θα φορτωθεί, την φορτώνει και ξεκινά την εφαρμογή. Εάν η προσαρμογή συμβατότητας αντιμετωπίζει ένα σφάλμα (για παράδειγμα, εάν δεν μπορεί να εντοπίσει μια συμβατή έκδοση του .NET Framework στον υπολογιστή), εμφανίζεται ένα μήνυμα σφάλματος με οδηγίες. Αυτό το άρθρο παρέχει πληροφορίες σχετικά με τους κωδικούς σφάλματος, SHIM_NOVERSION_FOUND, SHIM_GOTO_CONTROLPANELκαι SHIM_UNSUPPORTED_PLATFORM.

Για περισσότερες πληροφορίες σχετικά με τα σφάλματα προετοιμασίας του .NET Framework, μεταβείτε στην ακόλουθη ιστοσελίδα MSDN:

Προειδοποίηση: Αυτό το άρθρο έχει μεταφραστεί αυτόματα

Ιδιότητες

Αναγνωριστικό άρθρου: 2715633 - Τελευταία αναθεώρηση: 10/02/2016 05:13:00 - Αναθεώρηση: 15.0

Microsoft .NET Framework 4.5

  • kbquadranttechsupp kbconsumer kbsurveynew kbtshoot kbexpertiseinter kbmt KB2715633 KbMtel
Σχόλια