Το σφάλμα "Σφάλμα διακομιστή στην εφαρμογή '/'" κατά την προσπάθειά σας να εισέλθετε σε μια εφαρμογή που έχει οριστεί για διεπιχειρησιακό AD Azure

ΣΗΜΑΝΤΙΚΟ: Αυτό το άρθρο έχει μεταφραστεί χρησιμοποιώντας λογισμικό μηχανικής μετάφρασης της Microsoft και μπορείτε να το διορθώσετε χρησιμοποιώντας την τεχνολογία Community Translation Framework (CTF) (Πλαίσιο μετάφρασης κοινότητας). Η Microsoft παρέχει μηχανική μετάφραση, επεξεργασία μετά τη μηχανική μετάφραση από την κοινότητα και άρθρα μεταφρασμένα από επαγγελματίες προκειμένου να έχετε πρόσβαση σε όλα τα άρθρα της Γνωσιακής βάσης σε πολλές γλώσσες. Τα άρθρα μηχανικής μετάφρασης και αυτά που επεξεργάζονται ύστερα από μηχανική μετάφραση ενδέχεται να περιέχουν σφάλματα στο λεξιλόγιο, στη σύνταξη ή/και στη γραμματική. Η Microsoft δεν φέρει καμία ευθύνη για τυχόν ανακρίβειες, σφάλματα ή ζημίες που προκύψουν λόγω τυχόν παρερμηνειών στη μετάφραση του περιεχομένου ή χρήσης του από τους πελάτες μας. Για περισσότερες πληροφορίες σχετικά με το CTF, μεταβείτε στην τοποθεσία http://support.microsoft.com/gp/machine-translation-corrections/el.

Η αγγλική έκδοση αυτού του άρθρου είναι η ακόλουθη: 3092588
Συμπτώματα
Όταν προσπαθείτε να εισέλθετε σε μια εφαρμογή που έχει οριστεί για την εταιρεία Microsoft Azure Active Directory (AD) σε καταναλωτές (B2C), λαμβάνετε το ακόλουθο μήνυμα λάθους:

Σφάλμα διακομιστή στην εφαρμογή '/'

Κωδικός κατάστασης της απόκρισης δεν υποδηλώνει επιτυχία: 404 (δεν βρέθηκε)

Περιγραφή: Παρουσιάστηκε μια ανεπίλυτη εξαίρεση κατά την εκτέλεση της τρέχουσας αίτησης web. Ελέγξτε την ιχνηλάτηση στοίβας για περισσότερες πληροφορίες σχετικά με το σφάλμα και την προέλευσή του στον κώδικα.

Λεπτομέρειες της εξαίρεσης: System.Net.Http.HttpRequestException: κωδικός κατάστασης της απόκρισης δεν υποδηλώνει επιτυχία: 404 (δεν βρέθηκε)

Σφάλμα προέλευσης: Παρουσιάστηκε μια ανεπίλυτη εξαίρεση κατά την εκτέλεση της τρέχουσας αίτησης web. Πληροφορίες σχετικά με την προέλευση και τις θέσεις της εξαίρεσης μπορούν να προσδιοριστούν με τη χρήση της ιχνηλάτησης στοίβας εξαιρέσεων παρακάτω.

Ανίχνευση στοίβας:


[IOException: δεν είναι δυνατή η αντιγραφή παραστατικού από: https://login.microsoftonline.com/contoso.onmicrosoft.com/.well-known/openid-configuration?p=Όνομα_πολιτικής]
Αιτία
Το όνομα της πολιτικής εγγραφής ενδέχεται να λείπουν ή είναι εσφαλμένες στο αρχείο Web.config για την εφαρμογή.
Προτεινόμενη αντιμετώπιση
Για να διορθώσετε αυτό το ζήτημα, ακολουθήστε τα εξής βήματα:
  1. Ανοίξτε το αρχείο Web.config για την εφαρμογή.
  2. Στο αρχείο Web.config, βεβαιωθείτε ότι υπάρχει το κλειδί app "ida: SignUpPolicyId".
  3. Αντικαταστήστε την τιμή του κλειδιού app με το όνομα της πολιτικής εγγραφής που δώσατε στην πύλη διαχείρισης του Azure διεπιχειρησιακό AD.

    Το τροποποιημένο τμήμα του αρχείου θα έχει την εξής μορφή:
    <appSettings></appSettings>

    <add key="ida:SignUpPolicyId" value=" key="ida:SignUpPolicyId" value=""></add key="ida:SignUpPolicyId" value=">B2C_Signup_Policy_Name">

Περισσότερες πληροφορίες

Προειδοποίηση: Αυτό το άρθρο έχει μεταφραστεί αυτόματα

Ιδιότητες

Αναγνωριστικό άρθρου: 3092588 - Τελευταία αναθεώρηση: 09/17/2015 17:12:00 - Αναθεώρηση: 1.0

Microsoft Azure Active Directory

  • kbexpertiseadvanced kbsurveynew kbtshoot kbmt KB3092588 KbMtel
Σχόλια