Δημιουργία ή εκτέλεση μακροεντολής

Στο Word, μπορείτε να αυτοματοποιήσετε τις εργασίες που χρησιμοποιούνται συχνά, δημιουργώντας και εκτελώντας μακροεντολές. Μια μακροεντολή είναι μια σειρά από εντολές και οδηγίες που ομαδοποιείτε ως μεμονωμένη εντολή για την αυτόματη εκτέλεση μιας εργασίας.

Για να εξοικονομήσετε χρόνο στις εργασίες που εκτελείτε συχνά, συγκεντρώστε τα απαραίτητα βήματα σε μια μακροεντολή. Πρώτα, καταγράφετε τη μακροεντολή. Στη συνέχεια, μπορείτε να εκτελέσετε τη μακροεντολή κάνοντας κλικ σε ένα κουμπί της γραμμής εργαλείων γρήγορης πρόσβασης ή πατώντας ένα συνδυασμό πλήκτρων. Εξαρτάται από τον τρόπο με τον οποίο θα τη δημιουργήσετε.

  1. Κάντε κλικ στις επιλογές Προβολή > Μακροεντολές > Καταγραφή μακροεντολής.

    Εντολή "Καταγραφή μακροεντολής"

  2. Πληκτρολογήστε ένα όνομα για τη μακροεντολή.

    Πλαίσιο ονόματος μακροεντολής

  3. Για να χρησιμοποιήσετε αυτήν τη μακροεντολή σε οποιαδήποτε νέα έγγραφα δημιουργήσετε, βεβαιωθείτε ότι στο πλαίσιο Αποθήκευση μακροεντολής σε αναγράφεται η ένδειξη Όλα τα έγγραφα (Normal.dotm).

    Πλαίσιο για επιλογή θέσης αποθήκευσης μιας μακροεντολής

  4. Για να εκτελέσετε τη μακροεντολή σας όταν κάνετε κλικ σε ένα κουμπί, κάντε κλικ στο στοιχείο Κουμπί.

    Κάντε κλικ για να αντιστοιχίσετε τη μακροεντολή σε ένα κουμπί

  5. Κάντε κλικ στη νέα μακροεντολή (το όνομά της είναι κάπως έτσι: Normal.NewMacros.<το όνομα της μακροεντολής σας>) και κάντε κλικ στην επιλογή Προσθήκη.

    Η μακροεντολή και το κουμπί "Προσθήκη"

  6. Κάντε κλικ στο κουμπί Τροποποίηση.

    Κουμπί "Τροποποίηση" στο πλαίσιο "Προσαρμογή της γραμμής εργαλείων γρήγορης πρόσβασης"

  7. Επιλέξτε μια εικόνα κουμπιού, πληκτρολογήστε το όνομα που θέλετε και κάντε κλικ στο κουμπί OK στα δύο παράθυρα διαλόγου.

    Επιλογές κουμπιού στο πλαίσιο "Τροποποίηση κουμπιού"

  8. Τώρα ήρθε η ώρα να καταγράψετε τα βήματα. Κάντε κλικ στις εντολές ή πατήστε τα πλήκτρα για κάθε βήμα στην εργασία. Το Word καταγράφει τα κλικ και τα πατήματα πλήκτρων.

    Σημείωση: Χρησιμοποιήστε το πληκτρολόγιο για να επιλέξετε κείμενο ενώ καταγράφετε τη μακροεντολή σας. Οι μακροεντολές δεν καταγράφουν επιλογές που γίνονται με το ποντίκι.

  9. Για να σταματήσετε την καταγραφή, κάντε κλικ στις επιλογές Προβολή > Μακροεντολές > Διακοπή καταγραφής.

    Εντολή "Διακοπή καταγραφής"

Το κουμπί για τη μακροεντολή σας εμφανίζεται στη γραμμή εργαλείων Γρήγορης πρόσβασης.

Κουμπί μακροεντολής στη γραμμή εργαλείων Γρήγορης πρόσβασης

Για να εκτελέσετε τη μακροεντολή, κάντε κλικ στο κουμπί.

  1. Κάντε κλικ στις επιλογές Προβολή > Μακροεντολές > Καταγραφή μακροεντολής.

    Εντολή "Καταγραφή μακροεντολής"

  2. Πληκτρολογήστε ένα όνομα για τη μακροεντολή.

    Πλαίσιο ονόματος μακροεντολής

  3. Για να χρησιμοποιήσετε αυτήν τη μακροεντολή σε οποιαδήποτε νέα έγγραφα δημιουργήσετε, βεβαιωθείτε ότι στο πλαίσιο Αποθήκευση μακροεντολής σε αναγράφεται η ένδειξη Όλα τα έγγραφα (Normal.dotm).

    Πλαίσιο για επιλογή θέσης αποθήκευσης μιας μακροεντολής

  4. Για να εκτελείτε τη μακροεντολή σας όταν πατάτε μια συντόμευση πληκτρολογίου, κάντε κλικ στην επιλογή Πληκτρολόγιο.

    Κάντε κλικ για να αντιστοιχίσετε τη μακροεντολή σε μια συντόμευση πληκτρολογίου

  5. Πληκτρολογήστε ένα συνδυασμό πλήκτρων στο πλαίσιο Νέο πλήκτρο συντόμευσης.

  6. Ελέγξτε αν αυτός ο συνδυασμός έχει ήδη αντιστοιχιστεί σε κάτι άλλο. Αν έχει ήδη αντιστοιχιστεί, δοκιμάστε ένα διαφορετικό συνδυασμό.

  7. Για να χρησιμοποιείτε αυτήν τη συντόμευση πληκτρολογίου σε κάθε νέο έγγραφο που θα δημιουργήσετε, βεβαιωθείτε ότι στο πλαίσιο Αποθήκευση αλλαγών σε αναγράφεται η ένδειξη Normal.dotm.

  8. Κάντε κλικ στο στοιχείο Αντιστοίχιση.

  9. Τώρα ήρθε η ώρα να καταγράψετε τα βήματα. Κάντε κλικ στις εντολές ή πατήστε τα πλήκτρα για κάθε βήμα στην εργασία. Το Word καταγράφει τα κλικ και τα πατήματα πλήκτρων.

    Σημείωση: Χρησιμοποιήστε το πληκτρολόγιο για να επιλέξετε κείμενο ενώ καταγράφετε τη μακροεντολή σας. Οι μακροεντολές δεν καταγράφουν επιλογές που γίνονται με το ποντίκι.

  10. Για να σταματήσετε την καταγραφή, κάντε κλικ στις επιλογές Προβολή > Μακροεντολές > Διακοπή καταγραφής.

    Εντολή "Διακοπή καταγραφής"

Για να εκτελέσετε τη μακροεντολή, πατήστε τα πλήκτρα συντόμευσης πληκτρολογίου.

Για να εκτελέσετε μια μακροεντολή, κάντε κλικ στο κουμπί στη γραμμή εργαλείων γρήγορης πρόσβασης, πατήστε τη συντόμευση πληκτρολογίου, ή μπορείτε να εκτελέσετε τη μακροεντολή από τη λίστα Μακροεντολές.

  1. Κάντε κλικ στα στοιχεία Προβολή > Μακροεντολές > Προβολή μακροεντολών.

    Εντολή "Προβολή μακροεντολών"

  2. Στη λίστα στην περιοχή Όνομα μακροεντολής, κάντε κλικ στη μακροεντολή που θέλετε να εκτελέσετε.

  3. Κάντε κλικ στο κουμπί Εκτέλεση.

Για να κάνετε μια μακροεντολή από ένα έγγραφο διαθέσιμη σε όλα τα νέα έγγραφα, προσθέστε τη στο πρότυπο Normal.dotm.

  1. Ανοίξτε το βιβλίο εργασίας που περιέχει τη μακροεντολή.

  2. Κάντε κλικ στα στοιχεία Προβολή > Μακροεντολές > Προβολή μακροεντολών.

    Εντολή "Προβολή μακροεντολών"

  3. Κάντε κλικ στην επιλογή Οργάνωση.

    Κουμπί "Οργάνωση" στο πλαίσιο "Προβολή μακροεντολών"

  4. Κάντε κλικ στη μακροεντολή που θέλετε να προσθέσετε στο πρότυπο Normal.dotm και μετά κάντε κλικ στην επιλογή Αντιγραφή.

  1. Κάντε κλικ στα στοιχεία Αρχείο > Επιλογές > Προσαρμογή κορδέλας.

  2. Στην περιοχή Επιλογή εντολών από, κάντε κλικ στο στοιχείο Μακροεντολές.

  3. Κάντε κλικ στη μακροεντολή που θέλετε.

  4. Στην περιοχή Προσαρμογή της κορδέλας, κάντε κλικ στην καρτέλα και προσαρμόστε την ομάδα όπου θέλετε να προσθέσετε τη μακροεντολή.

Αν δεν διαθέτετε προσαρμοσμένη ομάδα, κάντε κλικ στο στοιχείο Νέα ομάδα. Στη συνέχεια, κάντε κλικ στην επιλογή Μετονομασία και πληκτρολογήστε ένα όνομα για την προσαρμοσμένη ομάδα σας.

  1. Κάντε κλικ στο κουμπί Προσθήκη.

  2. Κάντε κλικ στην επιλογή Μετονομασία για να επιλέξετε μια εικόνα για τη μακροεντολή και πληκτρολογήστε το όνομα που θέλετε.

  3. Κάντε κλικ δύο φορές στο κουμπί OK.

  1. Στην καρτέλα προγραμματιστής , στην ομάδα Κώδικας , κάντε κλικ στην επιλογή μακροεντολές.

  2. Στο πλαίσιο Όνομα μακροεντολής, πληκτρολογήστε ένα όνομα για τη μακροεντολή.

    Σημείωση: Εάν εκχωρήσετε μια νέα μακροεντολή με το ίδιο όνομα με μια ενσωματωμένη μακροεντολή στο Word, οι νέες ενέργειες μακροεντολής θα αντικαταστήσουν την ενσωματωμένη μακροεντολή. Για να προβάλετε μια λίστα με τις ενσωματωμένες μακροεντολές, κάντε κλικ στην επιλογή εντολές του Word στη λίστα μακροεντολές σε .

  3. Στη λίστα μακροεντολές σε , κάντε κλικ στο πρότυπο ή το έγγραφο στο οποίο θέλετε να αποθηκεύσετε τη μακροεντολή.

    Για να κάνετε τη μακροεντολή σας διαθέσιμη σε όλα τα έγγραφα, βεβαιωθείτε ότι έχετε κάνει κλικ στην επιλογή Normal. dotm.

  4. Κάντε κλικ στην επιλογή Δημιουργία για να ανοίξετε την επεξεργασία της Visual Basic.

Αφού ανοίξετε την επεξεργασία της Visual Basic, ίσως θέλετε περισσότερες πληροφορίες σχετικά με την εργασία με τη Visual Basic for Applications. Για περισσότερες πληροφορίες, κάντε κλικ στην επιλογή Βοήθεια για τη Microsoft Visual Basic στο μενού Βοήθεια ή πατήστε το πλήκτρο F1.

Μπορείτε να εγγράψετε μια ακολουθία ενεργειών ή μπορείτε να συντάξετε μια μακροεντολή από την αρχή, πληκτρολογώντας κώδικα της Visual Basic for Applications στο Επεξεργασία Visual Basic.

Σημείωση: Για να εργαστείτε με μακροεντολές στο Office Word 2007, πρέπει να εμφανίσετε την καρτέλα προγραμματιστής .

  1. Κάντε κλικ στο Κουμπί του Microsoft Office Εικόνα κουμπιού του Office και στη συνέχεια κάντε κλικ στο στοιχείο Επιλογές του Word.

  2. Κάντε κλικ στην επιλογή Δημοφιλή.

  3. Στην περιοχή κορυφαίες επιλογές για εργασία με το Word, επιλέξτε το πλαίσιο ελέγχου Εμφάνιση της καρτέλας "Προγραμματιστής" στην κορδέλα .

    Σημείωση: Η Κορδέλα είναι στοιχείο του Περιβάλλοντος εργασίας χρήστη Fluent του Microsoft Office.

  1. Στην καρτέλα Προγραμματιστής, στην ομάδα Κώδικας, κάντε κλικ στην εντολή Καταγραφή μακροεντολής.

    Ομάδα "Κώδικας" στην καρτέλα "Προγραμματιστής"
  2. Στο πλαίσιο Όνομα μακροεντολής, πληκτρολογήστε ένα όνομα για τη μακροεντολή.

    Σημείωση: Εάν εκχωρήσετε μια νέα μακροεντολή με το ίδιο όνομα με μια ενσωματωμένη μακροεντολή στο Office Word 2007, οι νέες ενέργειες μακροεντολής θα αντικαταστήσουν την ενσωματωμένη μακροεντολή. Για να προβάλετε μια λίστα με τις ενσωματωμένες μακροεντολές, στην καρτέλα προγραμματιστής , στην ομάδα Κώδικας , κάντε κλικ στην επιλογή μακροεντολές. Στη λίστα μακροεντολές σε , κάντε κλικ στην επιλογή εντολές του Word.

  3. Στο πλαίσιο Αποθήκευση μακροεντολής σε , κάντε κλικ στο πρότυπο ή στο έγγραφο στο οποίο θέλετε να αποθηκεύσετε τη μακροεντολή.

    Σημαντικό: Για να κάνετε τη μακροεντολή σας διαθέσιμη σε όλα τα έγγραφα, βεβαιωθείτε ότι έχετε κάνει κλικ στην επιλογή Normal. dotm.

  4. Στο πλαίσιο Περιγραφή , πληκτρολογήστε μια περιγραφή της μακροεντολής.

  5. Κάντε ένα από τα εξής:

    • Έναρξη εγγραφής    Για να ξεκινήσετε την καταγραφή της μακροεντολής χωρίς να την αντιστοιχίσετε σε ένα κουμπί στη γραμμή εργαλείων γρήγορης πρόσβασης ή σε ένα πλήκτρο συντόμευσης, κάντε κλικ στο κουμπί OK.

    • Δημιουργία κουμπιού    Για να αντιστοιχίσετε τη μακροεντολή σε ένα κουμπί στη γραμμή εργαλείων γρήγορης πρόσβασης, κάντε τα εξής:

      1. Κάντε κλικ στο κουμπί.

      2. Στην περιοχή Προσαρμογή γραμμής εργαλείων γρήγορης πρόσβασης, επιλέξτε το έγγραφο (ή όλα τα έγγραφα) για το οποίο θέλετε να προσθέσετε τη μακροεντολή στη γραμμή εργαλείων γρήγορης πρόσβασης.

        Σημαντικό: Για να κάνετε τη μακροεντολή σας διαθέσιμη σε όλα τα έγγραφα, βεβαιωθείτε ότι έχετε κάνει κλικ στην επιλογή Normal. dotm.

      3. Στην περιοχή επιλογή εντολών από το παράθυρο διαλόγου, κάντε κλικ στη μακροεντολή που καταγράφετε και, στη συνέχεια, κάντε κλικ στην επιλογή Προσθήκη.

      4. Για να προσαρμόσετε το κουμπί, κάντε κλικ στην επιλογή Τροποποίηση.

      5. Στην περιοχή σύμβολο, κάντε κλικ στο σύμβολο που θέλετε να χρησιμοποιήσετε για το κουμπί σας.

      6. Στο πλαίσιο εμφανιζόμενο όνομα , πληκτρολογήστε το όνομα της μακροεντολής που θέλετε να εμφανίσετε.

      7. Κάντε κλικ στο κουμπί OK δύο φορές για να ξεκινήσετε την καταγραφή της μακροεντολής.

        Το σύμβολο που επιλέγετε εμφανίζεται στη γραμμή εργαλείων γρήγορης πρόσβασης. Το όνομα που πληκτρολογείτε εμφανίζεται όταν τοποθετείτε το δείκτη του ποντικιού στο σύμβολο.

    • Εκχώρηση συντόμευσης πληκτρολογίου    Για να αντιστοιχίσετε τη μακροεντολή σε μια συντόμευση πληκτρολογίου, κάντε τα εξής:

      1. Κάντε κλικ στην επιλογή Πληκτρολόγιο.

      2. Στο πλαίσιο εντολές , κάντε κλικ στη μακροεντολή που καταγράφετε.

      3. Στο πλαίσιο πάτημα νέου πλήκτρου συντόμευσης , πληκτρολογήστε την ακολουθία πλήκτρων που θέλετε και, στη συνέχεια, κάντε κλικ στην επιλογή εκχώρηση.

      4. Κάντε κλικ στην επιλογή Κλείσιμο για να ξεκινήσετε την καταγραφή της μακροεντολής.

  6. Εκτελέστε τις ενέργειες που θέλετε να συμπεριλάβετε στη μακροεντολή.

    Σημείωση: Όταν καταγράφετε μια μακροεντολή, μπορείτε να χρησιμοποιήσετε το ποντίκι για να κάνετε κλικ σε εντολές και επιλογές, αλλά όχι για να επιλέξετε κείμενο. Πρέπει να χρησιμοποιήσετε το πληκτρολόγιο για να επιλέξετε κείμενο. Για περισσότερες πληροφορίες σχετικά με την επιλογή κειμένου με χρήση του πληκτρολογίου, ανατρέξτε στο θέμα επιλογή κειμένου.

  7. Για να διακόψετε την καταγραφή των ενεργειών σας, κάντε κλικ στην επιλογή Διακοπή εγγραφής στην ομάδα Κώδικας .

Αλλαγή της συντόμευσης πληκτρολογίου για μια μακροεντολή

  1. Κάντε κλικ στο Κουμπί του Microsoft Office Εικόνα κουμπιού του Office και στη συνέχεια κάντε κλικ στο στοιχείο Επιλογές του Word.

  2. Κάντε κλικ στην επιλογή Προσαρμογή.

  3. Δίπλα στις συντομεύσεις πληκτρολογίου, κάντε κλικ στην επιλογή Προσαρμογή.

  4. Στη λίστα κατηγορίες , κάντε κλικ στην επιλογή μακροεντολές.

  5. Στη λίστα μακροεντολές , κάντε κλικ στη μακροεντολή που θέλετε να αλλάξετε.

  6. Στο πλαίσιο πάτημα νέου πλήκτρου συντόμευσης , πληκτρολογήστε το συνδυασμό πλήκτρων που θέλετε να επιλέξετε.

  7. Επιλέξτε το πλαίσιο Τρέχοντα πλήκτρα για να βεβαιωθείτε ότι δεν εκχωρείτε ένα συνδυασμό πλήκτρων που χρησιμοποιείτε ήδη για να εκτελείτε μια διαφορετική εργασία.

  8. Στη λίστα Αποθήκευση αλλαγών σε , κάντε κλικ στην επιλογή που ταιριάζει στο σημείο όπου θέλετε να εκτελέσετε τη μακροεντολή σας.

    Σημαντικό: Για να κάνετε τη μακροεντολή σας διαθέσιμη σε όλα τα έγγραφα, βεβαιωθείτε ότι έχετε κάνει κλικ στην επιλογή Normal. dotm.

  9. Κάντε κλικ στο κουμπί Κλείσιμο.

  1. Στην καρτέλα προγραμματιστής , στην ομάδα Κώδικας , κάντε κλικ στην επιλογή μακροεντολές.

    Ομάδα "Κώδικας" στην καρτέλα "Προγραμματιστής"

  2. Στη λίστα στην περιοχή όνομα μακροεντολής, κάντε κλικ στη μακροεντολή που θέλετε να εκτελέσετε.

  3. Κάντε κλικ στο κουμπί Εκτέλεση.

  1. Στην καρτέλα προγραμματιστής , στην ομάδα Κώδικας , κάντε κλικ στην επιλογή μακροεντολές.

    Ομάδα "Κώδικας" στην καρτέλα "Προγραμματιστής"

  2. Στο πλαίσιο Όνομα μακροεντολής, πληκτρολογήστε ένα όνομα για τη μακροεντολή.

    Σημείωση: Εάν εκχωρήσετε μια νέα μακροεντολή με το ίδιο όνομα με μια ενσωματωμένη μακροεντολή στο Office Word 2007, οι νέες ενέργειες μακροεντολής θα αντικαταστήσουν την ενσωματωμένη μακροεντολή. Για να προβάλετε μια λίστα με τις ενσωματωμένες μακροεντολές, κάντε κλικ στην επιλογή εντολές του Word στη λίστα μακροεντολές σε .

  3. Στη λίστα μακροεντολές σε , κάντε κλικ στο πρότυπο ή στο έγγραφο στο οποίο θέλετε να αποθηκεύσετε τη μακροεντολή.

    Για να κάνετε τη μακροεντολή σας διαθέσιμη σε όλα τα έγγραφα, βεβαιωθείτε ότι έχετε κάνει κλικ στην επιλογή Normal. dotm.

  4. Κάντε κλικ στην επιλογή Δημιουργία για να ανοίξετε την επεξεργασία της Visual Basic.

Αφού ανοίξετε την επεξεργασία της Visual Basic, ίσως θέλετε περισσότερες πληροφορίες σχετικά με την εργασία με τη Visual Basic for Applications. Για περισσότερες πληροφορίες, κάντε κλικ στην επιλογή Βοήθεια για τη Microsoft Visual Basic στο μενού Βοήθεια ή πατήστε το πλήκτρο F1.

Για να κάνετε γρήγορη εργασία των εργασιών που κάνετε συχνά, στην έκδοση υπολογιστή του Word, μπορείτε να συνδυάσετε τα βήματα σε μακροεντολές που εκτελούνται με ένα μόνο κλικ. Στο Word για το web, πρέπει να ακολουθήσετε αυτές τις εργασίες με μη αυτόματο τρόπο.

Εάν έχετε το Word, κάντε πρώτα κλικ στο κουμπί Άνοιγμα στο Word για να ανοίξετε το έγγραφό σας στο Word.

Εικόνα της εντολής "Άνοιγμα στο Word" στο Word Online

Στη συνέχεια, ακολουθήστε τις οδηγίες για την έκδοση υπολογιστή του Word.

Όταν εκτελέσετε τη μακροεντολή στο Word και αποθηκεύσετε το έγγραφο, θα δείτε τα αποτελέσματα της μακροεντολής όταν ανοίξετε ξανά το έγγραφο στο Word για το web.

Σημείωση:  Αυτή η σελίδα έχει μεταφραστεί μέσω αυτοματοποιημένης διαδικασίας και ενδεχομένως να περιέχει γραμματικά λάθη και ανακρίβειες. Ο σκοπός μας είναι αυτό το περιεχόμενο να σας φανεί χρήσιμο. Μπορείτε να μας πείτε εάν σας βοήθησαν αυτές οι πληροφορίες; Εδώ θα βρείτε το άρθρο στα Αγγλικά για να το συμβουλεύεστε.

Αναπτύξτε τις δεξιότητές σας στο Office
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×