Symptoms
Assume that you deploy a new Microsoft Exchange Server 2016 environment in a computer that has an additional drive such as "D:". In this situation, you may find that the D:\AdvancedDataGovernanceLogs log file is created on the D drive instead of the default log folder C:\Program Files\Microsoft\Exchange Server\V15\Logging.
Cause
This issue occurs because the logs' file path is not set correctly by Exchange Server. In addition, two Transports agents, Supervisory Review agent and Retention Policy agent are enabled, which aren't applicable for Exchange Server 2016.
Resolution
To fix this issue, install Cumulative Update 11 for Exchange Server 2016 or a later cumulative update for Exchange Server 2016.
More information
After you apply cumulative update 11 or a later cumulative update for Exchange Server 2016, it's safe to delete the folder that's created on the D drive.
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
References
Learn about the terminology that Microsoft uses to describe software updates.