Beginning with Excel 2016 for Office 365 subscribers, The Data import and analysis options have been moved to their own Data section in the Excel Options dialog box. You can reach these options by selecting File > Options > Data. In earlier versions of Excel, the Data tab can be found by selecting File > Options > Advanced.

Data options have been moved from File > Options > Advanced section to a new tab called Data under File > Options.

Note: This feature is only available if you have an Office 365 subscription. If you are an Microsoft 365 subscriber, make sure you have the latest version of Office.

Data Options

  • Make changes to the default layout for Pivot Tables.

    You can choose from multiple default layout options for new PivotTables. For instance, you can choose to always create a new PivotTable in Tabular Form versus Compact, or turn off Autofit column widths on update.

  • Disable undo for large PivotTable refresh operations to reduce refresh time.

    If you choose to disable undo, you can select the number of rows as a threshold for when to disable it. The default is 300,000 rows.

  • Prefer the Excel Data Model when creating PivotTables, Query Tables and Data Connections.

    The Data Model integrates data from multiple tables, effectively building a relational data source inside an Excel workbook.

  • Disable undo for large Data Model operations.

    If you choose to disable undo, you can select the number of megabytes in file size as a threshold for when to disable it. The default is 8 Mb.

  • Enable Data Analysis add-ins: Power Pivot, Power View and 3D Maps.

    Enable Data Analysis add-ins here instead of through the Add-ins tab.

  • Disable automatic grouping of Date/Time columns in PivotTables.

    By default, date and time columns get grouped with + signs next to them. This setting will disable that default.

Show legacy data import wizards

Power Query (formerly Get & Transform) available through the Data tab on the ribbon, is superior in terms of data connectors and transformational capabilities compared to the legacy data import wizards. However, there may still be times when you want to use one of these wizards to import your data. For example, when you want to save the data source login credentials as part of your workbook.

Security    Saving credentials is not recommended and may lead to security and privacy issues or compromised data.

To enable the legacy data import wizards

  1. Select File > Options > Data.

  2. Select one or more wizards to enable access from the Excel ribbon.

    Get & Transform Restore Legacy options

  3. Close the workbook and then reopen it to see the activate the wizards

  4. Select Data  > Get Data > Legacy Wizards, and then select the wizard you want.

    Get & Transform Legacy Menu options

You can disable the wizards by repeating steps 1 through 3, but clearing the check boxes described in step 2. 

See Also

Power Query in Excel

Set PivotTable default layout options 

Create a Data Model in Excel

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Thank you for your feedback!

×