Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

Symptoms

Consider the following scenario:

  • You have a Windows Server 2008 R2 Service Pack 1 (SP1)-based multi-node failover cluster that has the Hyper-V server role installed.

  • You move the Cluster Shared Volumes (CSV) ownership from the failover cluster to a cluster node by using the Failover Cluster Management snap-in.

  • You log off from the failover cluster immediately after you move the CSV ownership, and then you receive the following message:

    Please wait for the System Event Notification Service...

In this scenario, the failover cluster crashes. Additionally, you receive a Stop error message that resembles the following:

STOP: 0x0000007E (parameter1, parameter2, parameter3, parameter4)

Notes

  • This Stop error describes a SYSTEM_THREAD_EXCEPTION_NOT_HANDLED issue.

  • The parameters in this Stop error message vary, depending on the configuration of the computer.

  • Not all "Stop 0x0000007E" errors are caused by this issue.

Cause

This issue occurs because the STATUS_NOTIFY_CLEANUP status that is returned by the CSV device for an I/O request packet (IRP) is not handled correctly by the system.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 SP1.For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information notes Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.1.760 1.22xxx

    Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Clusauthmgr.dll

6.1.7601.22400

37,376

23-Jul-2013

02:26

x64

Csvfilter.sys

6.1.7601.22400

156,160

23-Jul-2013

01:22

x64

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Clusauthmgr.dll

6.1.7601.22400

78,848

23-Jul-2013

01:31

IA-64

Csvfilter.sys

6.1.7601.22400

357,376

23-Jul-2013

00:49

IA-64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about the IRP_MN_NOTIFY_CHANGE_DIRECTORY request, go to the following Microsoft website:

General information about the IRP_MN_NOTIFY_CHANGE_DIRECTORY requestFor more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2

File property

Value

File name

Amd64_3fec23bb4a9254c00b5ac61f8bb3b93c_31bf3856ad364e35_6.1.7601.22400_none_ab7216596cb2e450.manifest

File version

Not applicable

File size

721

Date (UTC)

23-Jul-2013

Time (UTC)

09:47

Platform

Not applicable

File name

Amd64_microsoft-windows-f..uster-csvfiltercore_31bf3856ad364e35_6.1.7601.22400_none_6557590cbfd3e515.manifest

File version

Not applicable

File size

5,265

Date (UTC)

23-Jul-2013

Time (UTC)

02:56

Platform

Not applicable

Additional files for all supported IA-64-based versions of Windows Server 2008 R2

File property

Value

File name

Ia64_8ae8335f8561d4eda2d9b6f5b88adb58_31bf3856ad364e35_6.1.7601.22400_none_99550d0f34caef8d.manifest

File version

Not applicable

File size

719

Date (UTC)

23-Jul-2013

Time (UTC)

09:47

Platform

Not applicable

File name

Ia64_microsoft-windows-f..uster-csvfiltercore_31bf3856ad364e35_6.1.7601.22400_none_093a617f07747cdb.manifest

File version

Not applicable

File size

5,263

Date (UTC)

23-Jul-2013

Time (UTC)

01:58

Platform

Not applicable

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.