Symptoms

Assume that you use a script to access Active Directory Service Interfaces (ADSI) schema cache data from a computer that is running Windows 8 or Windows Server 2012. You run the script to perform Lightweight Directory Access Protocol (LDAP) queries against an OpenLDAP server. In this situation, the queries succeed and the data is returned to the client. However, you receive an error message that resembles the following:

0x8000500C, The directory datatype cannot be converted to/from a native DS datatype.

Cause

This issue occurs because the ADSI schema caching process requests an attribute that is not supported by the OpenLDAP server. In earlier versions of Windows, a failure to retrieve the attribute by using the caching process is ignored by Windows. However, Windows 8 and Windows Server 2012 optimize the schema download process to make retrieval of the attribute mandatory.

Resolution

A modification is made to the schema download process that no longer requires the presence of the attribute.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 8 or Windows Server 2012.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8 and Windows Server 2012 file information notesImportant Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.2.920 0.20 xxx

    Windows 8 and Windows Server 2012

    RTM

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8 and Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 8

File name

File version

File size

Date

Time

Platform

Adsldpc.dll

6.2.9200.20615

218,624

23-Jan-2013

23:29

x86

For all supported x64-based versions of Windows 8 and of Windows Server 2012

File name

File version

File size

Date

Time

Platform

Adsldpc.dll

6.2.9200.20615

238,592

23-Jan-2013

23:22

x64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows 8 and Windows Server 2012

Additional files for all supported x86-based versions of Windows 8

File name

X86_microsoft-windows-a..terface-ldapc-layer_31bf3856ad364e35_6.2.9200.20615_none_5cb3d06f50c80e15.manifest

File version

Not applicable

File size

6,203

Date (UTC)

24-Jan-2013

Time (UTC)

00:03

Platform

Not applicable

Additional files for all supported x64-based versions of Windows 8 and of Windows Server 2012

File name

Amd64_microsoft-windows-a..terface-ldapc-layer_31bf3856ad364e35_6.2.9200.20615_none_b8d26bf309257f4b.manifest

File version

Not applicable

File size

6,207

Date (UTC)

24-Jan-2013

Time (UTC)

02:06

Platform

Not applicable

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