Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

This article applies to Microsoft Dynamics AX for all regions.

Symptoms

Consider the following scenario in Microsoft Dynamics AX 2012:

  • You have the Public Sector model installed.

  • You try to create a Person-type customer from the customer details form in Accounts Receivable.

  • You specify the name of the customer.

  • You save the customer.

In this scenario, you receive the following error message:

Field 'Name' must be filled in.

Cause

This problem occurs because the value that you specified in the Name field is not saved correctly in the database if you have the Public Sector model installed. However, the Name field is a required field. Therefore, the new customer record cannot be saved.

Resolution

This problem is fixed in Cumulative Update 2 for Microsoft Dynamics AX 2012.
For more information about Cumulative Update 2 for Microsoft Dynamics AX 2012, click the following article number to view the article in the Microsoft Knowledge Base:

2606916 Cumulative Update 2 for Microsoft Dynamics AX 2012

Workaround

To work around this problem, create a new customer from the all customers list page in Accounts Receivable. To do this, follow these steps:

  • Click Accounts receivable, click Common, click Customer, and then click All customers.

  • In the Action pane, click Customer under New.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×