Symptom
Records shown for some entities but not others in lookup result.
For example, Queues entity is expected here but is missing.
Cause
Three possible causes
-
The entity is not enabled for UCI (Mobile Client)
-
The entity is not added to the UCI app.
-
For multi-entity lookup, if the entity is not added to the app, the lookup control will not retrieve the metadata for it, and thus will not show the tab or search record in it)
-
Common issue for Owner lookup that shows Users and Teams. Teams does not appear because user did not add it to the app.
-
-
This does not matter for single entity lookup control, because records should show up regardless if the entity has been added to the UCI app.
-
-
If the entity is a new custom entity and not displayed in Regarding Lookup, it might be because it is not configured as one of the activities.
Mitigation
Solution to each cause
-
Enable the entity. This setting is in entity designer. Some core entities like ConnectionRole are not user configurable and not supported in UCI, hence are not editable by design.
-
Add the entity to the UCI app.
For example, Add the Team entity to UCI App
-
Make sure the "Activity" box is checked in order for this entity to show up as one of the activities in Regarding Lookup.