PROBLEM
When you use In-Place eDiscovery & Hold in Exchange Online to search a large number of mailboxes, the search status is displayed as partially complete. Additionally, one or more mailboxes returns the following error message:
The server cannot service this request right now. Try again later.
When you search again, you receive the same error message but on different mailboxes.
CAUSE
An organization’s Exchange Online mailboxes may be distributed across multiple Office 365 servers. Some mailboxes may be homed on a server that's processing an unusual volume of higher-priority requests, such as requests that are related to mail flow. In this scenario, that server will be unable to respond to eDiscovery requests in a timely manner.
WORKAROUND
Use one of the following methods, as appropriate for your situation:
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If you're using eDiscovery search to establish an In-Place Hold or to export search results, this issue does not affect the actions that you're performing.
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To obtain search results for the mailboxes that didn’t succeed, create a new search query, and then add those mailboxes to it to search only those mailboxes.
STATUS
This is a known issue with In-Place eDiscovery search that may be corrected in a future update.